Dimension Pro 1.2 just stopped working

Max Output Level: -90 dBFS
  • Total Posts : 19
  • Joined: 2009/05/09 04:13:57
  • Status: offline
2009/05/09 04:24:07 (permalink)

Dimension Pro 1.2 just stopped working

I have been using Sonar for years without many problems when today something strange happened. I go an error saying that Dimension pro wasn't installed properly and to insert the original disk and reinstall. I did this and nothing worked. The program just quit working and it has worked fine since I first got Sonar Producer 8 last year. I am running vista 32 bit and as administrator and I did what tech support said do:

To completely wipe out and reinstall your Cakewalk program Dimension Pro try the following:

1) Completely un-install the Cakewalk program Dimension Pro from your computer. This is normally done from Start | Programs | Cakewalk. This will not remove any of your project files or audio data.

2) Next you will want to open the Run Command
a) In Windows XP this can be done by going to Start | Run
b) In Windows Vista this can be done by holding down the ‘windows’ key and pressing ‘r’

3) At the prompt type regedit and click [OK].

***Backup your Registry before making edits - you do this by clicking the File menu, Export Registry File.

4) Now delete the following Registry keys:

(note some of these keys may not be there depending on which part didn’t install properly)

HKEY_CURRENT_USER\Software\Cakewalk Music Software\Dimension Pro
HKEY_LOCAL_MACHINE\Software\Cakewalk Music Software\Dimension Pro
(with this key below the number may vary between windows systems it will always start with “S-1-5-21” and is second from the bottom in the list. )
HKEY_USERS\S-1-5-21-1124759246-1267421633-319577017-3205\Software\Cakewalk Music Software\Dimension Pro
*Please note that this will remove any effects presets and key bindings you may have made in Cakewalk. You can back these up separately if you like, using Options | Key Bindings,
Tools | SONAR Plug-in Manager, and Options | Colors. Hit F1 in these views for detailed instructions on how to do this.

5) Open the 'Run' command again.

6) Copy and paste the following into the prompt:


7) This will open your Application Data folder, right-click on the Cakewalk folder and choose ‘Delete’. (this will be reset on the next Sonar startup)

8) Navigate to the following directory and delete its contents:

C:\Program Files\Cakewalk\Dimension Pro
9) Open the 'Run' command again and type ‘msconfig’ Click [OK] and then click on the Startup tab at the upper right of the window that opens.

10) Uncheck all items listed, click [OK], then restart your computer. You can always recheck those items again at a later time.

11) Put the Dimension Pro disk in your drive now, and Cancel the auto start when it loads

12) Go to Start | Computer and right click on the DVD drive and select explore

13) Right Click on the “DimensionProSetup” file and select “Run as Adminstrator”

If everything went ok you can now install the updates

Download and run the 1.2 maintenance release

Download and extract the 1.2.215 VST patch
Copy the file in to both folders
C:\Program Files\Cakewalk\Dimension Pro
C:\Program Files\Cakewalk\Vstplugins\Dimension Pro

I have done this and nothing has worked HELP!!! Has anyone else had this problem. All my other instruments work fine.

2 Replies Related Threads

    Max Output Level: -31.5 dBFS
    • Total Posts : 4353
    • Joined: 2004/01/24 08:40:20
    • Location: Macomb, IL, USA
    • Status: offline
    RE: Dimension Pro 1.2 just stopped working 2009/05/09 07:48:04 (permalink)
    Launch SONAR using the "Run As Administrator" option then try using Dimension Pro as an instrument within SONAR. You could also temporarily disable Vista's UAC feature to see if that makes any difference for you.
    Max Output Level: -82 dBFS
    • Total Posts : 447
    • Joined: 2003/11/05 19:14:01
    • Status: offline
    Re: RE: Dimension Pro 1.2 just stopped working 2009/07/23 20:24:03 (permalink)
    Followed intructions above to the letter and this did not fix it for me.  I also tried various "solutions" posted here:  http://forum.cakewalk.com/tm.aspx?m=1636703&high=dimension+pro%2cproperly -- including the "dangerous" one that someone evidently learned about from a Cakewalk employee at NAMM, but that didn't do it either.  I have had UAC disabled since the day I bought this computer, and running as administrator doesn't help.  Like many others, Dimension Pro worked fine for me "forever" and then just didn't work one day when I opened a project that used it. 
    Jump to:
    © 2024 APG vNext Commercial Version 5.1