Helpful ReplyDisable audio engine on project startup

Author
Hidden_Symmetry
Max Output Level: -86 dBFS
  • Total Posts : 236
  • Joined: 2009/12/13 11:58:48
  • Status: offline
2018/11/07 16:13:50 (permalink)

Disable audio engine on project startup

Any settings or reg. tweaks available to keep the audio engine in the off state when starting up a project?
#1
John
Forum Host
  • Total Posts : 30423
  • Joined: 2003/11/06 11:53:17
  • Status: offline
Re: Disable audio engine on project startup 2018/11/09 16:21:53 (permalink)
Is there a reason for wanting this?

Best
John
#2
Cactus Music
Max Output Level: 0 dBFS
  • Total Posts : 8307
  • Joined: 2004/02/09 21:34:04
  • Status: offline
Re: Disable audio engine on project startup 2018/11/09 17:21:35 (permalink)
YA,, now I've heard everything, " I want to open my DAW but I don't want it to work,,, I just want to admire it" :) 
 
Well I'm sure you have some solid sane reason but I would think this is something the Bakers would never have wanted to happen.
post edited by Cactus Music - 2018/11/09 20:31:16

Johnny V  
Cakelab  
Focusrite 6i61st - Tascam us1641. 
3 Desktops and 3 Laptops W7 and W10
 http://www.cactusmusic.ca/
My Sonar Tutorial on using MIDI
http://www.cactusmusic.ca/Sonarmidi.htm
 
 
#3
scook
Forum Host
  • Total Posts : 23991
  • Joined: 2005/07/27 13:43:57
  • Location: TX
  • Status: online
Re: Disable audio engine on project startup 2018/11/09 17:42:21 (permalink) ☄ Helpfulby Hidden_Symmetry 2018/11/09 23:23:09
I do not know of a config option for this. For projects that must load silently, I mute whatever needs to be silenced then save the project. It could be as simple as muting the master bus.
#4
Hidden_Symmetry
Max Output Level: -86 dBFS
  • Total Posts : 236
  • Joined: 2009/12/13 11:58:48
  • Status: offline
Re: Disable audio engine on project startup 2018/11/09 23:20:40 (permalink)
John
Is there a reason for wanting this?


yes, obviously
 
#5
Hidden_Symmetry
Max Output Level: -86 dBFS
  • Total Posts : 236
  • Joined: 2009/12/13 11:58:48
  • Status: offline
Re: Disable audio engine on project startup 2018/11/09 23:21:54 (permalink)
Cactus Music
YA,, now I've heard everything, " I want to open my DAW but I don't want it to work,,, I just want to admire it" :) 
 
Well I'm sure you have some solid sane reason but I would think this is something the Bakers would never have wanted to happen.


thanks for nothing
#6
Hidden_Symmetry
Max Output Level: -86 dBFS
  • Total Posts : 236
  • Joined: 2009/12/13 11:58:48
  • Status: offline
Re: Disable audio engine on project startup 2018/11/09 23:22:59 (permalink)
scook
I do not know of a config option for this. For projects that must load silently, I mute whatever needs to be silenced then save the project. It could be as simple as muting the master bus.


Thanks scook, glad you chimed in with an insightful post (as always)
#7
John
Forum Host
  • Total Posts : 30423
  • Joined: 2003/11/06 11:53:17
  • Status: offline
Re: Disable audio engine on project startup 2018/11/10 09:04:34 (permalink)
Hidden_Symmetry
John
Is there a reason for wanting this?


yes, obviously
 


I can think of a number ways to prevent sound from Sonar no audio engine is not one of them. 

Best
John
#8
Hidden_Symmetry
Max Output Level: -86 dBFS
  • Total Posts : 236
  • Joined: 2009/12/13 11:58:48
  • Status: offline
Re: Disable audio engine on project startup 2018/11/10 15:32:52 (permalink)
Let me explain it this way:
When I close projects I archive all midi & audio tracks (& disable synths & certain fx bins on buses) This stops processing, resources, cpu usage & almost guarantees the project will re-open smoothly.
 
I'd like to try doing this by using an auto option setting or tweak that would prevent any resources or processes from running on startup. (keeping the engine in the off state; stopping all process & resources similar to using the 'Disable Audio Engine' button in the transport.)


 
Cakewalk runs very smoothly however certain plugins or large projects with lots of automation can trigger a crash. When this happens certain tracks I've been working on aren't archived, when re-opening the projects the running engine processing &  resources can sometimes trigger a crash instantly.
Maybe it wouldn't work the way I'm thinking it would but I'd like to try it to see what the results might be. (if it were possible)
#9
msmcleod
Max Output Level: -74 dBFS
  • Total Posts : 837
  • Joined: 2004/01/27 07:15:30
  • Location: Scotland
  • Status: offline
Re: Disable audio engine on project startup 2018/11/10 15:42:34 (permalink)
Maybe you can open another program (like a stand-alone plugin) that would steal the ASIO device?
 
Cakewalk would then be unable to start the audio engine until you've closed that program.

Mark McLeod
Cakewalk by BL | ASUS P8B75-V, Intel I5 3570 16GB RAM Win 10 64 + Win 7 64/32 SSD HD's, Scarlett 18i20 / 6i6 | ASUS ROG GL552VW 16GB RAM Win 10 64 SSD HD's, Scarlett 2i2 | Behringer Truth B2030A / Edirol MA-5A | Mackie MCU + C4 + XT | 2 x BCF2000, Korg NanoKontrol Studio
#10
Hidden_Symmetry
Max Output Level: -86 dBFS
  • Total Posts : 236
  • Joined: 2009/12/13 11:58:48
  • Status: offline
Re: Disable audio engine on project startup 2018/11/10 15:48:19 (permalink)
Sorry, I'm not understanding that idea.
#11
scook
Forum Host
  • Total Posts : 23991
  • Joined: 2005/07/27 13:43:57
  • Location: TX
  • Status: online
Re: Disable audio engine on project startup 2018/11/10 16:04:48 (permalink)
Hidden_Symmetry
when re-opening the projects the running engine processing &  resources can sometimes trigger a crash instantly.

Even starting in safe mode?
#12
Hidden_Symmetry
Max Output Level: -86 dBFS
  • Total Posts : 236
  • Joined: 2009/12/13 11:58:48
  • Status: offline
Re: Disable audio engine on project startup 2018/11/10 16:24:11 (permalink)
When the projects aren't processing on startup (tracks archived)  I rarely have any crashes.
I'll only use safe mode as a last resort when I have to delete plugins or synths out of a project.
#13
scook
Forum Host
  • Total Posts : 23991
  • Joined: 2005/07/27 13:43:57
  • Location: TX
  • Status: online
Re: Disable audio engine on project startup 2018/11/10 16:30:05 (permalink)
Safe mode does not have to be a last resort. It may be enough to have the process interrupted for the initial plug-in prompt to avoid the load problem. There is no need to step through the plug-ins one at a time.
#14
John
Forum Host
  • Total Posts : 30423
  • Joined: 2003/11/06 11:53:17
  • Status: offline
Re: Disable audio engine on project startup 2018/11/10 16:33:04 (permalink)
Hidden_Symmetry
Let me explain it this way:
When I close projects I archive all midi & audio tracks (& disable synths & certain fx bins on buses) This stops processing, resources, cpu usage & almost guarantees the project will re-open smoothly.
 
I'd like to try doing this by using an auto option setting or tweak that would prevent any resources or processes from running on startup. (keeping the engine in the off state; stopping all process & resources similar to using the 'Disable Audio Engine' button in the transport.)


 
Cakewalk runs very smoothly however certain plugins or large projects with lots of automation can trigger a crash. When this happens certain tracks I've been working on aren't archived, when re-opening the projects the running engine processing &  resources can sometimes trigger a crash instantly.
Maybe it wouldn't work the way I'm thinking it would but I'd like to try it to see what the results might be. (if it were possible)


That is very cleaver thinking. I do follow your logic. However there is a way to open a troublesome project using safe mode. Plus in the end this is an error and should be addressed in an update. This wont get done if Bandlab is unaware of the problem.  
 
Note: Safe mode is activated when you open a file while the SHIFT key is pressed.
 
I hope that this problem is fixed. 
 
One final thought. What happens if you save with the audio engine off?

Best
John
#15
scook
Forum Host
  • Total Posts : 23991
  • Joined: 2005/07/27 13:43:57
  • Location: TX
  • Status: online
Re: Disable audio engine on project startup 2018/11/10 16:35:55 (permalink)
AFAIK, the engine is automatically enabled when a project is open. The engine state is not saved in the project. I am unaware of any documented setting to change this behavior. There may be an undocumented setting but I do not recall reading about one.
#16
Hidden_Symmetry
Max Output Level: -86 dBFS
  • Total Posts : 236
  • Joined: 2009/12/13 11:58:48
  • Status: offline
Re: Disable audio engine on project startup 2018/11/10 17:27:54 (permalink)
@John, thanks, tried that already but it becomes enabled again after saving / re-opening.
 
@scook, again I'm not understanding. I use Safe mode for troubleshooting only, you can't work in it & a project can still crash. If I'm looking for a certain plugin (or audio file, automation ) that might be causing a problem I'll use safe mode to hunt it down using the disable options until I find the culprit, but that's not what I'm looking to do.
Any problematic plugins that might be causing the crash on startup otherwise run & work fine when working in the project itself.
I only want the engine from processing & using resources on startup. It's during that initial loading (with the processing, resources running) that causes a crash (& why I use archive to keep them off when re-opening)
 
Does that make sense or am I missing something about Safe Mode? thanks
 
 
 
#17
scook
Forum Host
  • Total Posts : 23991
  • Joined: 2005/07/27 13:43:57
  • Location: TX
  • Status: online
Re: Disable audio engine on project startup 2018/11/10 17:40:59 (permalink)
Sometimes projects that do not start regularly will start in safe mode because of the delay in loading plug-ins.  This may not be the case here. This may be a job for support include a dump in the report.
#18
msmcleod
Max Output Level: -74 dBFS
  • Total Posts : 837
  • Joined: 2004/01/27 07:15:30
  • Location: Scotland
  • Status: offline
Re: Disable audio engine on project startup 2018/11/10 17:56:52 (permalink)
How about checking "Suspend Audio Engine When Cakewalk Is Not in Focus", open your project, then quickly go to another window whilst it's loading?
 
You could also try unchecking MMCSS before loading your project. In theory, this should give SONAR lower priority for resources, which may slow down the loading of resources allowing things to settle down whilst the project is loading.
 
Also try unchecking "Always Stream Audio Through FX".
 
You probably want to re-enable MMCSS & "Always Stream Audio Through FX" after the project has loaded tho.
 
I'm not sure if disabling the Multiprocessing Engine will help or make things worse, but its probably worth messing around with.

Mark McLeod
Cakewalk by BL | ASUS P8B75-V, Intel I5 3570 16GB RAM Win 10 64 + Win 7 64/32 SSD HD's, Scarlett 18i20 / 6i6 | ASUS ROG GL552VW 16GB RAM Win 10 64 SSD HD's, Scarlett 2i2 | Behringer Truth B2030A / Edirol MA-5A | Mackie MCU + C4 + XT | 2 x BCF2000, Korg NanoKontrol Studio
#19
Hidden_Symmetry
Max Output Level: -86 dBFS
  • Total Posts : 236
  • Joined: 2009/12/13 11:58:48
  • Status: offline
Re: Disable audio engine on project startup 2018/11/10 17:58:01 (permalink)
@skook thanks, I'll save a report the next time it happens.
post edited by Hidden_Symmetry - 2018/11/10 21:27:40
#20
Hidden_Symmetry
Max Output Level: -86 dBFS
  • Total Posts : 236
  • Joined: 2009/12/13 11:58:48
  • Status: offline
Re: Disable audio engine on project startup 2018/11/10 21:28:43 (permalink)
msmcleod
How about checking "Suspend Audio Engine When Cakewalk Is Not in Focus", open your project, then quickly go to another window whilst it's loading?
 
You could also try unchecking MMCSS before loading your project. In theory, this should give SONAR lower priority for resources, which may slow down the loading of resources allowing things to settle down whilst the project is loading.
 
Also try unchecking "Always Stream Audio Through FX".
 
You probably want to re-enable MMCSS & "Always Stream Audio Through FX" after the project has loaded tho.
 
I'm not sure if disabling the Multiprocessing Engine will help or make things worse, but its probably worth messing around with.


thanks for the suggestion, I'll check it out.
#21
Jump to:
© 2018 APG vNext Commercial Version 5.1