AnsweredHow do I enable MIDI keyboard input?

Author
Moxica
Max Output Level: -89 dBFS
  • Total Posts : 62
  • Joined: 2013/09/22 09:15:17
  • Location: Norway
  • Status: offline
2018/11/06 21:20:46 (permalink)

How do I enable MIDI keyboard input?

I have on several instances recorded through a soft synth from an Oxygen midi keyboard. But I mostly use guitar and bass, so I never learn the mandatory steps to take. Today I needed a soft synth from kontakt, and it simply does not receive input from the keyboard. This happens so often that I hesitate to even think about a piano or other midi things in my projects. Virtual keyboard works. I've allways had to fumble around until suddenly, it receives my input with sound.
What am I missing? Why is this setting not enough:

#1
msmcleod
Max Output Level: -74 dBFS
  • Total Posts : 837
  • Joined: 2004/01/27 07:15:30
  • Location: Scotland
  • Status: online
Re: How do I enable MIDI keyboard input? 2018/11/06 21:35:11 (permalink)
You've probably not assigned a MIDI IN to the track Kontakt is on:
 

 
Try setting it to All Inputs, MIDI Omni as shown above first.
 
You can be more specific, and tie it down to a single controller and/or MIDI channel if needed.

Mark McLeod
Cakewalk by BL | ASUS P8B75-V, Intel I5 3570 16GB RAM Win 10 64 + Win 7 64/32 SSD HD's, Scarlett 18i20 / 6i6 | ASUS ROG GL552VW 16GB RAM Win 10 64 SSD HD's, Scarlett 2i2 | Behringer Truth B2030A / Edirol MA-5A | Mackie MCU + C4 + XT | 2 x BCF2000, Korg NanoKontrol Studio
#2
Moxica
Max Output Level: -89 dBFS
  • Total Posts : 62
  • Joined: 2013/09/22 09:15:17
  • Location: Norway
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/07 10:20:52 (permalink)
Thanks, Mark!
That setting is the first thing I try as part of my "fumbling around" procedure. :)
Other times/synths, this input is set to none by default, and it still works. Seems very random, very hit'n miss and confusing.
 
post edited by Moxica - 2018/11/07 11:28:41
#3
Steev
Max Output Level: -85 dBFS
  • Total Posts : 266
  • Joined: 2006/02/04 08:24:08
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/07 11:30:18 (permalink)
Set your MIDI channel input to Kontakt.
 
If at any time you lose control between Kontakt and your MIDI controller simply ckick on the MIDI track Kontakt is assigned to, or click on Kontakt in the Synth Rack in the browser.
 

Steev on Bandlab.com
 
Custom built workstation. Windows 10 Pro x64.
 
SONAR Platinum. Cakewalk by Bandlab.
Sony Sound Forge Pro 10, ACID Pro 7, Vegas Pro 11
Pro Tools.
 
ASRock 970 mobo, AMD FX 8370 8-Core. 16 gb DDR3 PC1866 G Skill Ripjaws X RAM. AMD FirePro V4900 1gb DDR5 accelerated graphics card. 
Behringer X Touch DAW Controller
Focusrite Scarlett 18i20 gen 2, OctoPre Mkll
Western Digital 500GB SSD bootdrive,  WD 500GB 10k rpm VelociRaptor for DAW projects . 2x1 TB WD Caviar Black SATA3 storage drives
 
#4
Moxica
Max Output Level: -89 dBFS
  • Total Posts : 62
  • Joined: 2013/09/22 09:15:17
  • Location: Norway
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/07 17:31:56 (permalink)
Thanks, Steev.
Decided to try this again now. So I inserted same kontakt synth, and tested without any change of settings.
-Input set to none by default. And there was sound. There was registered input. Hit today. Miss tomorrow, maybe.
#5
michael diemer
Max Output Level: -70 dBFS
  • Total Posts : 1046
  • Joined: 2013/05/24 18:54:50
  • Location: Maine, USA
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/07 18:13:03 (permalink)
You also need to assign a channel on the Kontakt synth, in addition to setting a channel in Cakewalk. These channels must agree.  If you pull out the grab bar in the clips pane/track view, you will see three options. (Using the settings on the left of the screen is too confusing). So, set the first one to Kontakt/Omni.  In the second option, choose the Kontakt synth. In the third column, set channel to whatever you want (let's say 1). Finally, on Kontakt you need to do two things: choose the first output, and in the drop down list select channel 1. These two settings are directly under the Name Of The Instrument on the Kontakt Synth. Yours should say:
 
Piano
Output One
Channel Two
 
That should do it.

michael diemer
Intel Quad Core i7-3770 Ivy Bridge
32 GB ram
1TB Western Digital Black X2
Microsoft Windows 7 Pro 64
UR22 interface
Bandlab Cakewalk/Sonar 8.5 Studio
GPO-EWQLSO Gold-Vienna SP ED-Cinematic Strings 2
 
 
 
 
#6
Moxica
Max Output Level: -89 dBFS
  • Total Posts : 62
  • Joined: 2013/09/22 09:15:17
  • Location: Norway
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/08 09:00:24 (permalink)
Thanks, Michael!
But why then, did it just work yesterday, without doing anything other than inserting the synth?
I changed no settings in any column. Nor did I set anything in Kontakt. 
Input on the strip was set to "None"


#7
bjornpdx
Max Output Level: -76 dBFS
  • Total Posts : 721
  • Joined: 2010/12/10 11:41:29
  • Location: Portland, Oregon
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/08 15:25:14 (permalink)
I've had weird MIDI stuff happen that turned out to be a bad MIDI cable. You're probably not using a MIDI cable, but how about trying a different USB cable?

Bjorn
soundcloud.com/orygun
www.bjornfredrickson.com
https://store.cdbaby.com/Artist/BjornFredrickson
 
Purrfect Audio Pro Studio, RME UCX
Cakewalk by Bandlab,  Studio One,  Reaper
#8
Moxica
Max Output Level: -89 dBFS
  • Total Posts : 62
  • Joined: 2013/09/22 09:15:17
  • Location: Norway
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/08 17:38:49 (permalink)
Seems plausible, bjorn. My chair has wheels... :)
#9
michael diemer
Max Output Level: -70 dBFS
  • Total Posts : 1046
  • Joined: 2013/05/24 18:54:50
  • Location: Maine, USA
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/08 17:54:10 (permalink)
Moxica
Thanks, Michael!
But why then, did it just work yesterday, without doing anything other than inserting the synth?
I changed no settings in any column. Nor did I set anything in Kontakt. 
Input on the strip was set to "None"




Try loading multiple instruments, each with different channels. It may be that loading only one inst. is like using the Dimension Pro synth, where you only have one inst per synth, so the channel doesn't matter. It works, but only for that one inst. 

michael diemer
Intel Quad Core i7-3770 Ivy Bridge
32 GB ram
1TB Western Digital Black X2
Microsoft Windows 7 Pro 64
UR22 interface
Bandlab Cakewalk/Sonar 8.5 Studio
GPO-EWQLSO Gold-Vienna SP ED-Cinematic Strings 2
 
 
 
 
#10
JoseC.
Max Output Level: -81 dBFS
  • Total Posts : 462
  • Joined: 2003/11/10 14:46:11
  • Location: León, Spain
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/09 00:36:50 (permalink) ☄ Helpfulby Moxica 2018/11/09 07:31:15
Sorry if this is a trivial answer. Take notice that when you insert an instrument in an instance of Kontakt, it usually gets loaded to receive midi through channel 1. If you then decide to change it, and add the new one before deleting the first, the second gets automatically loaded by Kontakt to receive midi in channel 2. If your Cakewalk track was set up to send to channel 1, you will not hear your instrument until you change the channel in the header of the new instrument to 1, or set the Cakewalk track to channel 2.
#11
Moxica
Max Output Level: -89 dBFS
  • Total Posts : 62
  • Joined: 2013/09/22 09:15:17
  • Location: Norway
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/09 09:03:51 (permalink)
Nothing is trivial when it comes to midi. :) Thank you.
#12
azslow3
Max Output Level: -42.5 dBFS
  • Total Posts : 3255
  • Joined: 2012/06/22 19:27:51
  • Location: Germany
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/09 11:35:37 (permalink) ☄ Helpfulby Moxica 2018/11/09 19:30:31
I want to mention several "self explaining" features of Sonar, which it easy to overseen:
1) "MIDI omni" and "None" are equivalent
2) default Echo is "auto", means it is automatically switch on when the track is selected and off when deselected. Controlled by Preferences / MIDI /Playback and recording, "Always echo current MIDI track". Note then when the option is on, disabling/enabling on the track level is reset once you select different track.
3) in the Windows tray, there is MIDI icon which indicate in/out signals. Useful to check the hardware sending something.
4) if you get no sound and do not know at which part something wrong, simply try to record MIDI on the track.

Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
#13
Cactus Music
Max Output Level: 0 dBFS
  • Total Posts : 8307
  • Joined: 2004/02/09 21:34:04
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/09 17:27:21 (permalink)
I always choose my Keyboard controller as the input, I never use all inputs, and Omni. This always works
If it doesn't I will find that PRV is open and focus is still on a different track. It should automatically swap to the new track but this doesn't always happen for me.
 

Johnny V  
Cakelab  
Focusrite 6i61st - Tascam us1641. 
3 Desktops and 3 Laptops W7 and W10
 http://www.cactusmusic.ca/
My Sonar Tutorial on using MIDI
http://www.cactusmusic.ca/Sonarmidi.htm
 
 
#14
shawker
Max Output Level: -89 dBFS
  • Total Posts : 78
  • Joined: 2014/08/12 12:45:03
  • Location: Sunshine Coast BC
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/09 21:33:10 (permalink) ☼ Best Answerby Moxica 2018/11/10 11:06:22
Did you turn on Input Echo on the midi track?
#15
Moxica
Max Output Level: -89 dBFS
  • Total Posts : 62
  • Joined: 2013/09/22 09:15:17
  • Location: Norway
  • Status: offline
Re: How do I enable MIDI keyboard input? 2018/11/10 11:06:40 (permalink)
Its on by default.
#16
Jump to:
© 2018 APG vNext Commercial Version 5.1