No Sound from ASIO4ALL???

Author
Leat
Max Output Level: -90 dBFS
  • Total Posts : 9
  • Joined: 2017/12/26 04:25:36
  • Status: offline
2017/12/26 04:45:33 (permalink)

No Sound from ASIO4ALL???

So I'm using an outdated SONAR HS 4 XL with my new Windows 10 Tablet-PC. I haven't had any pc for a few years now, so I'm very happy to have this. Thanks ma for the Christmas gift. :D
 
Now I used my gma laptop dvd drive to install the software remotely over wifi, worked great. App runs, vst adapter works, sound on my pc works normal, but has no sound in it. I've tried WDM MME and ASIO drivers, using ASIO4ALL. As an added note, using VMPK has an audio stutter when pressing keys i can't figure out why. Also, using MidiYoke seems to cause crashes.
 
So it is interesting that VMPK makes sound, though very choppy, unusable.
 
I am broke, with no income. I am starting college this Jan. My question is, HELP?!
 
Using the Intel SST drivers? I'm having to catch up to what's been going on with windows since I've been stuck on iPhone, then sold for an Android device. I have FL studio Mobile on my android and it works fine, but I don't want to use that unless I'm stuck out and about with no PC. It's good for if I have an idea while I'm out.
 
Anyways, when SONAR is open, ASIO4ALL shows my audio devices are selected and working[play button i think]. Games sound output is regular no glitches. So, yea, wth is going on here?
#1

5 Replies Related Threads

    Cactus Music
    Max Output Level: 0 dBFS
    • Total Posts : 8003
    • Joined: 2004/02/09 21:34:04
    • Status: offline
    Re: No Sound from ASIO4ALL??? 2017/12/26 17:35:54 (permalink)
    What are the specs for the tablet? Most tablets are way to underpowered to run apps like Sonar. And memory is important too. 
    Not only that the version of W10 is not always the same as the ones run on full size computers. 
     
    I use ASIO4all on a Lenovo idea Pad at work, it has W10. I installed SPlat just to test some things and it runs great and ASIO4all works as it should. But that's an i5 and 8 GB RAM. 

    Johnny V  
    What ever the new stuff is- I have that. 
    Focusrite 6i61st - Tascam us1641. 
    3 Desktops and 3 Laptops W7 and W10
     http://www.cactusmusic.ca/
    My Sonar Tutorial on using MIDI
    http://www.cactusmusic.ca/Sonarmidi.htm
     
     
    #2
    Leat
    Max Output Level: -90 dBFS
    • Total Posts : 9
    • Joined: 2017/12/26 04:25:36
    • Status: offline
    Re: No Sound from ASIO4ALL??? 2017/12/26 18:46:28 (permalink)
    I have an Intel Atom z3735f CPU with Bay Trail GPU chipset, intel HD audio, showing Realtek LS2 Codec. I was tinkering after my post, and discovered that one[probably my main] output is shown as used by something else, hover over pop up says "is MS GS synth in use" you know what i mean? So I turned my Windows sound profile off, as suggested saying that[from the internet that is] Windows sound profile uses GS synth, so I turned it off with no help.
     
    Someone had discovered that they installed FL Studio Demo and it had an asio driver with it, and that worked for them. So I registered the Asio driver from FL and it does show up as available in my SONAR. Now here's another interesting issue, FL Studio Demo plays and makes sound just fine.
     
    It seems perhaps my software is old[2005 release date] and may have compatability issues, so I'm going to try everything from Windows XP and up to see if it makes an output. But FL Studio Demo does work, but I only installed it for the ASIO driver.
     
    I loved my Cakewalk software, and love it tho it's old. If there's any way?
     
    So to make it plain:
    1.8Ghz per Core[x4] average at 1.33Ghz
    2GB DDR3 RAM
    32GB HDD SSD storage
     
    I have no idea what Mobo is in this thing, it's a Kocaso brand, so I may just call them and Microsoft to see what they say.
    #3
    Leat
    Max Output Level: -90 dBFS
    • Total Posts : 9
    • Joined: 2017/12/26 04:25:36
    • Status: offline
    Re: No Sound from ASIO4ALL??? 2017/12/26 18:57:27 (permalink)
    This guy on another forum with a similar issue, did this:
    HKLM/Software/Microsoft/WindowsNT/CurrentVersion/Driver32

    and renamed (or deleted) ALL the keys starting with midi...etc
    Then rebooted, and this "fixed" the problem with Realtek HD on XP.

    I'm trying to do the same on Vista, but I don´t know how can I disable MIDI on it.
    Please answer if you know how to do that.

     
    I kinda wanna try it but nervous to mess with registry.
     
    #4
    Leat
    Max Output Level: -90 dBFS
    • Total Posts : 9
    • Joined: 2017/12/26 04:25:36
    • Status: offline
    Re: No Sound from ASIO4ALL??? 2017/12/26 19:03:39 (permalink)
    Found my fix:

    #6 - VirtualMIDISynth is not listed as output device in Cakewalk / Sonar

    This solution works for Sonar 5, but can be adapted to newer versions (here's the original page):
    Internal Sound Card Playback:
    If you have a built-in sound card and want Cakewalk to play MIDI through the synth built into Windows, you will need to switch Cakewalk's driver mode so it can see it.
    - Go to Edit > Preferences > Audio - Playback and Recording (Options > Audio > Advanced in legacy products)
    - Change the Driver Mode to "MME (32-bit)" and click Apply (in legacy products put a check in the box that says "Always Use MME Interface" then click OK)
    - Restart the program and let the Wave Profiler Test your hardware.
    - Go to Edit > Preferences > MIDI - Devices (Options > MIDI Devices in legacy products).
    - You should now see "Microsoft GS Wavetable S/W synth" under outputs.
    - Select this new device and click Apply (if available) then OK.

     
    Makes it work, now I want the same from asio for low latency.
     
    #5
    Cactus Music
    Max Output Level: 0 dBFS
    • Total Posts : 8003
    • Joined: 2004/02/09 21:34:04
    • Status: offline
    Re: No Sound from ASIO4ALL??? 2017/12/27 16:59:38 (permalink)
     
    Your problem is your trying to run old software on a new device. Don't. There are plenty of up to date DAW's. Many are very inexpensive and demos are free to try so you can see what works. Look at all the time your spending trying to get it to work. Move on and find software that works on a tablet. I would have recommended Home Studio latest version but of course that's a goner.

    Johnny V  
    What ever the new stuff is- I have that. 
    Focusrite 6i61st - Tascam us1641. 
    3 Desktops and 3 Laptops W7 and W10
     http://www.cactusmusic.ca/
    My Sonar Tutorial on using MIDI
    http://www.cactusmusic.ca/Sonarmidi.htm
     
     
    #6
    Jump to:
    © 2018 APG vNext Commercial Version 5.1