Not seeing keyboard in MIDI input screen

Author
snauman
Max Output Level: -90 dBFS
  • Total Posts : 2
  • Joined: 2018/01/15 17:09:24
  • Status: offline
2018/02/25 17:43:40 (permalink)

Not seeing keyboard in MIDI input screen

I have a YAMAHA P80 keyboard connected to Win 10 PC with a Roland UM-ONE and am trying to get it set up with Music Creator 6.  The connection from keyboard to PC appears to be working fine.  I've added the keyboard to MIDI Devices in the preferences window but when I try to set up the keyboard as a MIDI input for a track it doesn't show up.  Is there something I'm missing?
#1

5 Replies Related Threads

    jimfogle
    Max Output Level: -82 dBFS
    • Total Posts : 409
    • Joined: 2007/03/14 10:08:19
    • Location: Winston-Salem, NC USA
    • Status: offline
    Re: Not seeing keyboard in MIDI input screen 2018/02/25 20:37:17 (permalink)
    I assume you have installed the Roland UM-ONE Windows 10 driver?  If not it is available here:  https://www.roland.com/us/products/um-one/downloads/
     
    What USB port are you plugging the Roland UM-ONE into?  It requires 70 milli-amperes from the computer USB port to operate so go into your Windows 10 settings and make sure all your USB ports are set to operate at full power.  If you have a laptop, you'll likely need to change your power setting so the USB ports don't automatically remove power to save battery energy.  If you have a desktop try connecting to a rear panel USB port that directly connects to the motherboard.  Many front panel USB ports are limited.
     
    Make sure you plug the MIDI-IN Roland UM-ONE connector into the rear panel MIDI-OUT of the Yamaha P-80.  The MIDI-OUT Roland UM-ONE connector plugs into the rear panel MIDI-IN of the Yamaha P-80.
     
    With the correct Roland driver installed, Music Creator 6 should list the Roland UM-ONE as a MIDI device; does it?
     
    What are your MIDI settings on the Yamaha P-80?  Keyswitch F-8 on the Yamaha P-80 leads you into MIDI settings.  They are covered starting on page 32 of the owner's manual.  Notice there is no OMNI.  The keyboard transmits on one of 16 channels.  It also receives on one of 16 channels.
     
    Last, what position do you have the 4 position MIDI/PC2/PC1/MAC switch in?  It needs to be in the MIDI position otherwise data ismsent to the 9 pin mini-DIN connector you have nothing attached to.

    Jim F
    Cakewalk by Bandlab [2018.07] BUILD 10
    Sonar Home Studio V23.9.0 build 32
    Music Creator 6
    Audacity, Band-in-a-Box, ChordPulse
    Win 7, i3 cpu, 8Gig ram, 480 Gig Dell Laptop
    http://fogle622.wix.com/fogle622-audio-home
     
     
    #2
    jimfogle
    Max Output Level: -82 dBFS
    • Total Posts : 409
    • Joined: 2007/03/14 10:08:19
    • Location: Winston-Salem, NC USA
    • Status: offline
    Re: Not seeing keyboard in MIDI input screen 2018/02/25 20:41:37 (permalink)
    I forgot to provide you the link to the Yamaha P-80 owner's manual.  It is the last one listed in the link below:
     
    https://usa.yamaha.com/pr..._production&k=p-80

    Jim F
    Cakewalk by Bandlab [2018.07] BUILD 10
    Sonar Home Studio V23.9.0 build 32
    Music Creator 6
    Audacity, Band-in-a-Box, ChordPulse
    Win 7, i3 cpu, 8Gig ram, 480 Gig Dell Laptop
    http://fogle622.wix.com/fogle622-audio-home
     
     
    #3
    snauman
    Max Output Level: -90 dBFS
    • Total Posts : 2
    • Joined: 2018/01/15 17:09:24
    • Status: offline
    Re: Not seeing keyboard in MIDI input screen 2018/02/25 23:53:02 (permalink)
    Thanks for the response Jim :)
     
    Roland UM-ONE Windows 10 driver is installed
     
    UM-ONE is plugged into rear USB port and is working (used MIDIOX to check and it's receiving data from the keyboard)
     
    UM-ONE is listed in the MIDI device preferences screen in both Input and Output section.
     
    i have not modified any of the P80 MIDI settings - so they are the defaults.  The 4 pos. switch is on MIDI.
    MIDI settings:
    1 - 1
    2 - ALL
    3 - On
    4 - On
    5 - On
    6 - O
    7 - End
    8 - End
     
    What should they be set at?  and are there corresponding settings when setting up the device in MC?
     
    Thanks,
    Steve
    #4
    jimfogle
    Max Output Level: -82 dBFS
    • Total Posts : 409
    • Joined: 2007/03/14 10:08:19
    • Location: Winston-Salem, NC USA
    • Status: offline
    Re: Not seeing keyboard in MIDI input screen 2018/02/26 01:08:34 (permalink)
    Steve,
     
    I don't have a good answer for you.  You will need to look up the MIDI settings in the manual to find out what they should be set at.  In Music Creator 6, create a one track MIDI project.  Make sure the track one input is set for OMNI so it will accept all MIDI input.  Note:  Look under the Help > MIDI > Basics and Configuring MIDI devices if any questions.  Next go to the synth rack browser and add the TTS-1 soft synth.  The TTS-1 is an instrument that will play whatever MIDI it hears.  Finally, make sure the output of the MIDI track is set for the TTS-1.
     
    Now try it and tell us what happens.

    Jim F
    Cakewalk by Bandlab [2018.07] BUILD 10
    Sonar Home Studio V23.9.0 build 32
    Music Creator 6
    Audacity, Band-in-a-Box, ChordPulse
    Win 7, i3 cpu, 8Gig ram, 480 Gig Dell Laptop
    http://fogle622.wix.com/fogle622-audio-home
     
     
    #5
    gcolbert
    Max Output Level: -67 dBFS
    • Total Posts : 1176
    • Joined: 2010/11/13 18:34:06
    • Location: Windsor Mill, MD
    • Status: offline
    Re: Not seeing keyboard in MIDI input screen 2018/03/12 21:36:38 (permalink)
    Just for giggles, did you try to set the keyboard as an input to a MIDI track?  If you see audio inputs as options on a track you may not have set up the right type of track.
     
    Glen

    Platinum / VS-100 / 12 GB RAM / Win 10 Pro / AMD A8 / MP Touch Monitors
    Platinum / on-board audio / 4 GB RAM /Win 10 Pro / HP dm4 Laptop / stuff
    THpfft!
    #6
    Jump to:
    © 2018 APG vNext Commercial Version 5.1