Helpful ReplyProblem with MIDIGuitar 2

Author
Lynn
Max Output Level: -14.5 dBFS
  • Total Posts : 6080
  • Joined: 2003/11/12 18:36:16
  • Location: Kansas City, MO
  • Status: offline
2018/10/10 00:17:45 (permalink)

Problem with MIDIGuitar 2

I asked this question in the software forum but got no response, so here goes.  I got MG2 last Christmas, used it in several CW projects with no problems.  However, with the latest version of CW 2018.09 (build 29), I'm unable to save my settings in MG2 unless I freeze the track.  I had to rebuild a few projects that were created in earlier versions of CW.  If anyone else is using MG2, are you having this problem too?  Am I missing something simple?  Thanks in advance for any replies.

All the best,
Lynn

my songs
www.soundclick.com/lynnwilson

www.youtube.com/lywilson
my videos

Cakewalk by Bandlab| Sonar Platinum @ 64bits| i7 860 | 8 gigs ram | W10 @ 64 bits | RME FF 400
#1
brandonc
Max Output Level: -89 dBFS
  • Total Posts : 64
  • Joined: 2015/08/27 23:01:04
  • Status: offline
Re: Problem with MIDIGuitar 2 2018/10/10 06:24:02 (permalink)
I've had problems with MIDIGUITAR 2 for months. Every time I try to bounce to track using midiguitar 2 on a track it crashes . ( I often use midiguitar2 for guitar sounds I made in it, NO midi-synth triggering). I uninstalled it and installed an old Beta version of Midiguitar 2 and that fixed my problem.
#2
msmcleod
Max Output Level: -77 dBFS
  • Total Posts : 689
  • Joined: 2004/01/27 07:15:30
  • Location: Scotland
  • Status: online
Re: Problem with MIDIGuitar 2 2018/10/10 12:23:38 (permalink)
I was using MIDIGuitar2 on my desktop PC just after the current 2018.08 CbB update, and it crashed pretty quickly. 
 
At the time though it was before I moved to the beta drivers for my 1st gen Focusrite 6i6 - the "stable" drivers has its buffer sizes in ms (1ms, 2ms etc) which gives odd buffer sizes - i.e. not powers of 2. I ended up having to use ASIO4ALL to get a buffer size of 256 which it prefers.
 
As I've used it on my laptop several times (prior to 2018.08) using my 2i2 without issue, I put it down to some weirdness between MIDIGuitar2 & ASIO4ALL. 
 
When I get time, I'll play about with it again to see if it's more stable using ASIO drivers that support a buffer size of 256. The latest beta drivers for the 1st gen Focusrites (which I was forced to install due to Windows 1809) now use power of 2 buffer sizes.
 
It's worth mentioning though, that I never save a project with MIDIGuitar2.
 
I only use it to get the MIDI data out for triggering acoustic or 12 string guitar samples, and only then if melodyne doesn't do a decent job of extracting the MIDI.
 
Once I've got the MIDI data onto another track, I delete MIDIGuitar2.
 
Invariably, I'll replace that track with a real acoustic / 12 string once I get around to it, but using Melodyne and/or MIDIGuitar2 gets my ideas down quickly.
 

Mark McLeod
Cakewalk by BL | ASUS P8B75-V, Intel I5 3570 16GB RAM Win 10 64 + Win 7 64/32 SSD HD's, Scarlett 18i20 / 6i6 | ASUS ROG GL552VW 16GB RAM Win 10 64 SSD HD's, Scarlett 2i2 | Behringer Truth B2030A / Edirol MA-5A | Mackie MCU + C4 + XT | 2 x BCF2000, Korg NanoKontrol Studio
#3
msmcleod
Max Output Level: -77 dBFS
  • Total Posts : 689
  • Joined: 2004/01/27 07:15:30
  • Location: Scotland
  • Status: online
Re: Problem with MIDIGuitar 2 2018/10/10 14:22:12 (permalink) ☄ Helpfulby Mesh 2018/10/10 14:55:47
Ok, did a quick 30 min test and it seems to be fine for me at a buffer size of 128, using 44.1Hkz/24 bit.
 
I had it inserted as a FX on an Audio track, MIDI output enabled, routed to a SONiVOX Singles Taylor Acoustic on a separate instrument track.
 
It actually worked at a buffer size of 32, but latency was increased to I reverted to 128.
 
I'm using the latest version (v2.2.1).
 
 

Mark McLeod
Cakewalk by BL | ASUS P8B75-V, Intel I5 3570 16GB RAM Win 10 64 + Win 7 64/32 SSD HD's, Scarlett 18i20 / 6i6 | ASUS ROG GL552VW 16GB RAM Win 10 64 SSD HD's, Scarlett 2i2 | Behringer Truth B2030A / Edirol MA-5A | Mackie MCU + C4 + XT | 2 x BCF2000, Korg NanoKontrol Studio
#4
scook
Forum Host
  • Total Posts : 23852
  • Joined: 2005/07/27 13:43:57
  • Location: TX
  • Status: online
Re: Problem with MIDIGuitar 2 2018/10/10 14:22:23 (permalink) ☄ Helpfulby TheMaartian 2018/10/10 22:37:29
^ This is how I use the plug-in. I may leave it in the project but do not use any of the built-in effects or its internal plug-in host. If it is losing its setup the only thing I can suggest is go back to the version the project is created with and save the MIDI Guitar settings as a preset in the plug-in's built-in preset manager.
#5
Lynn
Max Output Level: -14.5 dBFS
  • Total Posts : 6080
  • Joined: 2003/11/12 18:36:16
  • Location: Kansas City, MO
  • Status: offline
Re: Problem with MIDIGuitar 2 2018/10/10 16:04:06 (permalink)
Well, I've been using is to trigger Dimension Pro or Rapture samples.  Regardless of buffer time (I use 256), it will not save the presets, even if I create a preset in its own preset manager.  I have to freeze the track if I want to save it.  This didn't happen in the March version of CW.  Thanks for all your replies.

All the best,
Lynn

my songs
www.soundclick.com/lynnwilson

www.youtube.com/lywilson
my videos

Cakewalk by Bandlab| Sonar Platinum @ 64bits| i7 860 | 8 gigs ram | W10 @ 64 bits | RME FF 400
#6
scook
Forum Host
  • Total Posts : 23852
  • Joined: 2005/07/27 13:43:57
  • Location: TX
  • Status: online
Re: Problem with MIDIGuitar 2 2018/10/10 16:14:28 (permalink)
Lynn
Well, I've been using is to trigger Dimension Pro or Rapture samples.

Inside the MG2 plug-in or by adding separate track(s) for the synths. I do the latter.
#7
msmcleod
Max Output Level: -77 dBFS
  • Total Posts : 689
  • Joined: 2004/01/27 07:15:30
  • Location: Scotland
  • Status: online
Re: Problem with MIDIGuitar 2 2018/10/10 16:43:26 (permalink)
Lynn
Well, I've been using is to trigger Dimension Pro or Rapture samples.  Regardless of buffer time (I use 256), it will not save the presets, even if I create a preset in its own preset manager.  I have to freeze the track if I want to save it.  This didn't happen in the March version of CW.  Thanks for all your replies.




Yep, you're right - it doesn't recall presets.
 
Also, if you save a preset within MG2 itself, you have to manually recall it from within MG2. The CbB/Sonar preset system doesn't recall anything.
 
I think this is a MG2 issue. The same thing happens in Sonar Platinum.

Mark McLeod
Cakewalk by BL | ASUS P8B75-V, Intel I5 3570 16GB RAM Win 10 64 + Win 7 64/32 SSD HD's, Scarlett 18i20 / 6i6 | ASUS ROG GL552VW 16GB RAM Win 10 64 SSD HD's, Scarlett 2i2 | Behringer Truth B2030A / Edirol MA-5A | Mackie MCU + C4 + XT | 2 x BCF2000, Korg NanoKontrol Studio
#8
Lynn
Max Output Level: -14.5 dBFS
  • Total Posts : 6080
  • Joined: 2003/11/12 18:36:16
  • Location: Kansas City, MO
  • Status: offline
Re: Problem with MIDIGuitar 2 2018/10/10 16:47:03 (permalink)
scook
Lynn
Well, I've been using is to trigger Dimension Pro or Rapture samples.

Inside the MG2 plug-in or by adding separate track(s) for the synths. I do the latter.


I insert DP or Rapture inside MG2, find the sample I want, then create a preset within MG2.

All the best,
Lynn

my songs
www.soundclick.com/lynnwilson

www.youtube.com/lywilson
my videos

Cakewalk by Bandlab| Sonar Platinum @ 64bits| i7 860 | 8 gigs ram | W10 @ 64 bits | RME FF 400
#9
scook
Forum Host
  • Total Posts : 23852
  • Joined: 2005/07/27 13:43:57
  • Location: TX
  • Status: online
Re: Problem with MIDIGuitar 2 2018/10/10 16:55:56 (permalink)
Sorry, I do not use the plug-in that way. I can understand using the built-in VST host when running stand alone but unless there is an effect chain unique to MG2, I see no advantage to using the built-in host when running inside a DAW.
 
It does appear to have trouble loading preset when the project loads. The only way I could see keeping it straight using the build-in host and effects would be to name presets for each project/track.
#10
Jump to:
© 2018 APG vNext Commercial Version 5.1