AnsweredProblems with connecting RolandA-500 Pro to Ableton

Author
Jordy14
Max Output Level: -90 dBFS
  • Total Posts : 5
  • Joined: 2017/02/08 12:55:25
  • Status: offline
2018/10/20 20:24:32 (permalink)

Problems with connecting RolandA-500 Pro to Ableton

Hi there,
 
Thanks for taking the time to read my post. I have been fiddling for hours now trying to get this right. I have properly installed my A-500 for my Mac High Sierra with drivers and accompanying editor. CTRL map 12 is what I have selected. The keys, octave and transpose buttons are all working fine. The main problem is that the faders, knobs and play/pause buttons are not working in Live. I can see Live picks up the input when I twist the knob or slide the fader, but no visible effect is happening. I am also kind of confused by this preferences screen. What do I have to select for the MIDI keyboard, since it has multiple entries for the A500?
 
Many thanks!!

#1
tlw
Max Output Level: -49.5 dBFS
  • Total Posts : 2567
  • Joined: 2008/10/11 22:06:32
  • Location: West Midlands, UK
  • Status: offline
Re: Problems with connecting RolandA-500 Pro to Ableton 2018/10/21 00:09:39 (permalink)
Most people here probably don’t know Live very well, and don’t use Macs at all. It’s mostly a peer to peer support forum focussed on what was Cakewalk Sonar and is now just “Cakewalk” under new ownership. Cakewalk was once owned by Roland years ago and so some Roland hardware, and Roland-made hardware “Cakewalk” got included.

I suggest searching and asking about this problem in the Ableton forums, this might be some use to get you started - https://forum.ableton.com...ic.php?p=609432#609432

Though it’s a very old thread as you’d expect from a controller dating back over ten years. The A-X00 series controllers were made by Edirol originally, then Roland bought Edirol and re-branded them. I have an A-300 but haven’t used it in a long time because of the poor aftertouch, and never with Live. I remember it wasn’t the easiest of controllers to set up but reliable once programmed.

Sonar Platinum 64bit, Windows 8.1 Pro 64bit, I7 3770K Ivybridge, 16GB Ram, Gigabyte Z77-D3H m/board,
ATI 7750 graphics+ 1GB RAM, 2xIntel 520 series 220GB SSDs, 1 TB Samsung F3 + 1 TB WD HDDs, Seasonic fanless 460W psu, RME Fireface UFX, Focusrite Octopre.
Assorted real synths, guitars, mandolins, diatonic accordions, percussion, fx and other stuff.
#2
Jordy14
Max Output Level: -90 dBFS
  • Total Posts : 5
  • Joined: 2017/02/08 12:55:25
  • Status: offline
Re: Problems with connecting RolandA-500 Pro to Ableton 2018/10/21 15:48:53 (permalink)
thanks, im gonna try my luck!
#3
2:43AM
Max Output Level: -68 dBFS
  • Total Posts : 1142
  • Joined: 2013/06/24 07:59:49
  • Location: PHX
  • Status: offline
Re: Problems with connecting RolandA-500 Pro to Ableton 2018/11/04 15:28:35 (permalink) ☼ Best Answerby Jordy14 2018/11/20 21:34:10
Control Map 19 is the default for Live.
 
Setup your A500 to Live as you have done. It should be Roland A Pro , A-PRO 2 , A-PRO across the board. Then set your A500 to map 19. Then do a dump.  Should work now.

CPU Stuff: SPLAT / Ableton Live 10, Win10 x64, MSI M.Power Z97 mobo, MSI Radeon RX480, Intel i7-4790K @4GHz, 8GB RAM
HW Stuff: Saffire Pro40+Pro40 (Dual Setup), A500Pro, MicroLite 5x5, MIDISport 2x2, Ai3 (2), V-Synth XT, Q Rack, Virus Ti2, JV-1010, A6 Andromeda, TR-8, MS2000R, Minitaur, Spark, MS2000R, Quadraverb2, Midiverb2, Wedge, JBL LSR308's, Never-ending problems...

#4
abacab
Max Output Level: -31.5 dBFS
  • Total Posts : 4388
  • Joined: 2014/12/31 19:34:07
  • Status: offline
Re: Problems with connecting RolandA-500 Pro to Ableton 2018/11/04 17:48:21 (permalink)
The thing to remember about the A-PRO is that the driver uses two MIDI input ports in the host DAW.  One for the keys, and one for the control surface.
 
If your keys are working, but not the faders for example, you need to complete your DAW setup to use both ports.
 
I have the A-300PRO, but have not used it with Live, so don't have specifics on the setup for that, but this dual port requirement can be a stumbling block for users even with Windows and Cakewalk.  Works great once you figure it out.

DAW: Cakewalk by Bandlab; Sonar Platinum, and others ...  Other: AIR AIEP; Akai VIP; BIAB; Fathom; Ignite; iZotope Iris 2; Miroslav; Notion; Overture; SampleTank 3; SynthMaster; Syntronik; Waves  OS: Win10 Pro x64 1709  System: Homebuilt Asus; i3 3.4Ghz; 8GB DDR3; Intel HD Graphics; Dual Monitors; Samsung EVO 850 SSD, 250GB; PCIe FireWire  Audio: M-Audio FW-410  Controllers: A-300PRO; Alesis VX49; CME Xkey  Hardware: Roland JV880; JV1080; XP-30; Alesis QS-6; Casio CZ-1000; Fender P-Bass

#5
Jordy14
Max Output Level: -90 dBFS
  • Total Posts : 5
  • Joined: 2017/02/08 12:55:25
  • Status: offline
Re: Problems with connecting RolandA-500 Pro to Ableton 2018/11/11 14:09:52 (permalink)
Thank you kind people ;) I will try this in a week!
#6
Jordy14
Max Output Level: -90 dBFS
  • Total Posts : 5
  • Joined: 2017/02/08 12:55:25
  • Status: offline
Re: Problems with connecting RolandA-500 Pro to Ableton 2018/11/20 21:34:52 (permalink)
ah, you legend! that did the trick. Weirdly enough CTRL map 19 is not listed in the manual as the one for Ableton. Ah well, got it now :) 
#7
Jump to:
© 2018 APG vNext Commercial Version 5.1