Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time

Page: 12 > Showing page 1 of 2
Author
jb101
Max Output Level: -49.5 dBFS
  • Total Posts : 2569
  • Joined: 2011/12/04 05:26:10
  • Status: offline
2013/10/22 15:58:00 (permalink)

Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time

 Here's the recipe:
 
New project:-
 
Insert Audio Track
Insert an FX Chain module in ProChannel
Add Guitar Rig 5 to module
Clone track
Remove FX Chain Module from the cloned track (track 2) first
Remove FX Chain Module from original track (track 1) and crash..
 
Every time.
post edited by jb101 - 2013/10/22 18:03:50

 Sonar Platinum, Sonar X3e
#1

31 Replies Related Threads

    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/22 17:32:38 (permalink)
    It only happens with Guitar Rig in FX Chain Module - not if Guitar Rig is in FX Bin.
     
    No other Plug In seems to cause it.  I've tried TH2, Amplitube 3, R Mix and a few others.
     
    Only Guitar Rig shows in the Synth Rack.  Amplitube and TH2 don't.
     
    When you clone the track, there is still only one GR in the synth rack, although the two tracks both contain separate instances of GR.
     
    Coul someone try the recipe in  the above post to see if they get the same behaviour, please.

     Sonar Platinum, Sonar X3e
    #2
    wizard71
    Max Output Level: -74 dBFS
    • Total Posts : 810
    • Joined: 2012/02/12 05:45:05
    • Location: UK
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/22 17:55:17 (permalink)
    Tried this three times can't repeat crash. Any particular place in pro channel you are adding fx chain? I'm also assuming it's the latest version of GR5?
    Bibs

    http://www.youtube.com/SpaceTimeAces
    https://soundcloud.com/space-time-aces
    Sonar Platinum - Win 8.1 x64 - Haswell 4770k - ASrock Z87 pro3 - 32gb ram - Fractal design R4 case - 3x HDD 1 USB 2.0 external 1x cr M4 ssd for samples - Octa-capture - Sontronics Aria - Sontronics STC-1s - BX8 monitors - ARC 2 system - Kawai CA63 piano - Kawai MP6 Stage piano - Fender custom Telecaster FMT - Yamaha LL6 - Fender P bass


    #3
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/22 18:08:40 (permalink)
    Thanks for trying.
     
    That's odd.  Anywhere in PC seems to cause this.  Yes, latest version of GR.
     
    Are you removing the cloned track's FX Chain first, using right click - remove module?  Then removing the original track's module?
     
    Do you have the Synth Rack in view when you do?  What are you seeing there with respect to Guitar Rig?
     
    Thanks again.

     Sonar Platinum, Sonar X3e
    #4
    wizard71
    Max Output Level: -74 dBFS
    • Total Posts : 810
    • Joined: 2012/02/12 05:45:05
    • Location: UK
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/22 18:34:11 (permalink)
    Ok let me confirm my steps:
     
    1) New project (normal template)
    2) Insert Audio track
    3) Right click in pro channel > insert module> fx chain
    4) Right click in fx chain window and select guitar rig from audio fx - Guitar Rig 5 1 appears in synth rack.
    5) Right click on track 1 and select clone track (press ok and leave settings at default)
    6) The cloned track (2) fx-chain window reads 2-guitar rig 5
    7) Right click - remove module from cloned track - synth rack empties
    8) Right click - remove module from original track.
     
    No crash.
     
     Have tried this with both dual monitor and single and with patch loaded/not loaded in GR5.
     
    Is there anything i am doing wrong/differently to you?
     
    Bibs

    http://www.youtube.com/SpaceTimeAces
    https://soundcloud.com/space-time-aces
    Sonar Platinum - Win 8.1 x64 - Haswell 4770k - ASrock Z87 pro3 - 32gb ram - Fractal design R4 case - 3x HDD 1 USB 2.0 external 1x cr M4 ssd for samples - Octa-capture - Sontronics Aria - Sontronics STC-1s - BX8 monitors - ARC 2 system - Kawai CA63 piano - Kawai MP6 Stage piano - Fender custom Telecaster FMT - Yamaha LL6 - Fender P bass


    #5
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/22 19:32:35 (permalink)
    thanks again.
     
    There's a difference.  Original track shows "5-Guitar Rig 5" in FX Chain, and cloned track shows "6-Guitar Rig 5".
     
    Odd.

     Sonar Platinum, Sonar X3e
    #6
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/22 19:38:56 (permalink)
    When I open the Plug In's property window, it shows what I would expect in the title bar- "Guitar Rig 5 [1: Track 1]" and "Guitar Rig 5 [2: Track 2]",     but shows as "5-Guitar Rig 5" and "6-Guitar Rig 5" in FX Chain..

     Sonar Platinum, Sonar X3e
    #7
    Dude Ivey
    Max Output Level: -85 dBFS
    • Total Posts : 280
    • Joined: 2012/12/25 01:28:32
    • Location: Athens, Texas
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/22 20:05:34 (permalink)
    I just tried this and mine crashed immediately after removing the module on the original track!

    X-3e/X-2a, Windows 7 64bit, Intel i7-2600, 16Gb ram, 4 Tb HDD, 32 inch monitor, RME FireFace UFX, Shure SRH1840 Headphones, KRK Rockit 5 monitors w/ KRK 10 inch sub and 3 Dachshunds.
    #8
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/22 20:23:42 (permalink)
    Thanks for trying it, Dude Ivy.
     
    Guess we need to find what causes this on your system (and mine), but not wizard71's.

     Sonar Platinum, Sonar X3e
    #9
    wizard71
    Max Output Level: -74 dBFS
    • Total Posts : 810
    • Joined: 2012/02/12 05:45:05
    • Location: UK
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/22 20:24:41 (permalink)
    Hmmm that is strange, it reads as expected for me in fx chains.
    What about yours Dude Ivey?

    Edit: I should add that due to a new PC I have a fresh install of both OS and X3b and all plugins with no other versions of sonar yet installed.

    Bibs

    http://www.youtube.com/SpaceTimeAces
    https://soundcloud.com/space-time-aces
    Sonar Platinum - Win 8.1 x64 - Haswell 4770k - ASrock Z87 pro3 - 32gb ram - Fractal design R4 case - 3x HDD 1 USB 2.0 external 1x cr M4 ssd for samples - Octa-capture - Sontronics Aria - Sontronics STC-1s - BX8 monitors - ARC 2 system - Kawai CA63 piano - Kawai MP6 Stage piano - Fender custom Telecaster FMT - Yamaha LL6 - Fender P bass


    #10
    Dude Ivey
    Max Output Level: -85 dBFS
    • Total Posts : 280
    • Joined: 2012/12/25 01:28:32
    • Location: Athens, Texas
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/22 21:13:39 (permalink)
    It reads 3-Guitar Rig5 and the clone reads 4-Guitar Rig5. I also tried it by adding two audio tracks and not cloning and there was no crash.

    X-3e/X-2a, Windows 7 64bit, Intel i7-2600, 16Gb ram, 4 Tb HDD, 32 inch monitor, RME FireFace UFX, Shure SRH1840 Headphones, KRK Rockit 5 monitors w/ KRK 10 inch sub and 3 Dachshunds.
    #11
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 04:53:14 (permalink)
    No, it does seem very specific to the steps outlined above.

    Two of things about it intrigue me -

    The strange naming of GR in the FX Chain module

    The fact that GR only appears once in the synth rack after cloning.

    The fact that wizard71 is not seeing it.


    Okay, the three main weapons of the Spanish Inquisition are surprise....

     Sonar Platinum, Sonar X3e
    #12
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 04:54:27 (permalink)
    Thank you both for responding, by the way.

     Sonar Platinum, Sonar X3e
    #13
    Roo Stercogburn
    Max Output Level: -90 dBFS
    • Total Posts : 44
    • Joined: 2013/07/08 05:27:45
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 05:11:35 (permalink)
    I find the cloning feature very buggy. I get random crashes but can't remember which plugs it was, got a feeling it was different plugs. After it happened a few times I just stopped using the feature.
    #14
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 12:55:34 (permalink)
    Roo Stercogburn
    I find the cloning feature very buggy. I get random crashes but can't remember which plugs it was, got a feeling it was different plugs. After it happened a few times I just stopped using the feature.




    I've not had any problems with cloning tracks before this.
     
    Anyone else?

     Sonar Platinum, Sonar X3e
    #15
    wizard71
    Max Output Level: -74 dBFS
    • Total Posts : 810
    • Joined: 2012/02/12 05:45:05
    • Location: UK
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 13:03:36 (permalink)
    jb101
    Thank you both for responding, by the way.


    A pleasure, hope it gets sorted soon!

    If you want me to try any other version of events, I'd be happy to.

    Bibs

    http://www.youtube.com/SpaceTimeAces
    https://soundcloud.com/space-time-aces
    Sonar Platinum - Win 8.1 x64 - Haswell 4770k - ASrock Z87 pro3 - 32gb ram - Fractal design R4 case - 3x HDD 1 USB 2.0 external 1x cr M4 ssd for samples - Octa-capture - Sontronics Aria - Sontronics STC-1s - BX8 monitors - ARC 2 system - Kawai CA63 piano - Kawai MP6 Stage piano - Fender custom Telecaster FMT - Yamaha LL6 - Fender P bass


    #16
    lawp
    Max Output Level: -67 dBFS
    • Total Posts : 1200
    • Joined: 2012/06/28 13:27:41
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 13:22:54 (permalink)
    strange naming could be effected by the new plugin naming options
    #17
    stevec
    Max Output Level: -19.5 dBFS
    • Total Posts : 5581
    • Joined: 2003/11/04 15:05:54
    • Location: Parkesburg, PA
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 14:29:48 (permalink)
    It might be worth sending the project into CW for review... or maybe working with the support group first.  You may as well take advantage of a project that's already in that state.
     
    #18
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 14:50:42 (permalink)
    Thanks, Steve, I may do.  This is even happening on a new project, with only the steps above being performed.

     Sonar Platinum, Sonar X3e
    #19
    stevec
    Max Output Level: -19.5 dBFS
    • Total Posts : 5581
    • Joined: 2003/11/04 15:05:54
    • Location: Parkesburg, PA
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 14:56:21 (permalink)
    Definitely worthwhile IMHO!  There's obviously something to it, so if CW can figure out what that something is, all the better.
     
    #20
    Lance Riley [Cakewalk]
    Moderator
    • Total Posts : 61
    • Joined: 2011/05/17 17:18:01
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 17:19:27 (permalink)
    This look like it's an issue related to a change made in X3. Plug-ins that support MIDI OUT now automatically get ports enabled. This makes using things like stutter edit or vocoders easier to work with in SONAR. Were looking into this issue and should have a resolution soon. For now you can get around the issue by copy dragging the plug-in to the other bin or FX Chain.

    Lance Riley
    Product Manager
    #21
    Featherlight
    Max Output Level: -82 dBFS
    • Total Posts : 430
    • Joined: 2004/03/15 20:53:25
    • Location: The Great Northwest
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/23 17:38:40 (permalink)
    Cloning working very stable here as well and no luck reproducing the above steps but I'm working with Guitar Rig4 not 5.
    Hope you get it sorted as well.

    http://www.featherlightstudio.com/studio
     
    Computer: Intel i7 Quad, Intel P7P55D mobo, 16gig Corsair, Nvidia 8600gs Fanless
    OS: Windows 7 Professional 64 bit
    -----------------------------------------------------
    Computer: Mac Mini i7 Quad Core Server, Intel mobo, 16 gig DDR3, 2-USB3 Audio Drvs, Mavericks
    -----------------------------------------------------
    Audio Interface: Mackie 1640i Firewire Mixer on a 1394 400 TI Chip
    Peripherals: 3 UAD-1 PCie, Ilok 2, MIDI'd Yamaha Motif xs,
    #22
    mettelus
    Max Output Level: -46.5 dBFS
    • Total Posts : 2890
    • Joined: 2005/08/05 03:19:25
    • Location: Maryland, USA
    • Status: online
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/24 08:58:45 (permalink)
    jb101 - Quick question for you. I had a GR5 issue which was not obvious but causing a bug of patches switching. This did not occur in GR4.
     
    Open GR5 and go to the "Options" at the top. In the left pane, I removed the controller (NI suggested the controller settings were doing it), but this didn't fix it for me.
     
    On the right hand pane ("Preferences"), there is a setting near the bottom called "Rig Kontrol 1" which was defaulted to a channel. When I set "Rig Kontrol 1" to "Off" all of my issues went away. It appears that in stereo audio that controller information was being embedded into (or read from) the Left Channel on me.

    ASUS P8P67 Pro (B3), i7-2600k, 8GB RAM, SSD and HDD, ASUS GTX-580 w/dual monitors, Win 7 x64U, Sonar Platinum, X3e, X2a, X1d x64, Saffire PRO 24 DSP, A-300 PRO, plus numerous gadgets and gizmos that make or manipulate sound in some way.
    #23
    Roo Stercogburn
    Max Output Level: -90 dBFS
    • Total Posts : 44
    • Joined: 2013/07/08 05:27:45
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/24 09:14:52 (permalink)
    jb101
    Roo Stercogburn
    I find the cloning feature very buggy. I get random crashes but can't remember which plugs it was, got a feeling it was different plugs. After it happened a few times I just stopped using the feature.




    I've not had any problems with cloning tracks before this.
     
    Anyone else?




    Apologies, don't think I was clear. I was referring only to the copying/cloning of FX. Cloning whole tracks has always been fine. FX copying is like a lottery where I'm never sure if it will work or crash Sonar itself. Again, sorry if I've misunderstood the original problem. If I clone a track I always junk the FX after cloning or am careful not to have any FX on the track I clone. Admittedly I mostly put FX on a bus rather than on an audio track itself thus sidestepping the issue.
    #24
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/24 10:59:04 (permalink)
    mettelus
    jb101 - Quick question for you. I had a GR5 issue which was not obvious but causing a bug of patches switching. This did not occur in GR4.
     
    Open GR5 and go to the "Options" at the top. In the left pane, I removed the controller (NI suggested the controller settings were doing it), but this didn't fix it for me.
     
    On the right hand pane ("Preferences"), there is a setting near the bottom called "Rig Kontrol 1" which was defaulted to a channel. When I set "Rig Kontrol 1" to "Off" all of my issues went away. It appears that in stereo audio that controller information was being embedded into (or read from) the Left Channel on me.




     
    Thanks, I'll have a look when I get a chance.
     
    And thank you again for everyone who took the time to post..

     Sonar Platinum, Sonar X3e
    #25
    mettelus
    Max Output Level: -46.5 dBFS
    • Total Posts : 2890
    • Joined: 2005/08/05 03:19:25
    • Location: Maryland, USA
    • Status: online
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/25 06:15:28 (permalink)
    I am curious if this helps, since in *may* be linked to SONAR adding a synth to accommodate the MIDI from GR5. If that MIDI input suddenly "disappears," SONAR may be having a hiccup.
     
    I multi-task too much, so will minimize SONAR, forget it is on, and power off my ASIO controller... and that gives SONAR (and Win7) a seizure every time, lol. Locks the computer so bad I have to do a forced restart.
     
    Michael

    ASUS P8P67 Pro (B3), i7-2600k, 8GB RAM, SSD and HDD, ASUS GTX-580 w/dual monitors, Win 7 x64U, Sonar Platinum, X3e, X2a, X1d x64, Saffire PRO 24 DSP, A-300 PRO, plus numerous gadgets and gizmos that make or manipulate sound in some way.
    #26
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2013/10/25 07:25:05 (permalink)
    Interesting one, mettulus, that sounds plausible.

    It's interesting that you can remove the module from the original track, and then the clone with no issue. It's only if you remove clone first, and then the original that causes the crash.

    I've been rushed off my feet for the last few days, but will try out some of the ideas posted here. I know it has been submitted to devs, and that Dan G is looking into it, so we should get an answer somewhere along the line.

    Thank again, everyone.

     Sonar Platinum, Sonar X3e
    #27
    gswitz
    Max Output Level: -35.5 dBFS
    • Total Posts : 3997
    • Joined: 2007/06/16 07:17:14
    • Location: Richmond Virginia USA
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2014/01/08 20:09:40 (permalink)
    JB101,
     
    I tried to replicate with GR4 (Sonar version, not full) and I could not replicate the problem.
    #28
    Splat
    Max Output Level: 0 dBFS
    • Total Posts : 8985
    • Joined: 2010/12/29 15:28:29
    • Location: Mars.
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2014/01/08 20:26:10 (permalink)
    Ditto Guitar Rig 5.2.0 and X3D Pro, no crash.

    Sell by date at 9000 posts. Do not feed.
    @48/24 & 128 buffers latency is 367 with offset of 38.

    Sonar Platinum(64 bit),Win 8.1(64 bit),Saffire Pro 40(Firewire),Mix Control = 3.4,Firewire=VIA,Dell Studio XPS 8100(Intel Core i7 CPU 2.93 Ghz/16 Gb),4 x Seagate ST31500341AS (mirrored),GeForce GTX 460,Yamaha DGX-505 keyboard,Roland A-300PRO,Roland SPD-30 V2,FD-8,Triggera Krigg,Shure SM7B,Yamaha HS5.Maschine Studio+Komplete 9 Ultimate+Kontrol Z1.Addictive Keys,Izotope Nectar elements,Overloud Bundle,Geist.Acronis True Image 2014.
    #29
    jb101
    Max Output Level: -49.5 dBFS
    • Total Posts : 2569
    • Joined: 2011/12/04 05:26:10
    • Status: offline
    Re: Removing FX Chain with Guitar Rig/cloned track - Crashing Sonar every time 2014/01/09 04:44:08 (permalink)
    CakeAlexS
    Ditto Guitar Rig 5.2.0 and X3D Pro, no crash.


    No crash because this issue was fixed in X3b or X3c, after I had made Cakewalk aware of it.

    If you'd bothered to read any of the posts you would have noticed the date and Lance of Cakewalk's comment.
    post edited by jb101 - 2014/01/09 10:47:54

     Sonar Platinum, Sonar X3e
    #30
    Page: 12 > Showing page 1 of 2
    Jump to:
    © 2015 APG vNext Commercial Version 5.1