"Reset MIDI" Button Won't Work

Author
Creator
Max Output Level: -87 dBFS
  • Total Posts : 170
  • Joined: 2004/01/14 20:54:23
  • Status: offline
2008/08/29 07:24:22 (permalink)

"Reset MIDI" Button Won't Work

Usually when Sonar stops responding I can just hit the "Rest MIDI" button and in addition a MIDI reset, the audio engine will stop running and playback will stop. Lately this doesn't work.

Sometimes I'll start playback and the transport will move but nothing will happen. The meter will show no sound activity, I won't be able to stop playback or close the program. This will sometimes happen during a session that's been working fine.

Since I can't even quite the program, I'll typically have to end process and restart Sonar and sometimes it will start running again. Other times I'll have to reboot the whole computer before it will start responding again.

Has anybody else encountered this problem?

I am running Sonar PE 7.0.2 on Windows XP Pro SP 2 on a P4 3.2 GHz with HT disabled, and a 2048 sample ASIO buffer on an Audiophile 2496.
#1

16 Replies Related Threads

    CJaysMusic
    Max Output Level: 0 dBFS
    • Total Posts : 30423
    • Joined: 2006/10/28 01:51:41
    • Location: Miami - Fort Lauderdale - Davie
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/08/29 07:29:56 (permalink)
    2048 is pretty high. I think your taxing your single core pc too much. Try freezing some tracks. I assume this is on a project with many tracks and many plugins
    Cj

    www.audio-mastering-mixing.com - A Professional Worldwide Audio Mixing & Mastering Studio, Providing Online And Attended Sessions. We also do TV commercials, Radio spots & spoken word books
    Audio Blog
    #2
    Creator
    Max Output Level: -87 dBFS
    • Total Posts : 170
    • Joined: 2004/01/14 20:54:23
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/08/29 07:35:27 (permalink)
    Unfortunately, no. This is happening across the board, even on projects where I just add a single audio track to a blank template.
    #3
    Creator
    Max Output Level: -87 dBFS
    • Total Posts : 170
    • Joined: 2004/01/14 20:54:23
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/08/29 07:36:39 (permalink)
    It almost seems random because, as mentioned earlier, if I reboot and open the same project without changing anything, it will generally work. Lately I've been having to hard reboot a lot lately since I can't even end the SONARPDR.exe process from the Task Manager.
    post edited by Creator - 2008/08/29 07:37:44
    #4
    CJaysMusic
    Max Output Level: 0 dBFS
    • Total Posts : 30423
    • Joined: 2006/10/28 01:51:41
    • Location: Miami - Fort Lauderdale - Davie
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/08/29 07:42:25 (permalink)
    What other processes are enabled in your pc?? It sounds like something is turnign something off or going into sleep mode for that to happen. Hows your power managment options set to?? hows the power mgn for your usb hubs set to??
    what are your other sound card specs?? Have you tried WDM and ASIO driver modes???
    Cj

    www.audio-mastering-mixing.com - A Professional Worldwide Audio Mixing & Mastering Studio, Providing Online And Attended Sessions. We also do TV commercials, Radio spots & spoken word books
    Audio Blog
    #5
    Creator
    Max Output Level: -87 dBFS
    • Total Posts : 170
    • Joined: 2004/01/14 20:54:23
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/08/29 07:55:42 (permalink)
    Power management is disabled (i.e. everything is set to never power down).

    I haven't tried WDM drivers, just ASIO. That's because the 12 or so times I've tried WDM drivers in the 4 years I've been using Sonar with M-Audio products I encountered an array of issues with them. Even when I was "succesful" I couldn't get similar performance to the ASIO drivers.
    #6
    Creator
    Max Output Level: -87 dBFS
    • Total Posts : 170
    • Joined: 2004/01/14 20:54:23
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/08/29 07:58:02 (permalink)
    What's the simplest way to create a boot just for debugging Sonar? That way I could disable all the tray applications, etc., but not have all the hassle of "safe mode".
    #7
    Rbh
    Max Output Level: -52 dBFS
    • Total Posts : 2349
    • Joined: 2007/09/05 22:33:44
    • Location: Indiana
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/08/29 08:27:22 (permalink)
    You might try WDM drivers again and be sure to re-profile the card each time you make a change. For a start point I would try 2 buffers @ 256K. Reprofile and restart. It sounds to me like you're just not dialed in timing wise. Usually the difference between ASIO and WDM is at most a few ms less latency providing that the drivers are well written. The benefit is that changing buffers on the fly is easier with WDM.

    I7 930 2.8 Asus PDX58D
    12 Gig
    Appollo
    CbB, Sonar Pro, Reaper, Samplitude, MixBuss
     Win7 Pro

    http://www.soundclick.com/bands/default.cfm?bandID=902832
    #8
    Creator
    Max Output Level: -87 dBFS
    • Total Posts : 170
    • Joined: 2004/01/14 20:54:23
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/08/29 08:39:30 (permalink)
    Okay, I'm taking another shot with WDM.

    I re-profiled the AP 2496 with WDM and the furthest left it will go is... 46.4 ms with 2 buffers in playback queue.

    EDIT: I got it lower with the information from this thread - http://forum.cakewalk.com/tm.asp?m=1442562&mpage=1&key=�
    post edited by Creator - 2008/08/29 08:51:45
    #9
    Creator
    Max Output Level: -87 dBFS
    • Total Posts : 170
    • Joined: 2004/01/14 20:54:23
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/08/31 19:49:33 (permalink)
    Okay, now that I've tried using the WDM driver for a while, I can report that the error has only changed slightly, not gone away.

    Now, what will happen, is the same thing except as before except that now the transport won't even move.

    Any ideas?
    #10
    Creator
    Max Output Level: -87 dBFS
    • Total Posts : 170
    • Joined: 2004/01/14 20:54:23
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/09/07 19:11:30 (permalink)
    Still nothing? Nobody else has this issue?
    #11
    d45
    Max Output Level: -88 dBFS
    • Total Posts : 112
    • Joined: 2008/09/07 16:06:46
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/09/08 00:51:22 (permalink)
    I only started using Sonar this weekend having moved from Cubase but what you are experiencing can be caused by dodgy VSTs in Cubase, are you using any in your project?
    #12
    Creator
    Max Output Level: -87 dBFS
    • Total Posts : 170
    • Joined: 2004/01/14 20:54:23
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/09/08 03:19:06 (permalink)
    I'll double check the VSTs. It sometimes happens very early on in projects so it may happen before I even load a VST (when I'm just recording MIDI with a stage piano), but I can't remember at the moment.

    Worth checking out.
    #13
    jim y
    Max Output Level: -76 dBFS
    • Total Posts : 721
    • Joined: 2003/11/08 13:16:43
    • Location: The Middle of Wales.
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/09/08 05:32:55 (permalink)
    I would definitely suspect a VST plug in - is there one you only started using recently? Any made in Synth Edit? Any particularly old ones? Some old plugs don't like being used more than once in a project on a multicore processor PC.
    AFAIK, the common cause of the hang up is that some VST plugs don't stop & exit when Sonar tells them to - the commands Sonar uses are either not understood by them or not explicit enough.

    You're nearly there with the WDM profiling - what I would have done is set the cards driver buffer to 256 and then open Sonar and run the profiler. The WDM/KS latency is based on multiples of the cards buffer and won't go lower than it.

    Jim


    Yes, I know it's upside down.
    #14
    Creator
    Max Output Level: -87 dBFS
    • Total Posts : 170
    • Joined: 2004/01/14 20:54:23
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/09/08 17:23:35 (permalink)
    Yes, I had already figured out the wave profiler issue earlier based on the other thread, but thanks for clarifying that for me nonetheless. :)

    As far as the VSTs and VSTis, I'm running a single core P4 with HT disabled. In addition, the problem is both starting and stopping, not just stopping.

    In other words, sometimes the transport will start and there will be no signal showing up on any tracks. Then I reboot and re-open the same file and everything works fine.

    I am not sure whether the projects use any VSTs I've only started using recently. I'll try and check that.
    #15
    jim y
    Max Output Level: -76 dBFS
    • Total Posts : 721
    • Joined: 2003/11/08 13:16:43
    • Location: The Middle of Wales.
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/09/09 02:29:53 (permalink)
    Afraid it could be more of a computer setup problem.
    Disc drives on PIO instead of DMA transfer.
    Some device throttling the pci bus - search for "dpc latency check".
    Virus scanner running.
    Too many possibilities to detail right now!

    Jim


    Yes, I know it's upside down.
    #16
    jim y
    Max Output Level: -76 dBFS
    • Total Posts : 721
    • Joined: 2003/11/08 13:16:43
    • Location: The Middle of Wales.
    • Status: offline
    RE: "Reset MIDI" Button Won't Work 2008/09/09 11:48:10 (permalink)
    Now I have a bit more time...

    You could try the card in a different pci slot. As you have a P4, you may also have an AGP graphics and that can compete with certain pci slots - usually the one nearest the graphics card.
    Also search for "pci latency timer". If you have a greedy AGP card - or sometimes a network adapter or Raid controller can cause it, there is a way to "throttle" them.

    Jim

    Yes, I know it's upside down.
    #17
    Jump to:
    © 2022 APG vNext Commercial Version 5.1