Helpful ReplySetting buffer size on sound card and SONAR

Author
nollies1
Max Output Level: -89 dBFS
  • Total Posts : 71
  • Joined: 2008/10/18 16:16:23
  • Location: DC metro
  • Status: offline
2009/05/03 22:12:56 (permalink)

Setting buffer size on sound card and SONAR

Symptoms:
Using ASIO driver. Recording single track sounds ok, minimal popping sounds. Recording six at once = horrible drops and such with an occasional crash

Current settings:
A) Sound Card (Project Mix I/O): Sample rate 44100 Hz; ASIO/WDM buffer size 128 samples
B) SONAR Audio Options:
-General tab: 2.9 msec; 128 samples. ASIO In and out 5.4 msec and 236 samples, roundtrip 10.7 msec, 472 samples
-Advanced tab: Playback I/O 128 KB and record I/O 128 KB; Use ASIO reprted latency (236) is checked

As I am trying to learn what the relationship is between each of these settings, I did a few things here and there, only to make the drops worse. I next tried to determine what parameters change when you input a value in one of these.

Given:
1= ASIO/WDM buffer size on sound card
2= Buffer size in Audio options -> General tab
3= ASIO Input and Output (and total roundtrip) reported latencies, also general tab
4= Advanced tab; Playback I/O and Record I/O
5= Checkbox for "use ASIO reported latency"

Expt. A
Increase 1 from 128 to 384
Result: 2 doubles; 3 doubles; 4 stays the same; 5 doubles

Expt. B
set 1 back to 128; Increase 4 from 128 to 384
Result: All stay the same

So, To me it seems logical to simply match the setting in "4" with everything else. But, doing so at four different latencies attempted (128, 256, 384, 512) does not remove the drops.

I'm pretty sure I even matched "4" with the values in "total roundtrip" rather than only In or Out. Your thoughts on troubleshooting would be very much appreciated. I will answer any questions as best I can.

SONAR 8 PE (8.3.1.372)
M-Audio Project Mix I/O
Edirol PCR-300 (darn I should've gotten the 500 lol)
Lenovo T61
XP SP3
Intel T7300 Core 2 Duo (2.0GHz, 800MHz FSB, 4MB Cache)
100GB 7200RPM (Seagate Momentus 7200.1)
4GB RAM (2GB x 2GB)... but really only 3GB I have been told, being 32 bit
#1
DW_Mike
Max Output Level: -6 dBFS
  • Total Posts : 6907
  • Joined: 2006/11/29 18:06:40
  • Location: The arm-pit of the good 'ol US...New Jersey
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/03 22:49:44 (permalink)
Try setting your Playback and Record Buffers (#4 as per your post) to 256.
Of course you will still have to adjust the latency settings in your soundcard or under the general tab in Sonar. Start with the soundcard set to 128 then increase the latency until you get the result you want. If that doesn't work, raise the Record and Playback Buffers to 512 and lather, rinse, repeat. It will take a little trial and error but eventually you will find what works. 512 seems to be the most stable for me on my set up.

Then as you add more tracks and or effects you will have to adjust the latency again.

Mike
post edited by chefmike8888 - 2009/05/03 23:14:12

Sonar X3 ~ Scarlett 18i6 ~ Home Build DAW  
GA-Z77X-UD5H
Intel i7 3770k 4.2GHz
32GB RAM Crucial Ballistix Elite (4x8) 
2x Samsung 250GB SSD 
1TB WD Black HDD @ 7200RPM 6Gb/s 64MB 
Corsair H80i Liquid cooler 
Noctua Silent Fans ~ 3x120mm ~ 1x140mm 
Seasonic Platinum 760w PSU 
Windows 7 Pro 64Bit.
#2
SongCraft
Max Output Level: -36 dBFS
  • Total Posts : 3902
  • Joined: 2007/09/19 17:54:46
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/03 23:31:00 (permalink)
Not sure what version of SONAR you have. If you change the buffers you need to 'Re-Profile' run the Wave Profile and reboot. By not doing this could be the reason why you're getting drop outs and risk get 'argument error' (crash). Also make double sure you have the latest driver for your audio interface.

When I'm using Softsynths I can set the buffers down really low to 64 and get really good results (low latency) for tracking/recording, but when mixing with tons of effects, mastering suites piled on I up the buffers to 128 and raise the latency because at that point of the project latency isn't so much a concern. That said... all systems are different and requires different settings, you may need to set your buffers higher (128 to 256) should do it. You can usually tell if you have a good setting, the disk meter shouldn't exceed 50% and the CPU should stay below 50, on my setup it's 15% cpu and 35% disk, if I up the buffers more I can reduce those levels but latency will increase.

 
 
#3
Kalle Rantaaho
Max Output Level: -5 dBFS
  • Total Posts : 7005
  • Joined: 2006/01/09 13:07:59
  • Location: Finland
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/04 03:26:43 (permalink)

ORIGINAL: SongCraft
Not sure what version of SONAR you have. If you change the buffers you need to 'Re-Profile' run the Wave Profile and reboot.


IIRC you can't use Wave Profiler with ASIO.

SONAR PE 8.5.3, Asus P5B, 2,4 Ghz Dual Core, 4 Gb RAM, GF 7300, EMU 1820, Bluetube Pre  -  Kontakt4, Ozone, Addictive Drums, PSP Mixpack2, Melda Creative Pack, Melodyne Plugin etc.
The benefit of being a middle aged amateur is the low number of years of frustration ahead of you.
#4
bitflipper
01100010 01101001 01110100 01100110 01101100 01101
  • Total Posts : 26036
  • Joined: 2006/09/17 11:23:23
  • Location: Everett, WA USA
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/04 11:18:01 (permalink)
There is, I think, no direct relationship between the record and playback I/O buffers and the ASIO/WDM buffers. At least, it isn't necessary to correlate them. If there were a direct correlation, CW would not have exposed the I/O buffers as a separate parameter.

As you observed, increasing the ASIO buffer size increases latency. That's the fundamental tradeoff: the bigger buffer gives the CPU more time to process data between buffer cycles and eliminates pops/clicks, but at the cost of increased latency. These buffers are between the computer and the audio interface.

I/O buffers, by contrast, sit between the application and the Windows file system. ("I/O" does not refer to audio I/O, but rather disk I/O.) They have an entirely different purpose than the ASIO or WDM buffers. They also do not affect latency - only the efficiency with which data is written to and read from the disk drive.

Although they do not affect latency, I/O buffer size can have an impact on pops and clicks. If they're too small, the process of saving and reading data on disk becomes inefficient, increasing CPU usage and possibly exacerbating dropouts.

If you are not recording with soft synths or software DSP effects, leave the ASIO buffer at a high setting, since minimal latency is only important when you need to hear sound processed by the computer while tracking. 256, 384 or 512 work fine for most people, although the ideal setting may require some experimentation.


All else is in doubt, so this is the truth I cling to. 

My Stuff
#5
nollies1
Max Output Level: -89 dBFS
  • Total Posts : 71
  • Joined: 2008/10/18 16:16:23
  • Location: DC metro
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/04 12:54:16 (permalink)

ORIGINAL: chefmike8888

512 seems to be the most stable for me on my set up.



thanks mike... was 512 set on your sound card or are you referring to the rec/playback buffer settings in SONAR? Also, has anyone noticed a 'general rule' even if they can't really be correlated? For instance, do you always want 2x more I/O buffer than what you have set on your card? stuff like that? Or lol am I thinking about this stuff too simple-mindedly?

SONAR 8 PE (8.3.1.372)
M-Audio Project Mix I/O
Edirol PCR-300 (darn I should've gotten the 500 lol)
Lenovo T61
XP SP3
Intel T7300 Core 2 Duo (2.0GHz, 800MHz FSB, 4MB Cache)
100GB 7200RPM (Seagate Momentus 7200.1)
4GB RAM (2GB x 2GB)... but really only 3GB I have been told, being 32 bit
#6
nollies1
Max Output Level: -89 dBFS
  • Total Posts : 71
  • Joined: 2008/10/18 16:16:23
  • Location: DC metro
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/04 12:58:18 (permalink)

ORIGINAL: SongCraft

You can usually tell if you have a good setting, the disk meter shouldn't exceed 50% and the CPU should stay below 50, on my setup it's 15% cpu and 35% disk, if I up the buffers more I can reduce those levels but latency will increase.


Thx SC... are you referring to the task manager? or a tab somewhere in sonar? just tryin to learn thanks

SONAR 8 PE (8.3.1.372)
M-Audio Project Mix I/O
Edirol PCR-300 (darn I should've gotten the 500 lol)
Lenovo T61
XP SP3
Intel T7300 Core 2 Duo (2.0GHz, 800MHz FSB, 4MB Cache)
100GB 7200RPM (Seagate Momentus 7200.1)
4GB RAM (2GB x 2GB)... but really only 3GB I have been told, being 32 bit
#7
SongCraft
Max Output Level: -36 dBFS
  • Total Posts : 3902
  • Joined: 2007/09/19 17:54:46
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/04 13:02:49 (permalink)
Displayed in Sonar.

btw, I noticed you updated your sig! You're using S8.PE, have you installed the latest update for it? ;)

 
 
#8
nollies1
Max Output Level: -89 dBFS
  • Total Posts : 71
  • Joined: 2008/10/18 16:16:23
  • Location: DC metro
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/04 13:06:12 (permalink)

ORIGINAL: bitflipper

If you are not recording with soft synths or software DSP effects, leave the ASIO buffer at a high setting, since minimal latency is only important when you need to hear sound processed by the computer while tracking. 256, 384 or 512 work fine for most people, although the ideal setting may require some experimentation.


excellent, thanks for the explanation.

well... i technically (for what we're doing right now) can get by without soft synths or DSP effects, but in principle i'd like to delve there at some point... e.g. thought it would be fun to try messing with guitar rig 3 and such in a 'live' session. but that will be down the road i assume. for now, just trying to get past this hiccup.

if you check out the specs in my sig, although it's not lightning speed, I've talked to a few buddies in the area, and they were quite surprized that it hangs up the way it does however. would you agree? thanks

SONAR 8 PE (8.3.1.372)
M-Audio Project Mix I/O
Edirol PCR-300 (darn I should've gotten the 500 lol)
Lenovo T61
XP SP3
Intel T7300 Core 2 Duo (2.0GHz, 800MHz FSB, 4MB Cache)
100GB 7200RPM (Seagate Momentus 7200.1)
4GB RAM (2GB x 2GB)... but really only 3GB I have been told, being 32 bit
#9
nollies1
Max Output Level: -89 dBFS
  • Total Posts : 71
  • Joined: 2008/10/18 16:16:23
  • Location: DC metro
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/04 13:08:28 (permalink)
yes, thanks for asking tho... in fact... that's a separate issue altogether; my guitar rig claims I do not have a licence to it anymore... but crashes everytime I try to 'register'... still working on that one.
ORIGINAL: SongCraft

Displayed in Sonar.

btw, I noticed you updated your sig! You're using S8.PE, have you installed the latest update for it? ;)


SONAR 8 PE (8.3.1.372)
M-Audio Project Mix I/O
Edirol PCR-300 (darn I should've gotten the 500 lol)
Lenovo T61
XP SP3
Intel T7300 Core 2 Duo (2.0GHz, 800MHz FSB, 4MB Cache)
100GB 7200RPM (Seagate Momentus 7200.1)
4GB RAM (2GB x 2GB)... but really only 3GB I have been told, being 32 bit
#10
DW_Mike
Max Output Level: -6 dBFS
  • Total Posts : 6907
  • Joined: 2006/11/29 18:06:40
  • Location: The arm-pit of the good 'ol US...New Jersey
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/04 14:31:26 (permalink)
ORIGINAL: nollies1


ORIGINAL: chefmike8888

512 seems to be the most stable for me on my set up.



thanks mike... was 512 set on your sound card or are you referring to the rec/playback buffer settings in SONAR? Also, has anyone noticed a 'general rule' even if they can't really be correlated? For instance, do you always want 2x more I/O buffer than what you have set on your card? stuff like that? Or lol am I thinking about this stuff too simple-mindedly?

I'm referring to the I/O Buffer under Options/Audio/Advanced. And no, there are no sure shot equations like 2x a certain setting and one part of this setting. Even If we had the same exact PC - software - hardware set up, the settings would most likely still be different for each PC.

Mike
post edited by chefmike8888 - 2009/05/04 14:40:25

Sonar X3 ~ Scarlett 18i6 ~ Home Build DAW  
GA-Z77X-UD5H
Intel i7 3770k 4.2GHz
32GB RAM Crucial Ballistix Elite (4x8) 
2x Samsung 250GB SSD 
1TB WD Black HDD @ 7200RPM 6Gb/s 64MB 
Corsair H80i Liquid cooler 
Noctua Silent Fans ~ 3x120mm ~ 1x140mm 
Seasonic Platinum 760w PSU 
Windows 7 Pro 64Bit.
#11
nollies1
Max Output Level: -89 dBFS
  • Total Posts : 71
  • Joined: 2008/10/18 16:16:23
  • Location: DC metro
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/04 23:07:17 (permalink)
OK...

I have systematically gone through all combinations between what I can set on the card and what I can set in SONAR...well, I went up to 1024 on the card and 768 in SONAR... all present the same symptoms of mild but noticeable drops.

I kept my eye on the CPU and Disk % usage and they are always quite low (no more than a FEW %). I am beginning to wonder if there is another cause.

Prior to me trying to figure out this buffer size issue I have also: a) set windows for "best performance"; b) got a 'dedicated' firewire adapter (for the project mix); and c) all the random stuff like different cables, disabled IRQs, unplugged the cord to my laptop, etc. Oh and I reinstalled the software too, and all updates as well.

Any other thoughts on how to troubleshoot? Thanks

SONAR 8 PE (8.3.1.372)
M-Audio Project Mix I/O
Edirol PCR-300 (darn I should've gotten the 500 lol)
Lenovo T61
XP SP3
Intel T7300 Core 2 Duo (2.0GHz, 800MHz FSB, 4MB Cache)
100GB 7200RPM (Seagate Momentus 7200.1)
4GB RAM (2GB x 2GB)... but really only 3GB I have been told, being 32 bit
#12
DW_Mike
Max Output Level: -6 dBFS
  • Total Posts : 6907
  • Joined: 2006/11/29 18:06:40
  • Location: The arm-pit of the good 'ol US...New Jersey
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/04 23:13:51 (permalink)
Do you have an anti virus program running or maybe another app? Have you tried turning off your wireless connection. How about trying WDM/KS instead of ASIO.

Mike
post edited by chefmike8888 - 2009/05/04 23:23:26

Sonar X3 ~ Scarlett 18i6 ~ Home Build DAW  
GA-Z77X-UD5H
Intel i7 3770k 4.2GHz
32GB RAM Crucial Ballistix Elite (4x8) 
2x Samsung 250GB SSD 
1TB WD Black HDD @ 7200RPM 6Gb/s 64MB 
Corsair H80i Liquid cooler 
Noctua Silent Fans ~ 3x120mm ~ 1x140mm 
Seasonic Platinum 760w PSU 
Windows 7 Pro 64Bit.
#13
nollies1
Max Output Level: -89 dBFS
  • Total Posts : 71
  • Joined: 2008/10/18 16:16:23
  • Location: DC metro
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/05 09:31:02 (permalink)
I'll go and try that stuff tonight... but seriously stuff like wireless and anti virus is enough to do it?

WDM is certainly an option, haven't messed too much with it, primarily out of ignorance I suppose. The rationalle was more or less
1) Nobody seems to like WDM with SONAR, every thread I've read seems to suggest ASIO is preferred.
2) If WDM is used in SONAR, then (if I recall) adjusting the buffer of the sound card no longer has an influence... because WDM uses a "native windows driver", the name of which (or any possible settings to tinker with) I have yet to find. Any takers on that?
3) The latency calculated by the profiler is never at or lower than that obtained with ASIO

A few other things I was told may be worth trying:
- Use "ASIO4ALL" driver... I guess it's downloadable on the web somewhere?
- Delete the AUD.ini file altogether

One thing I HAVE done that is a bit eyebrow raising:
- Installed Reaper, used ASIO driver, and default (i.e. didn't do anything) settings
- Result: PERFECT. Not a single hiccup.
- BUT I don't know how to tell the project mix to work with reaper. And besides, it doesn't really solve the SONAR problem, just negates it.

Any thoughts?

SONAR 8 PE (8.3.1.372)
M-Audio Project Mix I/O
Edirol PCR-300 (darn I should've gotten the 500 lol)
Lenovo T61
XP SP3
Intel T7300 Core 2 Duo (2.0GHz, 800MHz FSB, 4MB Cache)
100GB 7200RPM (Seagate Momentus 7200.1)
4GB RAM (2GB x 2GB)... but really only 3GB I have been told, being 32 bit
#14
DW_Mike
Max Output Level: -6 dBFS
  • Total Posts : 6907
  • Joined: 2006/11/29 18:06:40
  • Location: The arm-pit of the good 'ol US...New Jersey
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/05 10:00:11 (permalink)
First off, yes your anti virus and wireless can cause that.
And I use WDM on my set up. It works much better for me, ASIO causes too many pops and clicks for me.
Quite a few of us get better results with WDM. One is not better then the other is all a matter of what works for you.
WDM is still better then ASIO4ALL. ASIO4ALL is a WDM Wrapper so it actually uses WDM it just makes your system see it as ASIO.
ASIO4ALL is generally used to get the on-board sound chip working.


Sonar 8.3.1 PE.
Dell Precision M90, Intel Core 2 DUO, 1.66 GHz, 2GB RAM, 80GB HD @ 7200RPM. XP Pro SP3
Glyph GT050- 320GB HD @ 7200RPM
Mackie Onyx 1640 w/FireWire.
And a bunch of other stuff.


Mike

Sonar X3 ~ Scarlett 18i6 ~ Home Build DAW  
GA-Z77X-UD5H
Intel i7 3770k 4.2GHz
32GB RAM Crucial Ballistix Elite (4x8) 
2x Samsung 250GB SSD 
1TB WD Black HDD @ 7200RPM 6Gb/s 64MB 
Corsair H80i Liquid cooler 
Noctua Silent Fans ~ 3x120mm ~ 1x140mm 
Seasonic Platinum 760w PSU 
Windows 7 Pro 64Bit.
#15
bvideo
Max Output Level: -58 dBFS
  • Total Posts : 1707
  • Joined: 2006/09/02 22:20:02
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/05 20:19:51 (permalink)
Another thing to check: are your Playback Timing Master and Record Timing Master settings (Options-Audio->General) pointed to your sound card?
Bill B.
#16
nollies1
Max Output Level: -89 dBFS
  • Total Posts : 71
  • Joined: 2008/10/18 16:16:23
  • Location: DC metro
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/05 21:10:15 (permalink)
OK here's the update... it's not good and I am trying my best to be patient but it is starting to get to me.

This is latest of what I did do:
-Set windows for "best performance"
-Turned off wireless (tried both “disconnected” from the network, and physically “disabled”)
-Confirmed (thanks bvid) that SONAR is pointing to the right sound card
-Tried both ASIO and WDM… with WDM for fun I even dragged that bar all the way to “safe”… was like in the seconds lol for latency

OK now here’s what I didn’t/couldn’t do:
-With the newly purchased “dedicated” firewire adapter w/ TI chipset… it shares IRQs with things that I cannot disable… only uninstall… but I can’t do that. Things like a) video card (won’t see screen); b) PCIs on the motherboard (don’t wanna risk that!); and c) SATA controller (definitely don’t wanna risk that)

I am by far no expert, but given the amount of messing around with this stuff… I still think it may be some other issue I am having, b/c it’s always the same sounding drops no matter what I do to adjust. For example, if I go back to the onboard or original firewire adapter (which shares IRQs with things I CAN disable)… no difference. Things like that. I mean, it’s not like I’m on an old 386 trying to do this. Ugh.

The other weird thing is that (at least the one time I tried, and only did it with one track) Reaper works fine. My only issue is that I don’t know how to get the project mix to talk to Reaper. Oh, and I’d have to spend more money.

Is there any way I can do some type of diagnostic to confirm that the project mix itself isn’t fried or something? Perhaps I can get lucky and see if a buddy of mine will let me connect it to his system. Or maybe it's fine given Reaper had no problems.

It's a shame I cannot use this thing, it sounded so awesome in the ads and two-grand ago. Sorry, I guess I'm starting to sound grumpy, I will behave.

SONAR 8 PE (8.3.1.372)
M-Audio Project Mix I/O
Edirol PCR-300 (darn I should've gotten the 500 lol)
Lenovo T61
XP SP3
Intel T7300 Core 2 Duo (2.0GHz, 800MHz FSB, 4MB Cache)
100GB 7200RPM (Seagate Momentus 7200.1)
4GB RAM (2GB x 2GB)... but really only 3GB I have been told, being 32 bit
#17
evansmalley
Max Output Level: -76 dBFS
  • Total Posts : 715
  • Joined: 2005/06/07 08:25:15
  • Location: Kansas City, MO, USA
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/05/05 21:24:24 (permalink)
yes nollies1 Reaper is very efficient... it just sucks compared to Sonar as an editing app I think.
But the fact that it works so well for actual recording is an educator to me regarding Sonar. I have both- I use Reaper only for vari-speed but I can clearly see the difference in the way it records audio and uses the cpu. I think Sonar is so far heads and tails above Reaper as a recording/production app there's just no comparison- but I constantly have problems with simply recording audio and having it placed in sync with other tracks. It's a problem- a huge problem- for me. Yet it's better than anything else by far (Sonar). I miss my analog multitrack bad...

And bitflipper I notice and really appreciate that all your posts are so very fact-based. You do a good job bringing technical details and accuracy to the forum. Thanks!

There really should be more exact science in the wild zone of how many buffers and milliseconds of latency to use. There have to be exact and repeatable values that are best with certain apps and certain set-ups. It's such an important parameter. Someday we need to get it right!
#18
nollies1
Max Output Level: -89 dBFS
  • Total Posts : 71
  • Joined: 2008/10/18 16:16:23
  • Location: DC metro
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/06/08 10:11:51 (permalink)
OK. here is the update. also, for anyone curious enough, or especially for ANYONE NEW TO THIS silly computer stuff feel free to read this as well and share my pain lol:

http://forum.cakewalk.com/tm.asp?m=1702303&mpage=1&key=�

So... I got annoyed that sonar wouldn't work and for whatever reason reaper was like install, open, hit record, and wholla... no problem.

but i was determined to figure out the sonar issue over time, as i just didn't feel that switching to reaper really 'solved the problem', it just negated it.

anyways here's the skinny. i was able to get rid of my 2, 1 GB ram sticks at work in exchange for 2, 2 GB sticks. for some reason it only claims 3 GB ram, but someone here at my work claims that's because it's not a 64 bit system (only vista is?). whatever that means. if it really only can take 3 i don't know why work would have let me install them. so maybe that extra 1 is doing something... but who knows.

nevertheless i then went back to sonar and started messing with it again thinking i might get lucky. selected wdm/ks driver, this time I checked "enable read caching" and "enable write caching", no idea what that means but on a whim i said screw it let's try it (hadn't done that before... or, i don't think so at least).

works like a charm, at least as tested (six tracks simultaneously active). out of a number (5 or 6) live takes there were 100% no pops/crackles and it only crashed once on me. when it did, i just exited sonar, opened it back up, hit record... and all was fine again. guess it's just going to happen from time to time.

call me crazy, but I am content, not at all because i think reaper stinks, but for whatever reason i just feel our needs are better met in sonar. i'll leave it at that. now on to another post about the metronome (check it out if you can).

SONAR 8 PE (8.3.1.372)
M-Audio Project Mix I/O
Edirol PCR-300 (darn I should've gotten the 500 lol)
Lenovo T61
XP SP3
Intel T7300 Core 2 Duo (2.0GHz, 800MHz FSB, 4MB Cache)
100GB 7200RPM (Seagate Momentus 7200.1)
4GB RAM (2GB x 2GB)... but really only 3GB I have been told, being 32 bit
#19
rotaholic
Max Output Level: -86 dBFS
  • Total Posts : 204
  • Joined: 2005/02/28 19:48:55
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/07/05 01:07:03 (permalink)
Im sure you have allready but make sure that the projectmix is in sonar mode and that you have installed the latest firmware and drivers from m-audio.
#20
CJaysMusic
Max Output Level: 0 dBFS
  • Total Posts : 30423
  • Joined: 2006/10/28 01:51:41
  • Location: Miami - Fort Lauderdale - Davie
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2009/07/05 12:08:28 (permalink)
anyways here's the skinny. i was able to get rid of my 2, 1 GB ram sticks at work in exchange for 2, 2 GB sticks. for some reason it only claims 3 GB ram, but someone here at my work claims that's because it's not a 64 bit system (only vista is?). whatever that means. if it really only can take 3 i don't know why work would have let me install them. so maybe that extra 1 is doing something... but who knows.

It means that all 32bit windows can only see no more than 4 gigs. and if your seeing 3 gigs, then you need to enable the 3gig switch and take into account that your video card takes up ram also. In 64bit windows, it can see as much as 16gigs, i think
Cj
post edited by CJaysMusic - 2009/07/05 12:20:23

www.audio-mastering-mixing.com - A Professional Worldwide Audio Mixing & Mastering Studio, Providing Online And Attended Sessions. We also do TV commercials, Radio spots & spoken word books
Audio Blog
#21
Elu
Max Output Level: -90 dBFS
  • Total Posts : 17
  • Joined: 2004/12/23 10:37:51
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2010/01/04 18:59:35 (permalink)
nollies1


OK...

I have systematically gone through all combinations between what I can set on the card and what I can set in SONAR...well, I went up to 1024 on the card and 768 in SONAR... all present the same symptoms of mild but noticeable drops.

I kept my eye on the CPU and Disk % usage and they are always quite low (no more than a FEW %). I am beginning to wonder if there is another cause.

Prior to me trying to figure out this buffer size issue I have also: a) set windows for "best performance"; b) got a 'dedicated' firewire adapter (for the project mix); and c) all the random stuff like different cables, disabled IRQs, unplugged the cord to my laptop, etc. Oh and I reinstalled the software too, and all updates as well.

Any other thoughts on how to troubleshoot? Thanks

I have the same issues with latency and such just finishing a new 64 bit installation with all software running in 64 bit as well.  It will just take some time to work out the latency issues.  However what I noticed about this particular post is that you said you set windows for "best performance", however it must be said that sound drivers work in the background not in the foreground.  So setting your computer for best performance does not help latency issues, it hinders them.  It would be more prudent to set your computer to run background services as the more important processes.  Cakewalk itself will run fine.  This is something that I picked up from M-Audio.
#22
doctorweir
Max Output Level: -90 dBFS
  • Total Posts : 34
  • Joined: 2009/05/14 23:34:00
  • Location: Singapore
  • Status: offline
RE: Setting buffer size on sound card and SONAR 2010/01/05 02:23:06 (permalink) ☄ Helpfulby jasonthelegend 2017/09/04 21:57:47
Also run DPC Latency Checker http://www.thesycon.de/deu/latency_check.shtml
and look out for latency spikes. These also contribute to the pops/clicks and can originate from various sources, e.g. LAN card, windows sidebar, gadgets, system hardware monitoring tools, antivir, etc.
I also nearly freaked out on the latency till I figured out to switch the windows sidebar and Everest off!!!
So switch on DPC lat and play around a bit, ending processes, switching off devices, etc...

Comp: Sonar X1PE, AMD 1055T Hexacore @ 4 GHz, 8GB, Win7-64, Velociraptor 300GB (System), Caviar 640GB Black Ed (Data), SB X-Fi Fatality
Hardware: Focusrite Saffire Pro40, Edirol M-16DX, Novation Remote Zero MK2, Waldorf Blofeld, E-Mu Morpheus, Novation Drumstation, and loads of other stuff..
#23
jasonthelegend
Max Output Level: -90 dBFS
  • Total Posts : 2
  • Joined: 2017/08/02 21:26:53
  • Status: offline
Re: Setting buffer size on sound card and SONAR 2017/09/04 21:40:02 (permalink)
Wow, your latency results are much better than mine with a Focusrite Scarlett 18i20 connected via USB 3.1 [Thunderbolt 3]. Something that many people using USB interfaces don't realize is that if you have multiple usb devices or hubs connected to your system, it uses all of the available bandwidth on the Universal Serial Bus. That's why I opted to use my only USB 3.1 port for the 18i20. Windows 10 wouldn't even recognize the Scarlett until I disconnected all my USB devices. Even with just my 4k webcam connected, the camera wouldn't work because the Scarlett was using all my bandwidth. The USB 3.1 port has it's own dedicated bus so that fixed the problem there at least. Unfortunately my ASIO latency is 12.5 milliseconds for both input and output using 551 samples. When I increased the sample to 1024, the latency increased to 24.5 milliseconds.
 
Anyways, the last thing that I wanted to mention is that Windows WILL recognize a max of 4GB of RAM. If you don't have a video card with dedicated graphics memory then oftentimes the OS will reserve 1GB of your physical RAM to run graphics. A semi-workaround might be to increase the size of your paging file to act as virtual memory. This will allow a place for the memory usage that exceeds your available RAM to go. Here's the catch, virtual memory is limited to the speed of your hard drive, so when your system does use it, there is a drastic difference in speed. Upgrading to a solid state drive might help. They are 2.5" which fits perfectly in laptops. SSDs don't use paging files (at least you aren't supposed to) because they are always in a solid state of either read or write. I'm sure that people may disagree with me, but I do actually have a Bachelor's in Computer Science with Specialization in Computer Security so I know one or two things here and there. As for Audio Engineering, I literally just started last week. I know absolutely nothing on the subject. I bought my computer 3 years ago so I didn't go out and buy something fancy. I don't use Mac computers due to my own personal issues with the company, however, I figured out a way to run the latest macOS build in a virtual machine just in case I need to use a program that is only built for the macOS. Also, you have a Core 2 Duo which does support a 64 bit OS, and honestly, your performance will increase drastically if you were to switch. Just some ideas. 
 
I would love to get some more ideas as to correcting my latency. I'm also having trouble with the WDM driver. I can't even switch to it in Sonar because it causes an instant blue screen of death every time. So I'm forced to use ASIO. This is way out of my realm as I do not understand ASIO or WDM. The only reason that I tried switching to WDM is because Sonar is only showing half of my inputs, but unlike other Scarlett users, my list of inputs and outputs do not say "left" or "right" input so it's hard to believe that it is only showing stereo connections, although, it is detecting exactly half of the inputs and outputs. It's not like I will ever use all of my inputs/outputs because I'm just operating out of my bedroom, as I was injured badly in combat and I can no longer walk so I'm in my bed 24/7. I have set everything up around where I lay. Anyways, I said way more than I intended. I hope that you stay well. 
 
Take Care,
Jason
 
**Crap! I just now realized that this thread is 7 years old so it probably won't help anyone. I'm going to post it anyways because I took a lot of time to write it. Sorry everyone.**
 
____________________________________________________________________________________________
SONAR Platinum (23.7.0) Build 37 [07-2017] 
Focusrite Scarlett 18i20 (USB 3.1 [Thunderbolt 3])
Audio-Technica ATH W5000 
Alienware 15 R2 Laptop
Windows 10 Enterprise x64 
Intel Core i7 6920 Skylake (8 cores) (4.1GHz [Overclocked],1000MHz FSB, 6MB Cache/1024MB L2 Cache) 
32GB DDR4 2133 MHz RAM
1TB Samsung NVMe PM951 M.2 PCIe SSD (Boot/Programs)
1TB 7200RPM Seagate HTS721010A9E630 (SATA 6 Gbps) [Storage]
5TB 7200RPM Seagate SCSI USB 3.0 Expansion Drive
NVIDIA GeForce GTX 980M (4GB GDDR5 @ 2500 MHz) PCIe 3.0
Intel(R) HD Graphics 530
post edited by jasonthelegend - 2017/09/04 22:05:47
#24
chuckebaby
Max Output Level: 0 dBFS
  • Total Posts : 13146
  • Joined: 2011/01/04 14:55:28
  • Status: offline
Re: Setting buffer size on sound card and SONAR 2017/09/04 22:36:53 (permalink)
You should be using the driver you downloaded for your Focusrite 1820. The ASIO driver. that will get you the best results and lowest latency. Some might argue WASAPI but disagree. Use the ASIO Drivers that came with your device. there is no reason you cant get more than acceptable results using the ASIO driver for your scarrlett.

Windows 8.1 X64 Sonar Platinum x64
Custom built: Asrock z97 1150 - Intel I7 4790k - 16GB corsair DDR3 1600 - PNY SSD 220GB
Focusrite Saffire 18I8 - Mackie Control
   
#25
BRainbow
Max Output Level: -83 dBFS
  • Total Posts : 399
  • Joined: 2004/03/14 01:39:12
  • Location: Honolulu, Hawai'i
  • Status: offline
Re: Setting buffer size on sound card and SONAR 2017/09/05 01:08:36 (permalink)
 
Hi Jason,
 
Welcome to SONAR. ++1 on Chuck-E's advice to use the Scarlett's included ASIO drivers (and then update them from the website).
 
You said:  <<<Windows WILL recognize a max of 4GB of RAM.>>>
Do I misunderstand?  I definitely don't think this is true.
 
Your input/output list may seem like you are only getting half the ins/outs because it shows something like "Scarlet Input Device 1"  when it is actually Scarlett 1 and 2.  They are stereo by default, but the default naming is confusing.   You can rename all your ins/outs to make it less so -- just check "use friendly names" and double click on and edit the existing name  I just use "Z 1-2" for my Zoom and "O 1-2" for my Mackie Onyx interfaces - it's short and easily fits in the inputs/outputs window in Track View.
 
Good luck.  There is a lot to learn but digital recording/engineering with SONAR is addictive in the best possible way.
 
Aloha,
Bill

Cakewalk (forever), Two WIN10 64-bit DAWs: home-brew ASRock x299 Taichi / i7 7820x w/ 64GB RAM and ASUS X99A-II / i7-5820K w/ 32GB RAM, ZOOM UAC 8, Mackie ONYX 1640i FW Mixer/Interface, Mackie ONYX 1200F, Avalon U5 PreAmp, NI Komplete 11 Ultimate, EastWest Composer CloudX, Yamaha MOTIF XS8, Ensoniq SD-1 and ESQ-1, Korg M1rEX, Yamaha TX-81Z, Roland D110, Line6 HELIX Rack and Native, POD HD-Pro, POD Farm 2.5, Yamaha NS-10 and Presonus Eris E8 monitors, Yamaha Disklavier Upright Piano, mics, guitars, basses, and the cutest little tambourine.
#26
jasonthelegend
Max Output Level: -90 dBFS
  • Total Posts : 2
  • Joined: 2017/08/02 21:26:53
  • Status: offline
Re: Setting buffer size on sound card and SONAR 2017/09/05 20:06:26 (permalink)
Thanks for the advice guys. I am running the latest driver directly from Focusrite. I actually had a Focusrite tech log into my system remotely, and he ensured that everything was set up right. It took us a while to figure out that it was the overload of the Universal Serial Bus that was causing the problem. Honestly, it was the very last thing that came to my mind because I've never overloaded the bus before; never in all my years of working with computers has this happened. It makes a lot of sense though because with the 18i20 you are connecting 38 inputs/outputs that need to be ready to receive signal at any given time. Per your advice, I will stick with ASIO, and thank you for confirming that it sees the inputs as stereo connections. That's kind of what I thought, but it presented itself differently than what other people were experiencing so I doubted my gut instinct.
 
As for 32 bit Windows recognizing 4GB of RAM, back in the day it wouldn't show it at all, however, as the years have gone by, manufacturers began releasing BIOS updates that would fix it. I'm not sure if they have released updates for the Lenovo or not. Also, if you do NOT have a dedicated graphics card then Windows oftentimes reserves 1GB for video. One quick way to see if it is recognizing all of your physical RAM is to run Hardware Monitor by CPUID. You can Google it or I will attempt to paste a link: 
The free version will do the trick. You can also right click on "My Computer" or for newer versions of Windows you would open up file explorer and right click on "This PC", then select the "Advanced" tab, then choose the options you want. I would suggest that you select the option to configure the computer for Performance rather than letting Windows decide. Then I would select the options to allocate memory for programs rather than background processes. You can also adjust your paging file here. In my totally honest technical opinion, I would upgrade to a 64 bit OS and select the 64 bit precision checkbox in Sonar under Drivers. Hope this helps.
 
Take Care,
J
 
#27
GregGraves
Max Output Level: -85 dBFS
  • Total Posts : 282
  • Joined: 2014/11/14 11:32:14
  • Location: florida usa
  • Status: offline
Re: Setting buffer size on sound card and SONAR 2017/11/21 09:55:34 (permalink)
I've always wondered (though I experience no problems) that if when I'm mixing (not recording) I set the playback buffer to 512 and the record buffer to 512, does that mean that my soundcard buffer should be the sum of those two values, i.e., 1024?  In any case, that is why I read through this post, being bored and can't sleep.
 
RE: Jasonthelegend's post
 
I bought an M-Audio M-Track USB interface to use with my admittedly crappy laptop while on the road, and never could get the latency down to what I'm spoiled with my ancient PCI card stuck in my ancient Win7 motherboard in the studio, namely inaudible latency of a couple msec.   I found USB unusable.  It sits, brand new and unused, in a box on the shelf!
 
I realize that people do get these USB interfaces to work, so you should be able to get yours to work, given the power of your system, which far outpaces my mid-tower PC.  I suggest setting your buffers at 512.  I imagine Playback will be good, but latency with your guitar (?) will give you brain damage.  You can then reduce buffer size by steps of 128 until Playback begins to stutter but latency has improved. 
 
If this doesn't solve your problem, then your problem is due to something else.  Duh.  If you are trying to record guitar through a plugin to get the sound you want, I've never been able to get that to work.  Other than stick a mic in front of an amp, I use either my Behringer V-amp or Line6 rackmount guitar processors.  What I hear is what I get.  The line6 also has a direct bypass line-out, so if I want to use a plugin, I can set the Line6 (or whatever) to mimic the sound of the plugin, but only use the plugin on the dry recorded sound after I'm done laying down my parts.  I wonder if that is the problem you are having.....
 
As far as posting on here, folks generally try to be helpful, unlike the Dodge RAM forum where everyone seems to think it is their job to flame.  So if you get stuck, post.  I've been doing this stuff since Windows 95 came out and I sold all my multitrack tape machines.  I still get stuck and have to post.

I am "Five Foot Wall" on Spotify, Deezer, etc.  Platinum, Windows 7 64bit, AMD FX-6100 hex-core @3.8ghz, 8 gig ram (never use more than 5 gigs), Delta 44, UM-2
[Note: join date reflects inability to migrate old account to new forum]
 
 
https://greggraves.bandcamp.com/track/whatcha-gonna-do
https://greggraves.bandcamp.com/track/true-believer-man
 
#28
Jump to:
© 2021 APG vNext Commercial Version 5.1