[Solved] SONAR Platinum will not start.

Author
Metaphasic
Max Output Level: -85 dBFS
  • Total Posts : 262
  • Joined: 2010/09/28 16:36:37
  • Status: offline
2015/02/22 07:26:12 (permalink)

[Solved] SONAR Platinum will not start.

Hey guys! I'm excited to get this thing up and running, but there are a few minor issues I need to resolve.
 
Here are the conditions.
 
- Windows 7, fully patched.
- Previous install of X1 Producer, now uninstalled.
 
Here is the problem.
 
1. Installed Platinum.
2. SONARPLT.exe splash screen / loader just hangs and stops responding.
3. Attempted to clear the relevant %appdata% folder, as this site's KB indicated.
4. Reboot and try again. 
5. Back to 2.
6. Tried a "reinstall" from CCC.
7. Back to 2.
 
Has anybody encountered this before, or know how to resolve it?
#1

23 Replies Related Threads

    benjaminfrog
    Max Output Level: -81 dBFS
    • Total Posts : 477
    • Joined: 2006/11/05 12:26:57
    • Location: Minneapolis
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 07:37:00 (permalink)
    I've experienced it not relaunching if I've just closed it. Sometimes I have to go into Task Manager and kill SONARPLT.exe, which is still running behind the scenes. I usually don't even get the splash screen, though, in this scenario, so I'm not sure it applies to you, but you could check Task Manager and kill any running instances before trying to relaunch.

    SONAR Platinum
    Windows 10 Pro x64
    ASRock Z97 Pro4
    i7-4790K 4.0GHz
    32GB RAM
    Intel® HD Graphics 4600
    RME Fireface UFX
    http://www.sewardsound.com/
    #2
    Metaphasic
    Max Output Level: -85 dBFS
    • Total Posts : 262
    • Joined: 2010/09/28 16:36:37
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 07:40:04 (permalink)
    Yeah, already tried that. This is "first run" too by the way. I've never actually gotten in to the app outright.
     
    I'm wondering if there are remnants of past installations, other than the config files, that are messing with it.
     
    Does anybody know where the CCC keeps it's downloaded files? I might try uninstalling, cleaning up the file system and registry, then re-installing it fresh.
    #3
    Paul P
    Max Output Level: -48.5 dBFS
    • Total Posts : 2685
    • Joined: 2012/12/08 17:15:47
    • Location: Montreal
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 08:18:25 (permalink)
     
    Did you uninstall X1 after you installed Platinum ?
     

    Sonar Platinum [2017.10], Win7U x64 sp1, Xeon E5-1620 3.6 GHz, Asus P9X79WS, 16 GB ECC, 128gb SSD, HD7950, Mackie Blackjack
    #4
    Metaphasic
    Max Output Level: -85 dBFS
    • Total Posts : 262
    • Joined: 2010/09/28 16:36:37
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 08:25:07 (permalink)
    No. I uninstalled everything, including all my third party things, like Guitar Rig Pro, before I even installed the CCC.
     
    All my system drivers are up to date as well. However, I am going through and removing a lot of "little" things I no longer need or use, and cleaning up my file system and registry. In addition, the firewall and virus thing are both off.
     
    I am going to try completely fresh, testing each install along the way, to see if I can find where an error might be.
    #5
    gswitz
    Max Output Level: -18.5 dBFS
    • Total Posts : 5694
    • Joined: 2007/06/16 07:17:14
    • Location: Richmond Virginia USA
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 09:00:44 (permalink)
    Sonar prevents you from having more than one instance of the application running at once. If you try to re-launch while the app is still a live process, then it will not launch.
     
    If you can't launch it ever, even after a re-boot, I would probably uninstall and re-install to see if it fixes it.
     
    Short of that, I would call Cakewalk Support during business hours and work through it with them.
    https://www.cakewalk.com/Support/Contact
     

    StudioCat > I use Windows 10 and Sonar Platinum. I have a touch screen.
    I make some videos. This one shows how to do a physical loopback on the RME UCX to get many more equalizer nodes.
    #6
    Metaphasic
    Max Output Level: -85 dBFS
    • Total Posts : 262
    • Joined: 2010/09/28 16:36:37
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 09:22:58 (permalink)
    I may have to do that, because I've tried everything. I'm an ex-IT dev, so I know how to cancel processes. That wasn't it. Here's what I've tried...
     
    **Making this public just in case somebody has input, but mostly so I have something to review when I call support on Monday.**
     
    - Backed up the CCC downloads to another folder.
    - Uninstalled everything.
    - Cleaned the registry.
    - Cleaned file system for everything related to the install, including...
    -- %appdata%
    -- c:\
    -- c:\ProgramData
    -- c:\Program Files
    -- c:\Program Files\Common Files
    -- c:\Program Files (x86)
    -- c:\Program Files (x86)\Common Files
    - Checked drivers for video card, sound card, audio interface, mouse and keyboard.
    - Checked Windows Update, including optional items.
    - Rebooted.
    - Moved Platinum only files (and sub items) back to CCC download folder.
    - Re-installed Platinum, without Melodyne and Addictive Drums for now.
    - Updated Platinum.
    - Rebooted.
    - Attempted to run Platinum to have it hang, and stop responding, at the splash screen.
    #7
    tlw
    Max Output Level: -49.5 dBFS
    • Total Posts : 2567
    • Joined: 2008/10/11 22:06:32
    • Location: West Midlands, UK
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 10:10:45 (permalink)
    If you've not done it, try uninstalling then reinstalling the audio drivers.

    If that doesn't work try deleting (or renaming) Sonar's aud.ini file so it builds a new one on launch.

    It might also be worth trying renaming all the VST folders in program files in case the hang is being caused by a rogue plugin. If Sonar then launches rename the VST folders one at a time and see when and if the hang returns. If it does then it's probably a matter of tracking down the plugin that's causing the problem by trial and error.

    Sonar Platinum 64bit, Windows 8.1 Pro 64bit, I7 3770K Ivybridge, 16GB Ram, Gigabyte Z77-D3H m/board,
    ATI 7750 graphics+ 1GB RAM, 2xIntel 520 series 220GB SSDs, 1 TB Samsung F3 + 1 TB WD HDDs, Seasonic fanless 460W psu, RME Fireface UFX, Focusrite Octopre.
    Assorted real synths, guitars, mandolins, diatonic accordions, percussion, fx and other stuff.
    #8
    scook
    Forum Host
    • Total Posts : 24146
    • Joined: 2005/07/27 13:43:57
    • Location: TX
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 10:48:17 (permalink)
    These have not been suggested:
    Disabling the virus scanner during install
    Running SONAR as administrator
    #9
    Noel Borthwick [Cakewalk]
    Cakewalk Staff
    • Total Posts : 6475
    • Joined: 2003/11/03 17:22:50
    • Location: Boston, MA, USA
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 10:50:24 (permalink)
    A hung scan won't prevent SONAR launching since the scan is run as a separate process.
    My best guess is the audio driver is preventing startup. If its a USB/Firewire device try powering off or unplugging and then launch SONAR. Also check if there is a dialog hidden behind SONAR somehow.

    Noel Borthwick
    Senior Manager Audio Core, BandLab
    My Blog, Twitter, BandLab Profile
    #10
    Metaphasic
    Max Output Level: -85 dBFS
    • Total Posts : 262
    • Joined: 2010/09/28 16:36:37
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 10:52:21 (permalink)
    I figured it out. This information should probably entered into the Knowledge Base, or made into a sticky post at the very least.
     
    Problem: Sonar hangs during splash screen initialization.
    Cause: Sonar detects ASIO audio card drivers and attempts to connect. If the unit is unplugged, or off, with no phantom power supply, the connection will be left open and unanswered, thus causing the hang.
    Solution: Plug the unit in and turn it on!
    Recomendations: Update Sonar to utilize a timeout on such connections and automatically re-calibrate to something like WDM or another preferred secondary interface. This is, of course, a development issue.
     
    I figured this out by taking the advice above and uninstalling the ASIO drivers. But before I re-installed them, I attempted loading Sonar again. This time it worked. I installed the drivers again and reloaded Sonar, only to have it hang again. It occurred to me that, as I was setting up a new system, and had not moved my interface in to the room yet, I should do that. Once I did, Sonar loaded with no issues.
     
    Thanks for all the input and dialog. Hopefully, this will help somebody else in the future.
     
    Cheers, Drew
    #11
    Noel Borthwick [Cakewalk]
    Cakewalk Staff
    • Total Posts : 6475
    • Joined: 2003/11/03 17:22:50
    • Location: Boston, MA, USA
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 11:00:44 (permalink)
    Which audio interface are you using? Its not normal for the driver to hang if the device is missing. I suspect its throwing a dialog but the dialog is not visible hence it looks hung. SONAR itself doesn't hang when a device fails to load so there is nothing to fix from the SONAR side. 

    Noel Borthwick
    Senior Manager Audio Core, BandLab
    My Blog, Twitter, BandLab Profile
    #12
    Anderton
    Max Output Level: 0 dBFS
    • Total Posts : 14070
    • Joined: 2003/11/06 14:02:03
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 11:01:56 (permalink)
    Hmmmm...if an interface isn't connected, for me SONAR has always just loaded Windows audio drivers. Check the taskbar and see if the splash screen is there, but hidden behind SONAR.

    The first 3 books in "The Musician's Guide to Home Recording" series are available from Hal Leonard and http://www.reverb.com. Listen to my music on http://www.YouTube.com/thecraiganderton, and visit http://www.craiganderton.com. Thanks!
    #13
    Metaphasic
    Max Output Level: -85 dBFS
    • Total Posts : 262
    • Joined: 2010/09/28 16:36:37
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 11:09:04 (permalink)
    It's an old M-Audio Fast Track Ultra, which was sold by the company to Avid I believe. I also get the impression that their updated Windows 7 drivers are not all that professionally written. It is probably the driver that is crashing the system when an attempt to use it while not connected is made. It doesn't really seem to be a Sonar issue at this point, however, there should be a way to write a safegaurd around this with a multi-threaded process.
     
    If not plugged in, it definitely hangs, invoking the "Not Responding - Check for solutions" dialog. I haven't actually tried with it simply turn off, but still connected.
     
    There are no hidden dialogs listed on the bar, or in Apps / Processes in Task Manager.
     
    Any other input you guys need?
    #14
    gswitz
    Max Output Level: -18.5 dBFS
    • Total Posts : 5694
    • Joined: 2007/06/16 07:17:14
    • Location: Richmond Virginia USA
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 12:07:14 (permalink)
    I just launched Sonar Platinum using my FastTrack Ultra and it worked ok.

    StudioCat > I use Windows 10 and Sonar Platinum. I have a touch screen.
    I make some videos. This one shows how to do a physical loopback on the RME UCX to get many more equalizer nodes.
    #15
    Metaphasic
    Max Output Level: -85 dBFS
    • Total Posts : 262
    • Joined: 2010/09/28 16:36:37
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 12:09:30 (permalink)
    gswitz
    I just launched Sonar Platinum using my FastTrack Ultra and it worked ok.




    Mine does now too. Now that I know it has to be plugged in. For some reason it didn't work when unplugged. Curious, what driver are you using? The one that came with, or the updated one from Avid? And what OS are you using? The more info we have, the better.
    #16
    gswitz
    Max Output Level: -18.5 dBFS
    • Total Posts : 5694
    • Joined: 2007/06/16 07:17:14
    • Location: Richmond Virginia USA
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 12:16:36 (permalink)
    I'm using Windows 8.1.
    I always plug in my interfaces so they don't need to get power via USB. If your USB Bus is under-powered, you'd have trouble with your interface.
     
    Firewire carries more power, so Firewire interfaces sometimes work well without being plugged in.
     
    I can add that back in the day, I used to use a couple of channels on the interface without it being plugged in - when using a laptop to do recording.
     
    I use the latest drivers from here for the FastTrack Ultra...
    http://avid.force.com/pkb/articles/en_US/download/en379411
     
    post edited by gswitz - 2015/02/22 12:24:14

    StudioCat > I use Windows 10 and Sonar Platinum. I have a touch screen.
    I make some videos. This one shows how to do a physical loopback on the RME UCX to get many more equalizer nodes.
    #17
    Metaphasic
    Max Output Level: -85 dBFS
    • Total Posts : 262
    • Joined: 2010/09/28 16:36:37
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 12:24:09 (permalink)
    Oh! When I said "not plugged in", I meant "at all". Like, the USB itself isn't even hooked up.
    #18
    gswitz
    Max Output Level: -18.5 dBFS
    • Total Posts : 5694
    • Joined: 2007/06/16 07:17:14
    • Location: Richmond Virginia USA
    • Status: offline
    Re: SONAR Platinum will not start. 2015/02/22 12:25:19 (permalink)
    I will say the pre-amps on my FastTrack Ultra went bad. It maybe the case on yours too. Bump the buttons on the front to switch to the rear of the interface. Use external pre-amps and see if that fixes things for you.
     
    if you are using it USB Powered, definitely switch to Rear for all channels not in use to bypass the pre-amps.

    StudioCat > I use Windows 10 and Sonar Platinum. I have a touch screen.
    I make some videos. This one shows how to do a physical loopback on the RME UCX to get many more equalizer nodes.
    #19
    mdfmike
    Max Output Level: -90 dBFS
    • Total Posts : 2
    • Joined: 2005/01/24 14:52:48
    • Status: offline
    Re: SONAR Platinum will not start. 2016/01/13 02:18:00 (permalink)
    I just encountered this condition under Windows 10 with Sonar Platinum. My main audio device is a MOTU 8-pre USB which works fine. I am using an Alienware Laptop. Sonar started hanging at startup after latest Sonar maintenance install. Could not even kill sonar task via task manager. I then disconnected my Targus USB 3.0 port replicator, and Sonar startup completed. Sonar was hanging trying to detect or process the audio device built into the Targus USB 3.0, which I don't use and have no audio cables plugged into. Latest Targus drivers installed, and on latest Windows maintenance. For now, I unplug Targus before starting Sonar, and then plug it back in after Sonar initializes. Disabling Targus audio device in device manager doesn't help. Perhaps someone at Sonar can recreate this issue and bullet-proof Sonar from hanging on audio device detection at startup?
    #20
    voon
    Max Output Level: -90 dBFS
    • Total Posts : 27
    • Joined: 2015/12/29 23:21:04
    • Status: offline
    Re: SONAR Platinum will not start. 2016/02/04 07:11:05 (permalink)
    Found my solution to the exact same (Sonar hanging at splash): Deactivated all audio devices I do not use in the device manager of Windows. I had things like a USB Dock audio device, NVIDIA Audio devices etc there. Deactivated all but the one I need ... and voila, it finally starts up right. 
    #21
    mdfmike
    Max Output Level: -90 dBFS
    • Total Posts : 2
    • Joined: 2005/01/24 14:52:48
    • Status: offline
    Re: SONAR Platinum will not start. 2016/06/18 00:48:11 (permalink)
    FYI, Sonar support:
    This issue still exists on Sonar Platinum 2016.04 level - and is easily reproduced. Install a Targus USB 3.0 port replicator with no audio devices attached to it. SONARPLT.EXE hangs solid at splash screen - reboot is only way to break out - task manager kill has no effect.  Only circumvention is to disable Targus USB Audio in Device Manager.
    Windows 10 user with Sonar Platinum.
     
     
    #22
    Robert McAlister
    Max Output Level: -90 dBFS
    • Total Posts : 7
    • Joined: 2015/02/25 11:38:10
    • Status: offline
    Re: SONAR Platinum will not start. 2016/08/13 00:31:01 (permalink)
    I am trying to demo the Sonar Platinum and it poofs after splash screen shows for 1 second.
     
    Everything else is peachy on my Windows 7 here.
     
    So I tried to uninstall but it doesn't show in the Programs and Features.  How do we uninstall?
    post edited by Robert McAlister - 2016/08/13 00:52:54

    Win 7 32 bit
    8 GB ram
    #23
    audigo
    Max Output Level: -90 dBFS
    • Total Posts : 1
    • Joined: 2015/10/10 19:04:23
    • Status: offline
    Re: SONAR Platinum will not start. 2017/03/26 20:53:28 (permalink)
    Found the same solution as mdfmike - makes no since to have to unplug usb interface and plug in after initialization something need fixing - lastest install on Tascam 2x2 - will not install on main system Tasam 20x20 until this is fixed - still using X2 Prod on main
    #24
    Jump to:
    © 2020 APG vNext Commercial Version 5.1