Tips to improve MIDI response time?

Author
BermudaComposer
New Member
  • Total Posts : 16
  • Reward points: 0
  • Joined: 2004/04/27 15:48:29
  • Location: Bermuda
  • Status: offline
2004/09/04 13:52:30 (permalink)

Tips to improve MIDI response time?

Greetings,

I've recently hooked up the following:

Ensoniq TS-10
Sonar 3.1
M-Audio USB 1to1 MIDI port w/ in/out connectors
Garritan Personal Orchestra/Kontakt VST

I'd like to be able to hear my GPO instruments (through my PC, obviously) when I strike my Ensoniq keys.

I've hooked it all up correctly, but there's a half-second delay from when I strike the key, to the VST playing the sound. Is there anyway I can improve this lag time? What settings should I be checking? I'm assuming this has nothing to do with audio latency... but I may be wrong.

I'd appreciate your advice.

Kind regards,

Steve Gallant
B~E~R~M~U~D~A

BermudaFlyer@logic.bm
#1

10 Replies Related Threads

    LoopJunkie
    Silver Member
    • Total Posts : 2467
    • Reward points: 0
    • Joined: 2003/11/22 07:44:04
    • Location: Hamburg
    • Status: offline
    RE: Tips to improve MIDI response time? 2004/09/04 14:35:33 (permalink)
    but I may be wrong


    Seems like you are. To resolve the issue, start out with Sonar's online help. There are some useful hints. Then search the forum for "latency".

    If you want more specific help, list your specs (soundcard, driver, HD, ...)
    < Message edited by LoopJunkie -- 9/4/2004 2:36:56 PM >

    loop

    #2
    Yasoo
    Silver Member
    • Total Posts : 844
    • Reward points: 0
    • Joined: 2003/11/15 18:20:11
    • Status: offline
    RE: Tips to improve MIDI response time? 2004/09/05 11:45:44 (permalink)
    ORIGINAL: BermudaComposer
    I'm assuming this has nothing to do with audio latency... but I may be wrong.


    You are wrong. When it comes to usnig soft synths, it has almost everything to do with latency. I'm not sure about your particular soundcard, but you'll want to be set at 15 ms or below. Much more than that and you'll start noticing delay. If it won't let you select low latency, try different driver settings - WDM and ASIO. Also, your soundcard might have it's own control panel with some serttings to try. You may want to try and delete your AUD.INI (backup first) and restart Sonar and run the wav profiler. Enable only the inputs and outputs you really need to free up as many resources as possible.
    #3
    Summertime Studios
    Bronze Member
    • Total Posts : 90
    • Reward points: 0
    • Joined: 2004/03/19 23:29:38
    • Status: offline
    RE: Tips to improve MIDI response time? 2004/09/06 00:11:08 (permalink)
    So, how about this... When I play my Fatar or Ensoniq keyboard, I can't hear any real latency. But, if I've recorded the MIDI data, it is almost always delayed severely upon playback. Is there a way around this, or do I just have to manually adjust the MIDI data everytime?

    -John Vice
    Summertime Studios
    #4
    LoopJunkie
    Silver Member
    • Total Posts : 2467
    • Reward points: 0
    • Joined: 2003/11/22 07:44:04
    • Location: Hamburg
    • Status: offline
    RE: Tips to improve MIDI response time? 2004/09/06 08:00:41 (permalink)
    But, if I've recorded the MIDI data, it is almost always delayed severely upon playback. Is there a way around this, or do I just have to manually adjust the MIDI data everytime?


    This never happens in my setup, so there's no need to adjust MIDI data. What's wrong with your DAW configuration? Give us some details about your OS, soundcard, midi interface, drivers used, things you configured badly , ....

    Meanwhile you may find some more info here: http://www.cakewalk.com/forum/tm.asp?m=130201&mpage=1&key=delay%2Ccompensation
    < Message edited by LoopJunkie -- 9/6/2004 8:04:53 AM >

    loop

    #5
    Yasoo
    Silver Member
    • Total Posts : 844
    • Reward points: 0
    • Joined: 2003/11/15 18:20:11
    • Status: offline
    RE: Tips to improve MIDI response time? 2004/09/06 19:31:37 (permalink)
    That's a little odd. Have you messed with the "timing offset"? It's in Options->Audio, "Advanced" tab under "Synchonization". You can set it to a positive or negative value to set the timing of MIDI playback vs. audio playback.
    #6
    Summertime Studios
    Bronze Member
    • Total Posts : 90
    • Reward points: 0
    • Joined: 2004/03/19 23:29:38
    • Status: offline
    RE: Tips to improve MIDI response time? 2004/09/08 01:27:50 (permalink)
    That's a little odd. Have you messed with the "timing offset"? It's in Options->Audio, "Advanced" tab under "Synchonization". You can set it to a positive or negative value to set the timing of MIDI playback vs. audio playback.


    Fascinating stuff. I never thought of that actually. What effect does adjusting the "midi buffers" have? I've never played with that setting either, so I don't want to disrupt anything unnecessarily.

    -John Vice
    Summertime Studios
    #7
    Yasoo
    Silver Member
    • Total Posts : 844
    • Reward points: 0
    • Joined: 2003/11/15 18:20:11
    • Status: offline
    RE: Tips to improve MIDI response time? 2004/09/08 17:02:27 (permalink)
    I never messed with the MIDI buffers before. Just save your .INI files and you shouldn't have a problem trying different setttings. You can always just copy them back over if you mess things up.
    #8
    rallenjones
    Silver Member
    • Total Posts : 823
    • Reward points: 0
    • Joined: 2003/12/23 16:25:20
    • Status: offline
    RE: Tips to improve MIDI response time? 2004/09/08 17:41:43 (permalink)
    I'm not sure of everything about "latency", but my impression was that too much latency causes you to hear delays on playback associated with effects. If you're playing your keyboard and everything sounds fine, but there is a delay of the recorded MIDI track on playback, that sounds su****ously like the glitches I get when I record a MIDI track from my Roland Guitar Synth. In that case, the MIDI track sounds fine when I play it back through the Roland's synth, but is glitchy when I play it through the keyboard synth. In other words, it may be a MIDI rather than latency probem.
    #9
    LoopJunkie
    Silver Member
    • Total Posts : 2467
    • Reward points: 0
    • Joined: 2003/11/22 07:44:04
    • Location: Hamburg
    • Status: offline
    RE: Tips to improve MIDI response time? 2004/09/08 20:50:25 (permalink)
    but my impression was that too much latency causes you to hear delays on playback associated with effects


    Latency is the total time it takes for the MIDI signal to travel from your keyboard through your midi interface into the PC, then be routed to a specific soft synth and then to make this softsynth generate a sound. The midi travel time can usually be neglected if the midi data does not contain a huge amount of CCs (e.g. wheel, aftertouch, breath controller). So, the (audio) latency slider comes in handy to reduce the last part of the journey.

    During playback everything is lined up for you by Sonar and audio latency can be set to a much higher value with the slider.
    < Message edited by LoopJunkie -- 9/8/2004 8:55:29 PM >

    loop

    #10
    Scott Lee
    Silver Member
    • Total Posts : 1120
    • Reward points: 0
    • Joined: 2003/11/13 23:13:38
    • Location: Hollywood, California
    • Status: offline
    RE: Tips to improve MIDI response time? 2004/09/08 21:57:19 (permalink)
    He is using a VST softsynth so this would have to do with a audio latency. Could you goto your audio settings and tell us how many ms you have on playback and which drivers (soundcard too please) you are using. My "guess" is he is using either a soundblaster product and or a generic MME driverset and probably are in the 50-60ms range on playback timing. Let us know.

    Best,

    Scott Lee (ASCAP)
    SFX Media 
    Song Composer / Engineer / Audio Director

    http://www.youtube.com/user/Dezacrator?feature=mhee

    #11
    Jump to:
    © 2014 APG vNext Commercial Version 5.1