Using Fantom X6 as external MIDI instrument

Author
CDK
Max Output Level: -90 dBFS
  • Total Posts : 46
  • Joined: 2013/09/11 07:10:04
  • Status: offline
2018/07/05 10:24:34 (permalink)

Using Fantom X6 as external MIDI instrument

Thought I'd clarify the issues in a new port.
 
I have my Roland Fantom X6 set up as an external MIDI instrument for use in Sonar Platinum however:
  • Various sources state to turn local control off on the external keyboard however I’m finding that with local control on the X6 turned off, I get no sound during Sonar MIDI playback.
  • I have Soft Thru on the Fantom turned off.
  • Unless I turn MIDI echo off in Sonar, every time I press a key on the X6 or attempt Sonar MIDI playback, each MIDI note is triggered multiple times, resulting in somewhat of a MIDI note loop which can sometimes cause the X6 to hang/freeze. The only way I’ve found to stop this is turn off ‘Always echo the current MIDI track’ in Sonar but I’m not sure that’s really solving the problem?
  • Lastly, do I need a Fantom X Performance INS file for Sonar? Or can I select the Performance manually on the X6?Thanks :)

Windows 10 Pro
Intel Core i7-4790 CPU @ 3.60GHz
32GB RAM
64-bit operating system
Sonar Platinum
 
Roland Quad Capture USB Audio/MIDI interface
MOTU Micro Lite 5x5 USB MIDI interface
#1

1 Reply Related Threads

    Audioicon
    Max Output Level: -84 dBFS
    • Total Posts : 338
    • Joined: 2016/06/13 23:25:25
    • Status: offline
    Re: Using Fantom X6 as external MIDI instrument 2018/07/09 18:13:24 (permalink)
    CDK
    Various sources state to turn local control off on the external keyboard however I’m finding that with local control on the X6 turned off, I get no sound during Sonar MIDI playback.



    Local Control allows you use the Keyboard or MIDI as a Controller without triggering the device itself.
    For example: Lets say you have two Keyboards: A and B, you want to use A to Control B, meaning you want to play the Key-bed on A so that it triggers the sound in B. 
    Setting Local Control to off ensures that when you Play Keyboard A, it will not trigger it's own internal Sound. Unless you specify a MIDI channel and a MIDI output on Keyboard A itself.


    CDK
    Unless I turn MIDI echo off in Sonar, every time I press a key on the X6 or attempt Sonar MIDI playback, each MIDI note is triggered multiple times, resulting in somewhat of a MIDI note loop which can sometimes cause the X6 to hang/freeze.



    This usually happens when you have one MIDI output/input triggering multiple devices.
     
    Again, do you have multiple MIDI sound sources? 

    Here are simple steps:
    1. Turn Local Control to Off only if you are using the Fantom as a Controller and you do not want to trigger it's internal sounds when you are attempting to trigger other connected MIDI devices.
      My recommendation is that you turn it off, this will eliminate ambiguity and issues, such as what you are experiencing.

    2. In Sonar Insert a new MIDI track and turn the Echo on.
      Note: I usually like to Control Echo myself and so under preference I have:
      "Always Echo currently Selected track to off."

    3. For the MIDI track, set the MIDI out to the device you are attempting to control.
      For example: Lets say you have a MIDI interface Input and Output A set to the Fantom, then the MIDI input should be set to A OMNI and the Output (Where you are sending MIDI Messages) set to A output of your MIDI device.

    CDK
    I need a Fantom X Performance INS file for Sonar? Or can I select the Performance manually on the X6?


    No! You can control all of this on the Front Panel, however, the ini makes things easier. :)


    You do not need to do anything else. 






    Now playing: My New Song: OOH.
    #2
    Jump to:
    © 2018 APG vNext Commercial Version 5.1