VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?!

Author
csnack
Max Output Level: -89 dBFS
  • Total Posts : 96
  • Joined: 2015/02/03 19:10:12
  • Status: offline
2018/12/16 20:54:10 (permalink)

VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?!

Hi guys, so I just installed Splice along w/ Decimort2 from Splice and installation seemingly went fine. Then I went to scan my VST folders as per usual and it scans for a minute then I get a popup saying 'VST Scan has failed' though Cakewalk is seemingly left open/un-crashed, so it seems just the vst scan is crashing when scanning via the Plugin Manager or in Preferences. And in the Plugin Manger the VST3 folder is now empty (!) and so all of my VST3 plugins have now gone missing and I have no idea how to restore them to be scanned and used. Before I discovered that the VST3 folder was all of a sudden empty I hit the reset button in the VST scan section under Preferences and I only did that because someone here recommended I do that when I was having a problem w/ Waves 10 update and hitting the reset button per his suggestion fixed that, so I thought I'd hit the reset button this time to see if that was the problem and honestly I don't know if that made things worse. I've uninstalled/reinstalled Splice and Decimort2 at least twice now and also tried vst scan again w/ Splice/Decimort2 completely removed from the system, but no dice. VST Scan was fine before installing Splice, and in that log below it says something went wrong w/ Absynth all of the sudden? Anyone know what's going on or how to fix this? Many thanks in advance!
 
Here's the VST Scan log I captured:
 
Problem signature:
  Problem Event Name:    BEX64
  Application Name:    VstScan.exe
  Application Version:    6.0.0.0
  Application Timestamp:    5c064b0d
  Fault Module Name:    Absynth 5.dll_unloaded
  Fault Module Version:    0.0.0.0
  Fault Module Timestamp:    562648df
  Exception Offset:    000007fec9b2ea94
  Exception Code:    c0000005
  Exception Data:    0000000000000008
  OS Version:    6.1.7601.2.1.0.256.48
  Locale ID:    1033
  Additional Information 1:    3691
  Additional Information 2:    3691dfdfbae30e9aed073cf363de2e65
  Additional Information 3:    81e2
  Additional Information 4:    81e260b0f81eacfde8a844020aae0e6e

Read our privacy statement online:
  http://go.microsoft.com/f...04288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt
#1

10 Replies Related Threads

    csnack
    Max Output Level: -89 dBFS
    • Total Posts : 96
    • Joined: 2015/02/03 19:10:12
    • Status: offline
    Re: VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?! 2018/12/17 01:45:32 (permalink)
    So I still have X3e installed and I opened it and found that it is able to scan and find all of my vst3 and 2 plugs, yet CbB now can not. All this today after installing Splice and Decimort2, both of which I have removed from PC. I just uninstalled/reinstalled CbB and still it is unable to complete a vst scan, specifically it seems of the vst3 plugs. I Have no idea how to reconfigure the vst scan thing or whatever I need to do to fix this but my CbB daw anyway is basically broken as far as being able to scan/use my plugs. I have the lengthy scan log it generated (not the one above). The Same vst paths exist in both X3e and CbB here. and only X3e can complete the vst scan. Anyone from Bandlab know how to fix this?
    #2
    csnack
    Max Output Level: -89 dBFS
    • Total Posts : 96
    • Joined: 2015/02/03 19:10:12
    • Status: offline
    Re: VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?! 2018/12/17 01:49:09 (permalink)
    FWIW, my scan paths are
    • C:\Program Files\Cakewalk\VstPlugins
    • C:\Program Files\Common Files\VST3
    #3
    csnack
    Max Output Level: -89 dBFS
    • Total Posts : 96
    • Joined: 2015/02/03 19:10:12
    • Status: offline
    Re: VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?! 2018/12/17 02:36:54 (permalink)
    Am I correct that there's no technical support available from Bandlab via email or some other way to contact them? I can't find any. I mean there's some tech support link on the main Cakewalk page, but I doubt it's functional or goes to anyone at Bandlab. I've uninstalled/reinstalled CbB twice now and still it can't complete a vst scan, even though both X3e and SPLAT both complete the scan and find all my plugs just fine. CbB here is just broken now in that regard.
    #4
    gustabo
    Max Output Level: -49.5 dBFS
    • Total Posts : 2591
    • Joined: 2009/01/05 17:32:38
    • Status: offline
    Re: VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?! 2018/12/17 06:51:32 (permalink)
    csnack
    Am I correct that there's no technical support available from Bandlab via email or some other way to contact them? I can't find any. I mean there's some tech support link on the main Cakewalk page, but I doubt it's functional or goes to anyone at Bandlab. I've uninstalled/reinstalled CbB twice now and still it can't complete a vst scan, even though both X3e and SPLAT both complete the scan and find all my plugs just fine. CbB here is just broken now in that regard.


    Cakewalk by Bandlab support:
    support@cakewalk.com
    is the official email address and
    https://help.cakewalk.com/hc/en-us/requests/new
    will also forward to their central ticket system!


    Cakewalk by Bandlab - Win10 Pro x64 - StudioCat Platinum Studio DAW - 32 GB Ram - MOTU UltraLite-mk3
    M-Audio Keystation 88ES - Akai MPD26 (hot-rodded) - Alesis DM10 - a few guitars, a few amps
    Novation Launch Control - Korg nanoKONTROL2 - PreSonus FaderPort - DAW Remote HD on iPad
    Adam A7X - Behritone C50A
    PreSonus Monitor Station v2 (controlling the mons)
    https://www.facebook.com/groups/sonarusergroup/

    #5
    scook
    Forum Host
    • Total Posts : 24146
    • Joined: 2005/07/27 13:43:57
    • Location: TX
    • Status: offline
    Re: VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?! 2018/12/17 09:15:25 (permalink)
    Maybe time to upgrade to Win10.
     
    The reason plug-ins are missing is
    1) the VST reset cleared the CbB VST inventory in the registry and
    2) the scanner is not running to completion
     
    It is unusual the same vstscan.exe runs fine in SONAR but fails in CbB. Is it possible the scanner is failing everywhere but is only apparent in CbB because the VST inventory was cleared by running a reset? Does the scanner actually display the "Scan Complete" toast and plug-in count in SONAR? If not, the scanner is failing there too.
     
    By uninstalling and reinstalling CbB, the same scanner used by all three programs is removed and reinstalled.
     
    To create a scan log in Platinum just like the one created by CbB, hold the SHIFT key while clicking the scan button. This feature is not in X3 but should not matter since the scanner works in Platinum. This log may be used to compare to the CbB scan log.
     
    Even without the Platinum scan log, it should be pretty clear where the scanner stops in CbB by looking at the last plug-in reported in the CbB scan log.
     
    Before trying to repair by moving plug-ins in and out of the scan path, try toggling Scan in Sandbox in CbB preferences. The scanner should work better with the option enabled but it may be worth a shot with the option off.
     
    If the scanner still refuses to run to completion, try moving the last plug-in in the log out of the scan path and run the scan again. If Absynth 5.dll is not the last plug-in in the log, may want to temporarily move it out of the scan path too.
     
    There is a link to the main support page in the CbB help menu. The second link in msg #5 above is in the upper right of the main support page.
     
     
     
    #6
    csnack
    Max Output Level: -89 dBFS
    • Total Posts : 96
    • Joined: 2015/02/03 19:10:12
    • Status: offline
    Re: VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?! 2018/12/17 18:30:58 (permalink)
    Thanks scook. Yes, in X3e and SPLAT the toast message also appears after the scan and states the plugin count w/ no errors, so the vst scan certainly appears to be working correctly in X3e and SPLAT as it's scanning to completion, showing how many plugs it found and w/ zero errors and the plugs work fine and everything works fine in X3e and SPLAT. So I'm convinced that this vst scan problem - even if it is the same exact vstscan.exe - exists only in CbB, which yeah doesn't make much sense but that's what's happening.

    The vst scanner in CbB does display a toast message saying:

    'Scan is complete, XXX plugs found, 1 error'

    ... And then a windows pop-up comes up saying 'Vst scan has stopped working' - and it does that AFTER the scan and toast message appears. In fact, out of the countless times I ran the scan in CbB, I sat there and watched it and a few times and sometimes the toast message said there were NO errors, but then that pop-up comes up anyway saying vst scan is shutting down and still zero vst3 plugs are scanned/found.

    Since Absynth.dll is inexplicably showing up in that mini log as a "problem" I did yesterday temporarily move all of the Absynth.dll files out of the scan path yesterday and what happened was that Battery.dll was now listed in that little mini log as being the "problem." Going in alphabetical order, after Absynth.dll comes Battery.dll, so it appears to be all VST3 plugs that CbB won't scan, as all VST3 plugs and instruments are missing, and apparently if I move one of these plugs out of the scan path then it will just fail on the next one. It's scanning and finding the VST2 plugs, but zero vst3 plugs are scanned/found and the vst3 folder in Plugin Manager is empty, so it seems a vst3 problem solely with CbB.

    I'll be back at my daw shortly though and I'll try your Scan in Sandbox suggestion... Cuz after spending the whole day yesterday pulling my fro out over this even during the Seahawks game (I'm a Seattle guy), who lost, that one little tip of yours will probably work, lol. Thanks for the help man, I have reached out to Bandlab support and I'll update here.
    #7
    scook
    Forum Host
    • Total Posts : 24146
    • Joined: 2005/07/27 13:43:57
    • Location: TX
    • Status: offline
    Re: VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?! 2018/12/17 21:50:36 (permalink)
    Something I failed to mention before, one reason SONAR completes scanning and CbB does not may be SONAR is only scanning for new/removed plug-ins. CbB was reset which forces it to perform a complete scan of all VST2/3 plug-ins. I would expect SONAR would fail the same way as CbB if SONAR launched a VST reset.
     
    I believe paths are scanned in the order they are defined in the scan path. Given the VST3 path is after the VST2 path, if the scanner fails in the VST2 path or near the beginning the VST3 path, most the VST3 plug-ins will not be added after resetting the VST inventory.
     
    One other thing to note, so far only NI plug-ins have been mentioned as failing. This may be important.
    #8
    csnack
    Max Output Level: -89 dBFS
    • Total Posts : 96
    • Joined: 2015/02/03 19:10:12
    • Status: offline
    Re: VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?! 2018/12/17 23:56:53 (permalink)
    So I checked the "Scan in Sandbox" box and scanned and this time it was able to scan fully and find all my plugs. Then I unchecked the the box and scanned again the regular way and the scan errors out same as before. I checked the sandbox again, scanned again and it scans fine w/ the box checked. So I guess as long as that Scan in Sandbox box is checked things will hopefully continue to work, and reading about what Scan in Sandbox is/does it doesn't seem all that bad to have checked all the time if necessary.

    I removed Splice et al, but I still want to use it for rent to own, but I'm really wondering what it did to cause this problem for CbB and yes I blame Splice; too much of a coincidence otherwise as I've been adding plugs and rescanning regularly lately just fine but anyway. I'm wondering if trying Splice again after all this will cause my CbB daw to catch fire. I'll have to find out.

    Incidentally, TH2 or whatever it is always comes up as a bad plug in a scan for me on CbB (but not SPLAT) so it's always disabled, anyway. So scook looks like you fixed it so long as that box is checked. Thanks brother.

    P. S. FWIW, I only hit the Reset button after the 2nd or 3rd time the scan errored, so it was failing even prior to the reset though I don't intend to test this. All my NI stuff is working. I was staring at the sandbox box yesterday and I should've just ticked it but it's a good lesson sometimes there's one more tiny thing left to try when I was positive there was nothing left to try plus the Seahawks lost lol

    Thanks scook
    #9
    scook
    Forum Host
    • Total Posts : 24146
    • Joined: 2005/07/27 13:43:57
    • Location: TX
    • Status: offline
    Re: VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?! 2018/12/18 05:56:17 (permalink)
    Good news, I believe "Scan in Sandbox" should be enabled in CbB whenever possible.
     
    If scanning TH2 throws an dialog to Enable/Disable select the "risky" enable option. It should be OK. If disabled, the plug-in is probably in the VST audio plug-in exclude list. Open the Plug-in Manager, click on VST Audio Plug-ins, Show Excluded and enable the plug-in.
     
    What is strange about the original issue is the scanner failing on a previously scanned plug-in. Normally plug-ins are scanned when installed or updated then skipped in future scans unless the "Rescan Failed Plugins" or "Rescan Existing Plugins" options are enabled. The rescan options should always be unchecked unless trying to solve specific issues.
    #10
    csnack
    Max Output Level: -89 dBFS
    • Total Posts : 96
    • Joined: 2015/02/03 19:10:12
    • Status: offline
    Re: VST Scan Fail and VST3 Plugins Missing after installing Splice/Decimort2 ?! 2018/12/18 19:50:02 (permalink)
    Thanks again man and a great additional tips. Just reinstalled Splice and Decimort 2 and was able complete a full scan, but this time Splice did something to my waves v10 plugins and I had to run that waves v9 to v10 organizer again and now everything *seems* OK w/ Splice/Decimort 2 installed, but wtf is up w/ Splice anyway it's like it's determined to mess my s#++ up somehow lol
    #11
    Jump to:
    © 2019 APG vNext Commercial Version 5.1