iZotope Vocal Doubler is very CPU hungry [SOLVED]

Author
petemus
Max Output Level: -90 dBFS
  • Total Posts : 24
  • Joined: 2013/09/23 15:11:13
  • Status: offline
2018/10/10 06:35:55 (permalink)

iZotope Vocal Doubler is very CPU hungry [SOLVED]

Just got meself this freebie. Seems fine otherwise, but it sure likes its share of the CPU cycles. Has anyone else tried this plugin in CbB?
 
My laptop is an Asus A75. Maybe a bit old, yes, but it has been able to handle other plugins quite well so far. Vocal Doubler really puts it to its knees just by inserting it to a track or channel. 
 
   -Petemus
post edited by petemus - 2018/10/10 15:41:26
#1

10 Replies Related Threads

    mettelus
    Max Output Level: -23 dBFS
    • Total Posts : 5209
    • Joined: 2005/08/05 03:19:25
    • Location: Maryland, USA
    • Status: offline
    Re: iZotope Vocal Doubler is very CPU hungry 2018/10/10 07:20:53 (permalink)
    That may have some look-ahead going on with it. If you bump up your audio buffer does it help? Small audio buffers lower latency at the expense of CPU usage. That is definitely a mixing plugin, so I would run a higher buffer (probably 1024 samples if the machine is seeing an excessive CPU hit) to play with it.
     
    I did mess with this some, and cannot see any CPU hit, but my machine was only running at 5% to begin with. Apples to oranges there, so wouldn't be as helpful as buffer settings.

    ASUS ROG Maximus X Hero (Wi-Fi AC), i7-8700k, 16GB RAM, GTX-1070Ti, Win 10 Pro, Saffire PRO 24 DSP, A-300 PRO, plus numerous gadgets and gizmos that make or manipulate sound in some way.
    #2
    bitflipper
    01100010 01101001 01110100 01100110 01101100 01101
    • Total Posts : 25863
    • Joined: 2006/09/17 11:23:23
    • Location: Everett, WA USA
    • Status: offline
    Re: iZotope Vocal Doubler is very CPU hungry 2018/10/10 13:31:40 (permalink)
    When I experimented with this plugin, I put it on five vocal tracks. I did not notice any unusual CPU usage. When I find some time this week I'll perform additional tests to see how it compares to similar effects. It's possible there is some buffering going on that might increase latency, and that could conceivably impact what you see on the CPU meter if you're running with very small buffers.


    All else is in doubt, so this is the truth I cling to. 

    My Stuff
    #3
    bitflipper
    01100010 01101001 01110100 01100110 01101100 01101
    • Total Posts : 25863
    • Joined: 2006/09/17 11:23:23
    • Location: Everett, WA USA
    • Status: offline
    Re: iZotope Vocal Doubler is very CPU hungry 2018/10/10 13:32:24 (permalink)
    I'm going to move this to the Software forum, as it is not directly relevant to SONAR/Cakewalk.
     


    All else is in doubt, so this is the truth I cling to. 

    My Stuff
    #4
    petemus
    Max Output Level: -90 dBFS
    • Total Posts : 24
    • Joined: 2013/09/23 15:11:13
    • Status: offline
    Re: iZotope Vocal Doubler is very CPU hungry 2018/10/10 13:55:07 (permalink)
    Thanks for all your replies, folks!
     
    I find the plugin behavior a bit odd, because it also makes the entire Cakewalk UI very unresponsive. Seems to make no difference if the plugin UI is visible or not. The UI of the plugin is also very stiff, it takes a long time to see any alteration in the settings.
     
    My soundcard is Focusrite 2i2 (1st gen), with the latest drivers, on Windows 10 1803. I might to tinker with buffer sizes as well to see if it makes any difference. I think the setting was 1024 samples, as high as it would go.
     
    Have to try the plugin on a small project by itself to see, how it is then...
    #5
    bitflipper
    01100010 01101001 01110100 01100110 01101100 01101
    • Total Posts : 25863
    • Joined: 2006/09/17 11:23:23
    • Location: Everett, WA USA
    • Status: offline
    Re: iZotope Vocal Doubler is very CPU hungry 2018/10/10 14:56:54 (permalink)
    petemus
    ...it also makes the entire Cakewalk UI very unresponsive. Seems to make no difference if the plugin UI is visible or not. The UI of the plugin is also very stiff, it takes a long time to see any alteration in the settings.

    Could be related to GPU acceleration issues, or conceivably iZotope's usage analytics. I don't know if you can disable GPU acceleration for iZotope products, but you can disable analytics via the registry (\HKCU\Software\iZotope\VOCALDOUBLER\EnableAnalytics). Might be worth at least looking to see if analytics are enabled.
     


    All else is in doubt, so this is the truth I cling to. 

    My Stuff
    #6
    petemus
    Max Output Level: -90 dBFS
    • Total Posts : 24
    • Joined: 2013/09/23 15:11:13
    • Status: offline
    Re: iZotope Vocal Doubler is very CPU hungry 2018/10/10 15:44:21 (permalink)
    It turned out to be the GPU. My laptop has this funny Intel/nVidia combo and Cakewalk was running on the integrated Intel GPU. Switched it to use the nVidia and voilà, Vocal Doubler now behaves like the other plugins.
     
    Thanks for the hint, bitflipper!
     
       -Pete
    #7
    Paul G
    Max Output Level: -52 dBFS
    • Total Posts : 2329
    • Joined: 2004/03/17 21:38:03
    • Location: Florida
    • Status: offline
    Re: iZotope Vocal Doubler is very CPU hungry 2018/10/10 16:26:00 (permalink)
    I tried it out several days ago and saw no issues.

    Intel i7-4790K, Win7 Pro, 16GB Ram
    1TB OS, 2TB Audio, 1TB Samples
    Focusrite Scarlett 6i6
    Cakewalk by Bandlab
    Paul Robert Glaser
    The Brothers Glaser
    SoundClick
    #8
    leaglebeagle
    Max Output Level: -90 dBFS
    • Total Posts : 4
    • Joined: 2017/02/28 19:39:23
    • Status: offline
    Re: iZotope Vocal Doubler is very CPU hungry 2018/10/10 16:27:33 (permalink)
    petemus
    It turned out to be the GPU. My laptop has this funny Intel/nVidia combo and Cakewalk was running on the integrated Intel GPU. Switched it to use the nVidia and voilà, Vocal Doubler now behaves like the other plugins.
     
    Thanks for the hint, bitflipper!
     
       -Pete


    Hi
     
    I too have this GPU combo and whatever I do via Nivida control panel, windows settings or Sonar exe file I cannot force Sonar to use the Nvidia card. All other apps I point at Nvidia are fine using windows settings only (Studio One, Sound Forge.....etc).
     
    Would you mind saying how you did this please?
     
    TIA
     
    sb
    #9
    clintmartin
    Max Output Level: -36.5 dBFS
    • Total Posts : 3889
    • Joined: 2009/10/11 12:16:43
    • Location: Fort Smith, AR
    • Status: offline
    Re: iZotope Vocal Doubler is very CPU hungry 2018/10/11 03:39:12 (permalink)
    I have tried to install it several times now and keep getting a "Main call" error. Cakewalk tells me to disable it.

    Sonar Platinum, Harrison Mixbus 4, Waveform 9, ADK intel i7 2600 3.40 ghz, 8gb Ram, Win 7, Presonus Audiobox 44VSL. 
     https://itunes.apple.com/...lint-martin/1010966023
    https://open.spotify.com/artist/4x4TBz32i56bTJkgu7b4tN
     
     
     
    #10
    petemus
    Max Output Level: -90 dBFS
    • Total Posts : 24
    • Joined: 2013/09/23 15:11:13
    • Status: offline
    Re: iZotope Vocal Doubler is very CPU hungry 2018/10/11 09:11:36 (permalink)
    leaglebeagle
    petemus
    It turned out to be the GPU. My laptop has this funny Intel/nVidia combo and Cakewalk was running on the integrated Intel GPU. Switched it to use the nVidia and voilà, Vocal Doubler now behaves like the other plugins.
     
    Thanks for the hint, bitflipper!
     
       -Pete


    Hi
     
    I too have this GPU combo and whatever I do via Nivida control panel, windows settings or Sonar exe file I cannot force Sonar to use the Nvidia card. All other apps I point at Nvidia are fine using windows settings only (Studio One, Sound Forge.....etc).
     
    Would you mind saying how you did this please?
     
    TIA
     
    sb




    I did just that: set Cakewalk.exe (which I use) to use "High performance..." or whatever the "non-integrated GPU" option is called, applied the setting. Then launched Cakewalk and checked the Vocal Doubler UI, and it was fine now. I guess the graphics it wants to show are quite resource-consuming. Would be nice to disable such resource hogs, though; as if there wasn't more important stuff to burn CPU cycles on in a DAW than UI animation... 
     
        -Pete
    #11
    Jump to:
    © 2018 APG vNext Commercial Version 5.1