Helpful Reply[solved] Ilok License Manager problems

Author
mikedocy
Max Output Level: -67 dBFS
  • Total Posts : 1157
  • Joined: 2007/05/09 23:00:37
  • Location: Cleveland, Ohio
  • Status: offline
2015/08/31 22:34:35 (permalink)

[solved] Ilok License Manager problems

I installed a new graphics card and now "Ilok License Manager" (ILM) is giving me this pop-up error message:
 
"Software Component Unavailable
A background component required for iLok License Manager seems to be unavailable. If rebooting does not fix this issue, please visit iLok.com and download and run the latest License Support installer."
 
I rebooted and got the same result.
I reinstalled and was able to move my licenses to the cloud.
I uninstalled ILM, rebooted, reinstalled ILM then reactivated my licenses. Everything worked and seemed to be OK.
Now, one day later, I turn on the computer and start up Sonar, load a project, and all the previously activated vst are popping up with messages saying that they are not activated. I am back at square one.
 
I'm not sure what to do now. Any suggestions? I will contact Ilok, but maybe someone has been through this and can tell me how to fix it myself.
 
Thanks.
 
PS. I am beginning to dislike "Ilok License Manager"
 
post edited by mikedocy - 2015/09/01 18:58:41
#1
cclarry
Max Output Level: 0 dBFS
  • Total Posts : 20964
  • Joined: 2012/02/07 09:42:07
  • Status: offline
Re: Ilok License Manager problems 2015/08/31 22:41:53 (permalink)
Make sure you are running the current version of iLok Manager....


#2
mikedocy
Max Output Level: -67 dBFS
  • Total Posts : 1157
  • Joined: 2007/05/09 23:00:37
  • Location: Cleveland, Ohio
  • Status: offline
Re: Ilok License Manager problems 2015/08/31 23:22:45 (permalink) ☄ Helpfulby H3O2 2016/07/26 21:19:45
cclarry
Make sure you are running the current version of iLok Manager....


Thanks, yes I am. That's one of the first things I tried.
I may be onto something here. I followed their online help and it told me to set pace services to "delayed startup" and, so far, it seems to be working. If the problem is indeed solved I will post more details tomorrow for the benefit of anyone else reading this post and having the same problem.
#3
Sycraft
Max Output Level: -73 dBFS
  • Total Posts : 871
  • Joined: 2012/05/04 21:06:10
  • Status: offline
Re: Ilok License Manager problems 2015/09/01 01:33:14 (permalink) ☄ Helpfulby aghschwabe 2015/11/27 16:53:30
mikedocy
Thanks, yes I am. That's one of the first things I tried.
I may be onto something here. I followed their online help and it told me to set pace services to "delayed startup" and, so far, it seems to be working. If the problem is indeed solved I will post more details tomorrow for the benefit of anyone else reading this post and having the same problem.



If that does fix it then it means that there is another service that the iLok is depending on that wasn't starting fast enough for its tastes. If it does fix it see if you can get a list of services it depends on.
#4
mikedocy
Max Output Level: -67 dBFS
  • Total Posts : 1157
  • Joined: 2007/05/09 23:00:37
  • Location: Cleveland, Ohio
  • Status: offline
Re: Ilok License Manager problems 2015/09/01 19:05:57 (permalink) ☄ Helpfulby backwoods 2015/09/01 20:51:38
Yes, Sycraft. There seems to be another service (that is slow to get started) that ILM waits for.
If ILM doesn't get the needed service in time it doesn't run and you get VST authorization errors.
 
To check for this problem go to Administrative Tools/Services/ and see if "Pace License Services" status is  "running".
If not running then that is the problem.
The quick fix is to double click or right click and select Properties then change "Startup Type" from "Automatic" to "Automatic (Delayed Startup)". This causes the Pace service to wait a while before running.
 
I have no idea what service(s) Pace was waiting for. I could not find any dependencies for Pace.
My guess it that either the graphics card was calling home checking for updates or Microsoft was checking/updating and it caused Pace to time out and not run.
 
See here for more detailed troubleshooting information: https://www.ilok.com/#!resource/windows_troubleshooting
 
 
#5
Sycraft
Max Output Level: -73 dBFS
  • Total Posts : 871
  • Joined: 2012/05/04 21:06:10
  • Status: offline
Re: Ilok License Manager problems 2015/09/01 20:26:44 (permalink)
So nice of them to not tell us what the hell it needs :P.
#6
backwoods
Max Output Level: -49.5 dBFS
  • Total Posts : 2571
  • Joined: 2011/03/23 17:24:50
  • Location: South Pacific
  • Status: offline
Re: Ilok License Manager problems 2015/09/01 20:43:13 (permalink)
Good to know just in case :) Thanks for detailing this mikedocy.
#7
H3O2
Max Output Level: -90 dBFS
  • Total Posts : 2
  • Joined: 2012/03/22 15:29:42
  • Status: offline
Re: Ilok License Manager problems 2016/07/26 20:59:19 (permalink) ☄ Helpfulby wesjones 2016/09/17 01:44:29
Starting the service fixed the problem.  It was set to automatic but sometimes it NEVER starts.  Now I hate iLok a tiny bit less... maybe.
 
Thanks for the help and the details.
 
Steve S.
#8
arachnaut
Max Output Level: -67 dBFS
  • Total Posts : 1168
  • Joined: 2007/05/05 17:24:33
  • Location: Sunnyvale, CA USA
  • Status: offline
Re: Ilok License Manager problems 2016/07/26 23:51:44 (permalink)
On my Win10 laptop the PACE service starts on Automatic, but on my desktop it rarely starts up.
I switch to and from delay start, but I don't think it matters much, I just get into the habit of starting it myself.

- Jim Hurley -
SONAR Platinum - x64  - Windows 10 Pro 
ASUS P8P67 PRO Rev 3.0;  Core i7-2600K@4.4GHz; 16 GB G.SKILL Ripjaws X;
GeForce GT 740; Saffire Pro14 MixControl 3.7; Axiom 61
64-Bit audio, SR: 48kHz, ASIO 256 samples latency, Rec/Play I/O Buffers 512k, Total Round Trip Latency 13 ms, Pow-r 3 dither 
#9
kitekrazy1
Max Output Level: -40 dBFS
  • Total Posts : 3524
  • Joined: 2014/08/02 17:52:51
  • Status: offline
Re: Ilok License Manager problems 2016/07/27 14:49:23 (permalink)
There's a cloud for iLok?   The problem is rarely the dongle unless you aren't using one.

Sonar Platinum, W7 Pro 32GB Ram, Intel i7 4790, AsRock Z97 Pro 4,  NVidia 750ti, AP2496
 
Sonar Platinum, W7 Pro, 16GB Ram, AMD FX 6300, Gigabyte GA 970 -UD3 P, nVidia 9800GT, Guitar Port, Terratec EWX 2496
#10
Thedoccal
Max Output Level: -85 dBFS
  • Total Posts : 290
  • Joined: 2014/10/12 16:43:08
  • Location: Joshua Tree, CA
  • Status: offline
Re: Ilok License Manager problems 2016/07/30 22:15:22 (permalink)
mikedocy
To check for this problem go to Administrative Tools/Services/ and see if "Pace License Services" status is  "running".
If not running then that is the problem.  The quick fix is to double click or right click and select Properties then change "Startup Type" from "Automatic" to "Automatic (Delayed Startup)". This causes the Pace service to wait a while before running.
 
 See here for more detailed troubleshooting information: https://www.ilok.com/#!resource/windows_troubleshooting
 



That worked for me.  Mine was set to disabled.

http://www.catastrophelounge.com
The NeckDive Strap - NEW^^
Sonar: Platinum Lifetime/Computer: i7-870, 16GB RAM, AMD R9 380 graphics, Windows 10 (Pro x64)/500gb SSD C:, Barracuda sample(3T) and projects(1T) drives/3 Display Monitors (2&3 split)/Audio Interface: Behringer UFX1604 USB/Firewire/USB Stick/MIDI: Roland A-800Pro, Keystation Pro 88, Roland UM-3G:/Hardware Synths: Korg M3, Yamaha MOX6, Roland TD-8
#11
Vastman
Max Output Level: -50 dBFS
  • Total Posts : 2508
  • Joined: 2006/08/30 02:49:18
  • Location: Oakland, CA
  • Status: offline
Re: Ilok License Manager problems 2016/09/24 15:43:45 (permalink)
I have been a long time defender of ilok but am in the middle of this very same problem, having purchased a laptop to continue songwriting while caring for my 90 year old mom up in Idaho...Here is exactly the case where I felt ilok was perfect... going to a new computer and not having to laboriously go thru the reauthorization process, like in Kontakt, which took me a few hours, only thanks to the new Native Access, which centralizes the serial numbers... But NOOOOOOO! I'm totally stuck at the moment...given that this stupid License Manager is all screwed up. This is a RIDICULOUS situation to be still happening a year after people started complaining about it...I followed the ilok thread suggestions yesterday and was able to use Ozone to process a song I'd been working on but then last night I rebooted and now have the same thing happening.

This problem should have been rectified by now. While I've not had this problem with my desktop rig when migrating to W10, I do now! F'um...

Will try again to fix this issue... arrrrrg! Ruined my evening last night.

Dana
We make the future... Climate Change Music
VastMaschine:SP4L/W10/i74930K/32GB/RME/CAD E100s; The Orchestra! NOVO!/Inspire/BohemianViolin&Cello, ARK1&2,/MinimalCapriccioMaximoSoto/OE1&2, Action&Emotive/Omni2/Tril/RMX/All OrangeTree/Falcon/APE Jugs/Alpha&Bravo/BFD3 & SD3
Gravity/DM307/AEON/DM/Damage/Diva/HZebra/Hive/Diversion/VC4/Serum/Alchemy/blablabla
Spitfire/8DIO/SL/KH/EW/NI; Shred1&2/AGF,G,M&T Torch&Res&Ren/GD-6; Ibanez SR1200&SR505
NOVAX FanFret Tele&Strat 
#12
subtlearts
Max Output Level: -53.5 dBFS
  • Total Posts : 2200
  • Joined: 2006/01/10 05:59:21
  • Location: Berlin
  • Status: offline
Re: Ilok License Manager problems 2016/12/02 04:41:19 (permalink)
Once again, CW forums to the rescue! I was banging my head against the wall about this, I'm not very iLok-savvy having scrupulously avoided it for years but then a few sweet deals on things that required it led me down the garden path (no physical iLok here though). Everything was relatively smooth until I picked up the AIR complete bundle for a song (well, a figurative song anyway), having demo'd a couple of the synths, and started installing its various other bits. Suddenly iLok is down for the count, and no amount of reinstalling, rebooting, uninstalling (rinse and repeat) seemed to be doing anything.
 
Google the error message... first hit is this thread... problem solved. Boom. Gotta love that. Thanks folks!
 
Hopefully the Air stuff is worth the effort in the end. I particularly like Loom, and I've heard good things about Transfuser...

tobias tinker 
music is easy: just start with complete silence, and take away the parts you don't like!
tobiastinker.com
aeosrecords.com
soundfascination.com
Sonar Platinum, a bunch of other stuff...
#13
E-Dub
Max Output Level: -90 dBFS
  • Total Posts : 30
  • Joined: 2015/01/28 17:17:16
  • Status: offline
Re: Ilok License Manager problems 2016/12/25 09:51:53 (permalink)
Wow! Having the same problem on Christmas morning. It worked! Thanks!
#14
yorolpal
Max Output Level: 0 dBFS
  • Total Posts : 13829
  • Joined: 2003/11/20 11:50:37
  • Status: offline
Re: Ilok License Manager problems 2016/12/25 11:24:44 (permalink)
I always check to make sure the ILM is working right after every new plug I install...whether it is an iLok plug or not. Plus I go back and check the services after every new Win10 update. I don't know why they cannot fix this problem. But at least I can. Sheesh.

https://soundcloud.com/doghouse-riley/tracks 
https://doghouseriley1.bandcamp.com 
Where you come from is gone...where you thought you were goin to weren't never there...and where you are ain't no good unless you can get away from it.
 
SPLAT 64 bit running on a Studio Cat Pro System Win 10 64bit 2.8ghz Core i7 with 24 gigs ram. MOTU Audio Express.
#15
northlake63
Max Output Level: -90 dBFS
  • Total Posts : 15
  • Joined: 2015/01/02 20:43:13
  • Location: Charlotte, NC
  • Status: offline
Re: Ilok License Manager problems 2017/01/17 03:07:41 (permalink)

To check for this problem go to Administrative Tools/Services/ and see if "Pace License Services" status is  "running".
If not running then that is the problem.  The quick fix is to double click or right click and select Properties then change "Startup Type" from "Automatic" to "Automatic (Delayed Startup)". This causes the Pace service to wait a while before running.
 
This fixed it.
#16
jonnewyork
Max Output Level: -85 dBFS
  • Total Posts : 263
  • Joined: 2007/02/07 19:38:38
  • Status: offline
Re: Ilok License Manager problems 2017/08/13 21:15:27 (permalink)
mikedocy
Yes, Sycraft. There seems to be another service (that is slow to get started) that ILM waits for.
If ILM doesn't get the needed service in time it doesn't run and you get VST authorization errors.
 
To check for this problem go to Administrative Tools/Services/ and see if "Pace License Services" status is  "running".
If not running then that is the problem.
The quick fix is to double click or right click and select Properties then change "Startup Type" from "Automatic" to "Automatic (Delayed Startup)". This causes the Pace service to wait a while before running.
 
I have no idea what service(s) Pace was waiting for. I could not find any dependencies for Pace.
My guess it that either the graphics card was calling home checking for updates or Microsoft was checking/updating and it caused Pace to time out and not run.
 
See here for more detailed troubleshooting information: https://www.ilok.com/#!resource/windows_troubleshooting
 
 


Thanks and hallefreakinlujah!
 
I still have no idea what caused ilok's massive failure but I know what to do in the future.
 
I just wish Ilok wouldn't provide us with an unwanted and unwarranted Indiana Jones and the Mystery of Malfunctioning Software experience.
 
 

Cheers,
 Jon
 
Win 7 Pro
Intel Core i7-3770 @ 3.40 GHz, 3.40 GHz
16 GB RAM
64 bit op sys
Lynx Aurora 16 ADC w/ AES16e card
 
 

 
#17
TheMaartian
Max Output Level: -47.5 dBFS
  • Total Posts : 2774
  • Joined: 2015/05/21 18:30:52
  • Location: Flagstaff, AZ
  • Status: offline
Re: Ilok License Manager problems 2017/08/14 14:09:33 (permalink)
Amateur tip (I'm no pro)...
 
You will need to reset the PACE startup to "Automatic - Delayed" or "Automatic (Trigger Start)", depending on your Windows version, every time you update the iLok Manager. It gets, or used to get, reset to "Automatic" by the installer. With the latest version of Win10, with the new "Trigger Start", I don't know what happens on install. I'll have to check it after the next iLok Manager update.

Intel i7 3.4GHz, 16 GB RAM, 2 TB HD Win10 Home 64-bit Tascam US-16x08
Studio One 4 Pro NotionMelodyne 4 Studio Acoustica 7 Guitar Pro 7
PreSonus FaderPort Nektar P6 M-Audio BX8 D2 Beyerdynamic DT 880 Pro
NI K9U XLN AK, AD2 AAS VS-2, GS-2, VA-2, EP-4, CP-2, OD Toontrack SD3, EZK
#18
Jump to:
© 2019 APG vNext Commercial Version 5.1