Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221

Author
ebayer
Max Output Level: -89 dBFS
  • Total Posts : 86
  • Joined: 2003/11/22 17:23:14
  • Location: San Jose, CA, USA
  • Status: offline
2009/12/17 14:01:57 (permalink)

Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221

I've now tried 8.5 and 8.5.2 and have a continuing problem.  When I use it on my Laptop, Sonar will popup a message fairly routinely (every 20s-2min) that says the following:


Conexant High Definition SmartAudio 221

The above Audio/MIDI device was disconnected from your system.  Would you like SONAR to reroute these outputs to an available device?  Clicking 'No' allows SONAR to remember output settings to this device.  Note: If playback is in progress, clicking 'Yes' will stop the transport.


This is the built in laptop audio card.  It is already at the latest version that I can get (HP hasn't updated it in almost a year.)  The most annoying thing is that though this pops up routinely, the audio never seems to be effected despite using ASIO4ALL connected to this device (or using ASIO via M-Audio Fast Track Ultra.)  Moreover, I believe by the naming it is referring not to the ASIO4ALL driver either.

Is there a way to get Sonar to not popup when audio devices you aren't using are "disconnected", or maybe a way to force it to ignore a specific audio device?  This more or less renders Sonar unusable because the popup gets in the way (and takes over the keyboard) very routinely.

Any help would be greatly appreciated as I really would like to use the Arpreggiator as well as some other new features.  For the time being I am stuck using 8.0.

    -Eric
#1

13 Replies Related Threads

    emwhy
    Max Output Level: -68 dBFS
    • Total Posts : 1145
    • Joined: 2006/01/03 15:09:02
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2009/12/17 14:25:40 (permalink)
    Gotta get a real audio interface with better drivers, sorry to say, but built-in audio devices with 3rd party drivers can be a recipe for disaster in many cases.


    #2
    scoble08
    Max Output Level: -90 dBFS
    • Total Posts : 6
    • Joined: 2005/01/26 08:13:23
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2009/12/17 16:39:53 (permalink)
    I get the same msg with my AXION 61 keyboard.  Doesn't matter if I'm using MIDI in/out or USB.
    Very annoying!
    Win 7 x64
    Sonar 8.5.2 x32
    emu 1212m

    #3
    ebayer
    Max Output Level: -89 dBFS
    • Total Posts : 86
    • Joined: 2003/11/22 17:23:14
    • Location: San Jose, CA, USA
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2009/12/17 16:42:04 (permalink)
    Even when not using the built in sound card it interferes with my use of the software.  I have a M-Audio Fast Track Ultra that I use many times.  The popups occur no matter which sound driver I'm using, they just always are for the built in Conexant HD SmartAudio 221.  This is why I want a way to disable either specific audio drivers or any unused audio drivers from the monitoring that Sonar does.
    #4
    emwhy
    Max Output Level: -68 dBFS
    • Total Posts : 1145
    • Joined: 2006/01/03 15:09:02
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2009/12/17 16:46:15 (permalink)
    Just disable the Conextant in device manager, that way the driver doesn't load at all and hopefully keeps SONAR running smoothly.


    #5
    ebayer
    Max Output Level: -89 dBFS
    • Total Posts : 86
    • Joined: 2003/11/22 17:23:14
    • Location: San Jose, CA, USA
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2009/12/17 17:15:06 (permalink)
    Hrm, thanks.  This seems to work as a workaround.  It allows me to use the M-Audio FTU without issue.  And thank goodness Windows 7 makes disabling/re-enabling easy and not requiring a reboot etc.

    That said, I am hoping there is another answer so that I can use ASIO4All as well.  Sometimes I'd rather not cart an audio interface and speakers/headphones around with me.  Note that even though the popups occur playback will continue happily using ASIO4All and the internal card.  Pressing No will get rid of it and it will continue still.  The only real hassle is the continual popups themselves.  And it never gives a message about the audio being connected, just disconnected over and over and over.  Also of note, Sonar 8.0 works fine in this configuration and there are no audio glitches noticeable in either 8.0 or 8.5 when using ASIO4All.  I'll probably contact Cakewalk about this, but I figured I'd ask here just in case it was something people had seen and gotten by.
    #6
    drhigh5
    Max Output Level: -90 dBFS
    • Total Posts : 25
    • Joined: 2007/04/24 09:40:19
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2010/03/01 08:41:38 (permalink)
    I have same issue since upgrading. How infuriating.
     
    I can't disable conexant as this is only sound card I have. I expect I will have to go back to 8.0.
     
    I am using the ASIO drivers which work fine for audio but no matter what I do I get serious latency playing midi, about quarter of a bar.
     
    When I look to see what is playing the midi it is the Microsoft GS Wavetable Synth with no option to change. Does ASIO have a Midi driver?
    I too have HP Pavillion (dv2500), Windows 7 (32 bit).
    post edited by drhigh5 - 2010/03/01 08:43:31
    #7
    ms22282
    Max Output Level: -90 dBFS
    • Total Posts : 15
    • Joined: 2006/09/25 16:19:55
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2010/03/13 12:59:21 (permalink)
    I get the same popup on my laptop. I use M-Audio fast pro and Conexant HD SmartAudio. I can't disable the Conexant HD SmartAudio because I'm blind and had to use a screen reader through it. Is there any other work around?
    #8
    darrenlc
    Max Output Level: -90 dBFS
    • Total Posts : 35
    • Joined: 2004/04/07 21:25:33
    • Location: Christiansburg, VA
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2010/04/23 01:16:35 (permalink)
    ebayer


    I've now tried 8.5 and 8.5.2 and have a continuing problem.  When I use it on my Laptop, Sonar will popup a message fairly routinely (every 20s-2min) that says the following:


    Conexant High Definition SmartAudio 221

    The above Audio/MIDI device was disconnected from your system.  Would you like SONAR to reroute these outputs to an available device?  Clicking 'No' allows SONAR to remember output settings to this device.  Note: If playback is in progress, clicking 'Yes' will stop the transport.


    Same problem except mine involves the built-in audio card for a new Windows 7 desktop from BOXX. Mercifully I am able to disable it and use my line6 Toneport UX2.

    Sonar X2 Producer Expanded
    i5 2.67 GHz
    6 GB
    Windows 7 Pro 64-bit
    Avast
    #9
    CJaysMusic
    Max Output Level: 0 dBFS
    • Total Posts : 30692
    • Joined: 2006/10/28 01:51:41
    • Location: Miami - Fort Lauderdale
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2010/04/23 01:19:41 (permalink)

    When I look to see what is playing the midi it is the Microsoft GS Wavetable Synth with no option to change. Does ASIA have a Midi driver? I too have HP Pavillion (dv2500), Windows 7 (32 bit).
    Dont use the GS wavetable. Use soft synths. ASIA is a driver mode, not a driver. Your sound card uses ASIO or WDM drivers and if your sound card has midi, then that is what has a midi driver. Or if you have a midi interface, like a midi controllers, that would have a midi driver. But AUDIO is a driver mode
    Cj
    Note. Onboard sound chips are not recommended for use with sonar. If you stop using them, your problems will go away
    Cj
    post edited by CJaysMusic - 2010/04/23 01:20:45


    www.audio-mastering-mixing.com - A Professional Worldwide Audio Mixing & Mastering Studio, Providing Online And Attended Sessions. Rated # 1 on Top20Sites For Audio Mastering.
     
     
    #10
    John
    Max Output Level: 0 dBFS
    • Total Posts : 25574
    • Joined: 2003/11/06 11:53:17
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2010/04/23 10:36:45 (permalink)
    What is happening here is you have SmartAudio 221 selected as an audio device in audio options along with Fast track. Sonar is only doing what you have setup there. All you need do is deselect Smartaudio in the list of audio devices. No need to disable it in Windows. 

    Best
    John
    #11
    SilkTone
    Max Output Level: -66 dBFS
    • Total Posts : 1232
    • Joined: 2003/11/10 17:41:28
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2010/04/23 12:15:37 (permalink)
    The reason you might be getting the popup in the first place is because Windows might power down the hardware after a few minutes of inactivity to conserve power. You need to figure out how to disable this, maybe in the BIOS, in the audio driver settings or in the power profile settings.

    As I said, this might be your problem, but if you are actively using the computer at the time the popup appears, then it is most likely something else.

    I have also seen this very same popup on my desktop computer with my Firewire FA-66 after the computer has been idle for a few hours while Sonar is open.
    post edited by SilkTone - 2010/04/23 12:16:49

    SONAR X3d 64-bit, Windows 8 Pro x64
    Komplete Audio 6 USB
    Intel Core2 Quad Q9450 @ 2.66GHz, 8GB, 256GB SSD (for OS), Multiple MDs
    AMD Radeon HD 6800, 2 x Monitors + 1 Monitor in ISO booth
     
     
     
    #12
    ebayer
    Max Output Level: -89 dBFS
    • Total Posts : 86
    • Joined: 2003/11/22 17:23:14
    • Location: San Jose, CA, USA
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2010/12/17 17:45:43 (permalink)
    If anyone has this problem, please file a tech support request.  I tried to get this fixed before, but I've decided that the only way it'll get fixed is numbers. (I'm posting this on every thread where someone reported this issue.)
    #13
    bbent91745
    Max Output Level: -89 dBFS
    • Total Posts : 96
    • Joined: 2008/04/06 18:50:32
    • Status: offline
    Re:Sonar 8.5.x disconnected popup issue (Windows 7 x64 with Conexant HD SmartAudio 221 2010/12/17 18:08:48 (permalink)
    ebayer


    I've now tried 8.5 and 8.5.2 and have a continuing problem.  When I use it on my Laptop, Sonar will popup a message fairly routinely (every 20s-2min) that says the following:


    Conexant High Definition SmartAudio 221

    The above Audio/MIDI device was disconnected from your system.  Would you like SONAR to reroute these outputs to an available device?  Clicking 'No' allows SONAR to remember output settings to this device.  Note: If playback is in progress, clicking 'Yes' will stop the transport.


    This is the built in laptop audio card.  It is already at the latest version that I can get (HP hasn't updated it in almost a year.)  The most annoying thing is that though this pops up routinely, the audio never seems to be effected despite using ASIO4ALL connected to this device (or using ASIO via M-Audio Fast Track Ultra.)  Moreover, I believe by the naming it is referring not to the ASIO4ALL driver either.

    Is there a way to get Sonar to not popup when audio devices you aren't using are "disconnected", or maybe a way to force it to ignore a specific audio device?  This more or less renders Sonar unusable because the popup gets in the way (and takes over the keyboard) very routinely.

    Any help would be greatly appreciated as I really would like to use the Arpreggiator as well as some other new features.  For the time being I am stuck using 8.0.

       -Eric
    Eric,
    In Sonar 8.5, click Options-Audio. In the General tab, make sure that the Playback and Record Timing Masters are set to your M-Audio Fast Track Ultra device. On the Drivers tab, make sure that only the M-Audio Fast Track Ultra Input and Output drivers are selected. That should be sufficient to solve your problem without having to disable the internal audio device in Device Manager. That should also solve the problem for MS22282 who needs the Conesant HD SmartAudio for the screen reader.

    Good luck and Happy Holidays!



    Regards,
    bbent 

    HW: GA-X58A-UD3R, i7-930, 6GB & 2ea WD2002FAEX 2TB, 1ea WD1001FALS 1TB, UA1000, FP-7F, Yamaha 2.1 HS80M/HS10W
    SW: Win7 Pro x64, SPE 8.5.3, NI Komplete 8 Ult., Ivory Grand Pianos II
    #14
    Jump to:
    © 2014 APG vNext Commercial Version 5.1