Rapture Pro does not always create the error log file

Author
arachnaut
Max Output Level: -67 dBFS
  • Total Posts : 1168
  • Joined: 2007/05/05 17:24:33
  • Location: Sunnyvale, CA USA
  • Status: offline
2015/04/29 02:33:54 (permalink)

Rapture Pro does not always create the error log file

Summary, if you install the  'Cakewalk Content' somewhere other than C:, beware!
 
I installed Rapture Pro on my laptop which has only a C: drive and uses all the default installations.
However, on my workstation DAW, I have 14 drive volumes in use and I have various parts of installations on various volumes.
 
After installing, the laptop shows a log file in
C:\Cakewalk Content\Logs\rap2-log-apr28.txt
It has 4373 entries and lots of errors like this:
 
18:55:01 [ C:\Cakewalk Content\Rapture Pro\Programs\Rapture (legacy)\Galbanum Piscis\2 - Multiwave Pads\Bradypodion Pad.prog ] Loading Program
18:55:01 [ C:\Cakewalk Content\Rapture Pro\Programs\Rapture (legacy)\Galbanum Piscis\2 - Multiwave Pads\Bradypodion Pad.prog ] Loading Legacy Program. (Program format version 10014)
18:55:01 [ \library\audio\plug-ins\rapture content\galbanum architecture\sfz multiwaveforms\velocity crossfades\stfm3 index exp\mwvx stfm3 01 03-05 exp.sfz ] Loading .sfz file
18:55:01 (!) [ \library\audio\plug-ins\rapture content\galbanum architecture\sfz multiwaveforms\velocity crossfades\stfm3 index exp\mwvx stfm3 01 03-05 exp.sfz ] ERROR: unable to load
18:55:02 [ \library\audio\plug-ins\rapture content\galbanum architecture\sfz multiwaveforms\velocity crossfades\stfm3 index exp\mwvx stfm3 01 03-05 exp.sfz ] Loading .sfz file
18:55:02 (!) [ \library\audio\plug-ins\rapture content\galbanum architecture\sfz multiwaveforms\velocity crossfades\stfm3 index exp\mwvx stfm3 01 03-05 exp.sfz ] ERROR: unable to load
18:55:02 [ ] done loading legacy program

 
But on my workstation, the Cakewalk Content path is at
K:\Cakewalk Content\
and there is not a single 'Logs' folder anywhere on the K: volume.
 
 
 

- Jim Hurley -
SONAR Platinum - x64  - Windows 10 Pro 
ASUS P8P67 PRO Rev 3.0;  Core i7-2600K@4.4GHz; 16 GB G.SKILL Ripjaws X;
GeForce GT 740; Saffire Pro14 MixControl 3.7; Axiom 61
64-Bit audio, SR: 48kHz, ASIO 256 samples latency, Rec/Play I/O Buffers 512k, Total Round Trip Latency 13 ms, Pow-r 3 dither 
#1

8 Replies Related Threads

    Dan Gonzalez [Cakewalk]
    Administrator
    • Total Posts : 395
    • Joined: 2013/01/14 12:28:40
    • Status: offline
    Re: Rapture Pro does not always create the error log file 2015/04/29 17:22:40 (permalink)
    arachnaut
    Summary, if you install the  'Cakewalk Content' somewhere other than C:, beware!
     
    I installed Rapture Pro on my laptop which has only a C: drive and uses all the default installations.
    However, on my workstation DAW, I have 14 drive volumes in use and I have various parts of installations on various volumes.
     
    After installing, the laptop shows a log file in
    C:\Cakewalk Content\Logs\rap2-log-apr28.txt
    It has 4373 entries and lots of errors like this:
     
    18:55:01 [ C:\Cakewalk Content\Rapture Pro\Programs\Rapture (legacy)\Galbanum Piscis\2 - Multiwave Pads\Bradypodion Pad.prog ] Loading Program
    18:55:01 [ C:\Cakewalk Content\Rapture Pro\Programs\Rapture (legacy)\Galbanum Piscis\2 - Multiwave Pads\Bradypodion Pad.prog ] Loading Legacy Program. (Program format version 10014)
    18:55:01 [ \library\audio\plug-ins\rapture content\galbanum architecture\sfz multiwaveforms\velocity crossfades\stfm3 index exp\mwvx stfm3 01 03-05 exp.sfz ] Loading .sfz file
    18:55:01 (!) [ \library\audio\plug-ins\rapture content\galbanum architecture\sfz multiwaveforms\velocity crossfades\stfm3 index exp\mwvx stfm3 01 03-05 exp.sfz ] ERROR: unable to load
    18:55:02 [ \library\audio\plug-ins\rapture content\galbanum architecture\sfz multiwaveforms\velocity crossfades\stfm3 index exp\mwvx stfm3 01 03-05 exp.sfz ] Loading .sfz file
    18:55:02 (!) [ \library\audio\plug-ins\rapture content\galbanum architecture\sfz multiwaveforms\velocity crossfades\stfm3 index exp\mwvx stfm3 01 03-05 exp.sfz ] ERROR: unable to load
    18:55:02 [ ] done loading legacy program

     
    But on my workstation, the Cakewalk Content path is at
    K:\Cakewalk Content\
    and there is not a single 'Logs' folder anywhere on the K: volume.



    The destination for the log files are hard coded and cannot be changed. They will be in the same location regardless of which media path you set on initial install. 
     
    Secondly, we're currently looking into the Piscis Packs that you're showing in your log file right now. This we know about and we're on :)
    #2
    Doktor Avalanche
    Max Output Level: -32.5 dBFS
    • Total Posts : 4294
    • Joined: 2015/03/26 18:02:02
    • Status: offline
    Re: Rapture Pro does not always create the error log file 2015/04/29 17:46:31 (permalink)
     
    Dan Gonzalez [Cakewalk]
    The destination for the log files are hard coded and cannot be changed. They will be in the same location regardless of which media path you set on initial install. 
     

     
    Confirmed but not quite as Dan says.
    My Cakewalk Content is on drive D, no log files there.
    I look at drive C and no "Cakewalk Content" folder exists and no logs, this needs fixing! And we should have a settings area within Rap Pro where we put the log files anywhere we want. But why would be want log files in our content folder (can we make music out of them? )
     
    You can get the log files back by creating folders C:\Cakewalk Content\Logs which is messy  but at least it is a workaround...
    post edited by Doktor Avalanche - 2015/04/29 17:54:46
    #3
    Doktor Avalanche
    Max Output Level: -32.5 dBFS
    • Total Posts : 4294
    • Joined: 2015/03/26 18:02:02
    • Status: offline
    Re: Rapture Pro does not always create the error log file 2015/04/29 17:49:12 (permalink)
    Anybody know what this means in the log?
    [ Start Up ] ERROR: unable to get value for key "C3 Path"
     
    At least I know that there is something going on when I load silent programs now, but why it doesn't get indicated in the UI who knows!!!!!!
     
    22:52:24 [ D:\Cakewalk Content\Rapture Pro\Programs\Dimension Pro (legacy)\Digital Sound Factory Symphonic Strings HD\Symphonic Cinematic\Legato Pizzicato Large Section MW.prog ] Loading Legacy Program. (Program format version 10019)
    22:52:24 [ \program files\cakewalk\dimension pro\multisamples\digital sound factory symphonic strings hd\large section legato full.sfz ] Loading .sfz file
    22:52:24 (!) [ \program files\cakewalk\dimension pro\multisamples\digital sound factory symphonic strings hd\large section legato full.sfz ] ERROR: unable to load
    22:52:24 [ \program files\cakewalk\dimension pro\multisamples\digital sound factory symphonic strings hd\large section pizzicato full.sfz ] Loading .sfz file
    22:52:24 (!) [ \program files\cakewalk\dimension pro\multisamples\digital sound factory symphonic strings hd\large section pizzicato full.sfz ] ERROR: unable to load
    22:52:24 [ ] done loading legacy program
     
     
    post edited by Doktor Avalanche - 2015/04/29 17:58:34
    #4
    bluesplayer
    Max Output Level: -89 dBFS
    • Total Posts : 78
    • Joined: 2004/03/28 17:51:32
    • Status: offline
    Re: Rapture Pro does not always create the error log file 2015/04/29 18:20:08 (permalink)
    In my case, more than a few "legacy" Dim Pro and Rapture add-ons (like muz3um)  fail to load (i.e., make sound)
     
    Now that I know to look at log files it seems that 99% of the ones that make no sound (and load no samples) are because Rapture Pro is looking at wrong or nonexistent drives.  I have 5 internal drives (C, D, E, H and Z (Z- is my Win XP dual boot drive) and 2 external USB drives (J and K just bulk storage) .
     
    However, 100% of all ALL DP and RP libraries are install on my "D:\" hard drive (dedicated to music & DAW apps).   For all the log file recorded "errors" and "failed to load" errors Rapture Pro is looking at my C:\, or J:\, or F:\ (which is a DVD device) for the samples/multi-samples - there are none installed on those drives
     
    Larry
     
    #5
    arachnaut
    Max Output Level: -67 dBFS
    • Total Posts : 1168
    • Joined: 2007/05/05 17:24:33
    • Location: Sunnyvale, CA USA
    • Status: offline
    Re: Rapture Pro does not always create the error log file 2015/04/29 18:55:49 (permalink)
    Going forward, I would expect most users to have a C: solid state drive of about 400-600 GB in size and a secondary drive for collateral I/O and backup.
     
    I've had a multi-drive setup for many years so these problems are not new to me.
     
    However the problems they incite due to careless programming assumptions are very tedious.
     
    I wish Windows would remove that silly drive letter abomination and go to mount points or something else...
     
    Meanwhile, developers should know better by now not to hard-code stuff... Shame on them, they should be required to eat items only from the first 5 entries on a Wendy's menu for a month.
     
     

    - Jim Hurley -
    SONAR Platinum - x64  - Windows 10 Pro 
    ASUS P8P67 PRO Rev 3.0;  Core i7-2600K@4.4GHz; 16 GB G.SKILL Ripjaws X;
    GeForce GT 740; Saffire Pro14 MixControl 3.7; Axiom 61
    64-Bit audio, SR: 48kHz, ASIO 256 samples latency, Rec/Play I/O Buffers 512k, Total Round Trip Latency 13 ms, Pow-r 3 dither 
    #6
    Doktor Avalanche
    Max Output Level: -32.5 dBFS
    • Total Posts : 4294
    • Joined: 2015/03/26 18:02:02
    • Status: offline
    Re: Rapture Pro does not always create the error log file 2015/04/29 19:37:24 (permalink)
    > In my case, more than a few "legacy" Dim Pro and Rapture add-ons (like muz3um)  fail to load (i.e., make sound)
     
    I've got Muz3um running on Z3TA+2 had no idea it ran in Rapture.
     
    So far (all my samples on D drive) according to log:
     
    Les Paul Gold Top (always asks for the G drive for some reason).
    Digital Sound Factory Symphonic String HD (points to a totally different path with no drive letter)
    Hardgroove Steinberger (points to a totally different path on the C drive).
    And as has already been discussed log file insists on pointing to a hard coded file path and will not work unless folder is there.
     
    There need to be a batch auto fix utility or something... this ain't cool right now...
    If we had somewhere where we could correct it in settings so much the better as well.
    post edited by Doktor Avalanche - 2015/04/29 19:43:43
    #7
    gswitz
    Max Output Level: -18.5 dBFS
    • Total Posts : 5694
    • Joined: 2007/06/16 07:17:14
    • Location: Richmond Virginia USA
    • Status: offline
    Re: Rapture Pro does not always create the error log file 2015/04/29 22:18:13 (permalink)
    I'm experiencing the same.

    StudioCat > I use Windows 10 and Sonar Platinum. I have a touch screen.
    I make some videos. This one shows how to do a physical loopback on the RME UCX to get many more equalizer nodes.
    #8
    pwalpwal
    Max Output Level: -43 dBFS
    • Total Posts : 3249
    • Joined: 2015/01/17 03:52:50
    • Status: offline
    Re: Rapture Pro does not always create the error log file 2015/06/09 08:30:38 (permalink)
    arachnautdevelopers should know better by now not to hard-code stuff... Shame on them, they should be required to eat items only from the first 5 entries on a Wendy's menu for a month.

    "schoolboy error"

    just a sec

    #9
    Jump to:
    © 2022 APG vNext Commercial Version 5.1