Answeredx3 : Missing set of audio outs on Virus Ti VST3?

Author
Mystic38
Max Output Level: -59 dBFS
  • Total Posts : 1622
  • Joined: 2010/08/30 17:40:34
  • Location: Mystic, CT
  • Status: offline
2013/10/03 08:04:52 (permalink)

x3 : Missing set of audio outs on Virus Ti VST3?

Hoping another Virus owner can check this..
 
Virus control opens correctly as a VST2 with three audio outs, but only two audio outs as VST3
 
as VST2, outs 1,2 3 are indicated. routed sounds go to correct stereo pair ie 1 > 1, 2> 2, 3 > 3.
 
as VST3, outs 2, 3 are indicated. routed sounds go 1 > 2 , 2 > 3, and 3 > zip.
 
regards

HPE-580T with i7-950, 8G, 1.5T, ATI6850, Win7/64, Motu 828 III Hybrid, Motu Midi Express, Sonar Platinum, Komplete 9, Ableton Live 9 & Push 2, Melodyne Editor and other stuff, KRK VXT8 Monitors
Virus Ti2 Polar, Fantom G6, Yamaha S70XS, Novation Nova, Novation Nova II, Korg MS2000, Waldorf Micro Q, NI Maschine Studio, TC-VoiceLive Rack, 2012 Gibson Les Paul Standard, 2001 Gibson Les Paul DC, 1999 Fender Am Hardtail Strat, Fender Blues Jr, Orange TH30/PPC212, Tak EF360GF, one mic, no talent.
#1
Noel Borthwick [Cakewalk]
Cakewalk Staff
  • Total Posts : 6475
  • Joined: 2003/11/03 17:22:50
  • Location: Boston, MA, USA
  • Status: offline
Re: x3 : Missing set of audio outs on Virus Ti VST3? 2013/10/03 08:36:35 (permalink)
Have you confirmed whether it works as a VST3 elsewhere? Ask the developer to contact me and we can work with them on investigating this.

Noel Borthwick
Senior Manager Audio Core, BandLab
My Blog, Twitter, BandLab Profile
#2
Mystic38
Max Output Level: -59 dBFS
  • Total Posts : 1622
  • Joined: 2010/08/30 17:40:34
  • Location: Mystic, CT
  • Status: offline
Re: x3 : Missing set of audio outs on Virus Ti VST3? 2013/10/03 08:47:30 (permalink)
The VST3 version has been available some time however, since I knew you would ask(!), I had already posted a question on their user forum for feedback regarding VST3.
 
Ian

HPE-580T with i7-950, 8G, 1.5T, ATI6850, Win7/64, Motu 828 III Hybrid, Motu Midi Express, Sonar Platinum, Komplete 9, Ableton Live 9 & Push 2, Melodyne Editor and other stuff, KRK VXT8 Monitors
Virus Ti2 Polar, Fantom G6, Yamaha S70XS, Novation Nova, Novation Nova II, Korg MS2000, Waldorf Micro Q, NI Maschine Studio, TC-VoiceLive Rack, 2012 Gibson Les Paul Standard, 2001 Gibson Les Paul DC, 1999 Fender Am Hardtail Strat, Fender Blues Jr, Orange TH30/PPC212, Tak EF360GF, one mic, no talent.
#3
Mystic38
Max Output Level: -59 dBFS
  • Total Posts : 1622
  • Joined: 2010/08/30 17:40:34
  • Location: Mystic, CT
  • Status: offline
Re: x3 : Missing set of audio outs on Virus Ti VST3? 2013/10/12 17:22:54 (permalink)
The Virus Ti VST3 is known to work correctly inside of Cubase, and I also saw anecdotal evidence of correct operation inside of Studio One.
 To quote Access:  "there is nothing specific to the VST3 plugin. I can only assume this being an issue
with the VST3 inside Sonar at this point."
 
 
EDIT 15th October:
 
I can confirm directly that VST3 version of Virus Control works correctly inside of Studio One.
post edited by Mystic38 - 2013/10/15 14:46:16

HPE-580T with i7-950, 8G, 1.5T, ATI6850, Win7/64, Motu 828 III Hybrid, Motu Midi Express, Sonar Platinum, Komplete 9, Ableton Live 9 & Push 2, Melodyne Editor and other stuff, KRK VXT8 Monitors
Virus Ti2 Polar, Fantom G6, Yamaha S70XS, Novation Nova, Novation Nova II, Korg MS2000, Waldorf Micro Q, NI Maschine Studio, TC-VoiceLive Rack, 2012 Gibson Les Paul Standard, 2001 Gibson Les Paul DC, 1999 Fender Am Hardtail Strat, Fender Blues Jr, Orange TH30/PPC212, Tak EF360GF, one mic, no talent.
#4
Noel Borthwick [Cakewalk]
Cakewalk Staff
  • Total Posts : 6475
  • Joined: 2003/11/03 17:22:50
  • Location: Boston, MA, USA
  • Status: offline
Re: x3 : Missing set of audio outs on Virus Ti VST3? 2013/10/12 18:41:07 (permalink)
Please ask them to get in touch with me and I will investigate it. I can get the developer a copy of X3 as well.
Do you have any screenshots that can show the problem? Do you see all the outputs when you insert it as a synth?

Noel Borthwick
Senior Manager Audio Core, BandLab
My Blog, Twitter, BandLab Profile
#5
Mystic38
Max Output Level: -59 dBFS
  • Total Posts : 1622
  • Joined: 2010/08/30 17:40:34
  • Location: Mystic, CT
  • Status: offline
Re: x3 : Missing set of audio outs on Virus Ti VST3? 2013/10/13 22:02:07 (permalink)
I had raised a support ticket number at Access Music. the reference number is S100074897. My most recent contact was with Joerg Huttner
 
here is a screen shot of the Virus instantiated correctly as a VST2

 
 and here is a screen shot with the Virus instantiated as a VST3

 
As stated earlier, the VST3 version has been out for quite some time, and in Sonar alone, it appears that one set of stereo outs is missing (output 1) and also the sounds that are directed to outputs 1 are being played on the track indicated to be output 2, sounds directed to output 2 are being played on the indicated output 3 and of course sounds directed to output 3 are not played.
 
I have raised a bug report against x3 ref: CWBRN-20510
 
 

HPE-580T with i7-950, 8G, 1.5T, ATI6850, Win7/64, Motu 828 III Hybrid, Motu Midi Express, Sonar Platinum, Komplete 9, Ableton Live 9 & Push 2, Melodyne Editor and other stuff, KRK VXT8 Monitors
Virus Ti2 Polar, Fantom G6, Yamaha S70XS, Novation Nova, Novation Nova II, Korg MS2000, Waldorf Micro Q, NI Maschine Studio, TC-VoiceLive Rack, 2012 Gibson Les Paul Standard, 2001 Gibson Les Paul DC, 1999 Fender Am Hardtail Strat, Fender Blues Jr, Orange TH30/PPC212, Tak EF360GF, one mic, no talent.
#6
Noel Borthwick [Cakewalk]
Cakewalk Staff
  • Total Posts : 6475
  • Joined: 2003/11/03 17:22:50
  • Location: Boston, MA, USA
  • Status: offline
Re: x3 : Missing set of audio outs on Virus Ti VST3? 2013/10/16 18:09:01 (permalink)
Hi guys,
 
I believe I may have fixed this one. I don't have an Access virus handy to test this but I fixed an issue with the Steinberg's Halion Sonic Vst3 that looks very similar to this issue. The Insert synth operation would create fewer tracks and the ports were incorrectly set up. 
Take a look at the port choices for an input port on an audio track after inserting the synth. If you see the correct number of  ports but they are named out of sequence, it is definitely the same bug.
 
If they contact us I can send them a version with the fix to test. They can contact us via this form or email devsupport@cakewalk.com
 

Noel Borthwick
Senior Manager Audio Core, BandLab
My Blog, Twitter, BandLab Profile
#7
Mystic38
Max Output Level: -59 dBFS
  • Total Posts : 1622
  • Joined: 2010/08/30 17:40:34
  • Location: Mystic, CT
  • Status: offline
Re: x3 : Missing set of audio outs on Virus Ti VST3? 2013/10/17 07:53:07 (permalink)
Noel Borthwick [Cakewalk]
Hi guys,
 
I believe I may have fixed this one. I don't have an Access virus handy to test this but I fixed an issue with the Steinberg's Halion Sonic Vst3 that looks very similar to this issue. The Insert synth operation would create fewer tracks and the ports were incorrectly set up. 
Take a look at the port choices for an input port on an audio track after inserting the synth. If you see the correct number of  ports but they are named out of sequence, it is definitely the same bug.
 
If they contact us I can send them a version with the fix to test. They can contact us via this form or email devsupport@cakewalk.com
 



That's certainly looks the same to the Virus, I am on it!
 
 
post edited by Mystic38 - 2013/10/17 09:20:04

HPE-580T with i7-950, 8G, 1.5T, ATI6850, Win7/64, Motu 828 III Hybrid, Motu Midi Express, Sonar Platinum, Komplete 9, Ableton Live 9 & Push 2, Melodyne Editor and other stuff, KRK VXT8 Monitors
Virus Ti2 Polar, Fantom G6, Yamaha S70XS, Novation Nova, Novation Nova II, Korg MS2000, Waldorf Micro Q, NI Maschine Studio, TC-VoiceLive Rack, 2012 Gibson Les Paul Standard, 2001 Gibson Les Paul DC, 1999 Fender Am Hardtail Strat, Fender Blues Jr, Orange TH30/PPC212, Tak EF360GF, one mic, no talent.
#8
Mystic38
Max Output Level: -59 dBFS
  • Total Posts : 1622
  • Joined: 2010/08/30 17:40:34
  • Location: Mystic, CT
  • Status: offline
Re: x3 : Missing set of audio outs on Virus Ti VST3? 2013/10/31 13:14:06 (permalink) ☼ Best Answerby Mystic38 2013/10/31 13:14:12
Thanks,
 
I confirm that X3c resolves this issue, so CWBRN-20510 can be closed

HPE-580T with i7-950, 8G, 1.5T, ATI6850, Win7/64, Motu 828 III Hybrid, Motu Midi Express, Sonar Platinum, Komplete 9, Ableton Live 9 & Push 2, Melodyne Editor and other stuff, KRK VXT8 Monitors
Virus Ti2 Polar, Fantom G6, Yamaha S70XS, Novation Nova, Novation Nova II, Korg MS2000, Waldorf Micro Q, NI Maschine Studio, TC-VoiceLive Rack, 2012 Gibson Les Paul Standard, 2001 Gibson Les Paul DC, 1999 Fender Am Hardtail Strat, Fender Blues Jr, Orange TH30/PPC212, Tak EF360GF, one mic, no talent.
#9
Jump to:
© 2022 APG vNext Commercial Version 5.1