z3ta+ (first) issue [solved]

Author
vitalker
Max Output Level: -90 dBFS
  • Total Posts : 16
  • Joined: 2016/10/15 16:59:16
  • Status: offline
2018/10/07 20:54:09 (permalink)

z3ta+ (first) issue [solved]

Hello gals and guys!

Something is going wrong and z3ta+ (the first one) VSTi plugin can't be even initialized by Reaper (it looks like z3ta_.dll=007B74E91075C701 in reaper-vstplugins64.ini file) and Cakewalk. Reinstalling didn't help and I really don't know how to make it work again. Did anyone notice the same issue? By the way, I got the license key from a giveaway in 2016.
Standalone version (z3ta+.exe) also doesn't run.
 
What can be the reason?
post edited by vitalker - 2018/11/18 13:57:11
#1

27 Replies Related Threads

    Fog
    Max Output Level: 0 dBFS
    • Total Posts : 12302
    • Joined: 2008/02/27 21:53:35
    • Location: UK
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/08 00:55:00 (permalink)
    try installing it again. but when you run it, do "run as admin" with a right click, instead of a left click on the icon.
     
    also run ccleaner, registry tab.. see if you have any issues / fix them. rescan... fix
     
     
    #2
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/08 06:54:29 (permalink)
    Fog
    try installing it again. but when you run it, do "run as admin" with a right click, instead of a left click on the icon.
     
    also run ccleaner, registry tab.. see if you have any issues / fix them. rescan... fix

    I've already installed it again, run with admin, uninstalled with a special software and removed registry entries both automatically and manually. Nothing helped.
    Do you think VSTi can't run because of some broken entry in registry?
    post edited by vitalker - 2018/10/08 07:20:15
    #3
    scook
    Forum Host
    • Total Posts : 24055
    • Joined: 2005/07/27 13:43:57
    • Location: TX
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/08 11:22:47 (permalink)
    IDK, maybe an issue addressed in the last update http://www.cakewalk.com/Support/Knowledge-Base/20070320/Z3TA-1-5-3-Update
     
     
    #4
    azslow3
    Max Output Level: -42.5 dBFS
    • Total Posts : 3285
    • Joined: 2012/06/22 19:27:51
    • Location: Germany
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/08 11:54:20 (permalink)
    vitalker
    Standalone version (z3ta+.exe) also doesn't run.

    Do you get any errors, blank window or just absolute silence?
    Also please write Windows version you use, with build and locale. Think about the changes your system had between the time it worked fine and now (f.e. major update for Win10, locale change, home migration, File system format change, etc.)

    Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
    GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
    RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
    www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
    #5
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/08 16:52:51 (permalink)
    scook
    IDK, maybe an issue addressed in the last update

    Sorry, I don't get it. What is the issue?
    #6
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/08 16:58:14 (permalink)
    azslow3
    vitalker
    Standalone version (z3ta+.exe) also doesn't run.

    Do you get any errors, blank window or just absolute silence?
    Also please write Windows version you use, with build and locale. Think about the changes your system had between the time it worked fine and now (f.e. major update for Win10, locale change, home migration, File system format change, etc.)

    Absolute silence, no running process at all. I don't think there is something wrong with my system, cause it worked before. I use Win10 Pro 15063.850 build(1703), Russian locale. I completely disabled updates, so it can't be that for sure. Never changed locale. I've already written some other details for you on Cockos forum.
    Well, I've just installed some software, but the uninstalled it and got no success.
    #7
    azslow3
    Max Output Level: -42.5 dBFS
    • Total Posts : 3285
    • Joined: 2012/06/22 19:27:51
    • Location: Germany
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/08 18:36:19 (permalink)
    vitalker
    Absolute silence, no running process at all.

    Have you tried from the command like? I do not think it print something, but it is easy to try...
     
    We are close to hardcore debugging (special VST loader with diagnostic printout, process monitoring, etc...)... still hope we can avoid that

    Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
    GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
    RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
    www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
    #8
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/08 19:36:53 (permalink)
    azslow3
    Have you tried from the command like? I do not think it print something, but it is easy to try...
     
    We are close to hardcore debugging (special VST loader with diagnostic printout, process monitoring, etc...)... still hope we can avoid that


    Nothing happens. Yeah, we are hackers.
    #9
    azslow3
    Max Output Level: -42.5 dBFS
    • Total Posts : 3285
    • Joined: 2012/06/22 19:27:51
    • Location: Germany
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/09 13:02:30 (permalink)
    vitalker
    azslow3
    Have you tried from the command like? I do not think it print something, but it is easy to try...
     
    We are close to hardcore debugging (special VST loader with diagnostic printout, process monitoring, etc...)... still hope we can avoid that


    Nothing happens. Yeah, we are hackers.

    Well, I have traced it in hope to find some specific files  (DLLs) it tries to use. No joy.
     
    I have moved the whole resource folder, exe still starts producing meaningful errors.
     
    So, it seems like something on your system block it.
    a) which antivirus you use? have you tried to run with it disabled?
    b) get https://github.com/lucasg/Dependencies , open DLL in it and check for any anomalies. Make a screenshot of it.
     
     

    Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
    GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
    RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
    www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
    #10
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/09 14:05:05 (permalink)
    azslow3
    So, it seems like something on your system block it.
    a) which antivirus you use? have you tried to run with it disabled?
    b) get , open DLL in it and check for any anomalies. Make a screenshot of it.

    a) I use NOD32, which I've also used when it worked. Yes, I have already tried to disable it and run the program. By the way, I don't need to run exe, I want VSTi work for me, nothing more.
    b) I'm not sure, how an anomaly could look like, but in almost any bible there are purple blocks in PI column.

    #11
    azslow3
    Max Output Level: -42.5 dBFS
    • Total Posts : 3285
    • Joined: 2012/06/22 19:27:51
    • Location: Germany
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/09 14:56:43 (permalink)
    Well, looks good.
    Can you try "regsvr32 z3ta+.dll" in the console (I thing admin rights required)?
    You can then do "regsvr32 /u z3ta+.dll". Interesting what the first command will print...

    Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
    GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
    RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
    www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
    #12
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/09 15:04:49 (permalink)
    azslow3
    Well, looks good.
    Can you try "regsvr32 z3ta+.dll" in the console (I thing admin rights required)?
    You can then do "regsvr32 /u z3ta+.dll". Interesting what the first command will print...

    Successful execution as I thought. There is something with my system, but I don't know, what exactly.
    #13
    azslow3
    Max Output Level: -42.5 dBFS
    • Total Posts : 3285
    • Joined: 2012/06/22 19:27:51
    • Location: Germany
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/09 18:27:16 (permalink)
    Hm... time to write a VST Host emulator with diagnostic, give me 1-2 days

    Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
    GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
    RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
    www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
    #14
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/09 18:40:54 (permalink)
    azslow3
    Hm... time to write a VST Host emulator with diagnostic, give me 1-2 days

    Don't waste your time please! It won't help, because there is something with my system obviously, but I don't know what.


    #15
    azslow3
    Max Output Level: -42.5 dBFS
    • Total Posts : 3285
    • Joined: 2012/06/22 19:27:51
    • Location: Germany
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/11 11:35:47 (permalink)
    Ok... download this program: http://www.azslow.com/index.php?action=downloads;sa=view;down=65
    Run it from console (cmd), File/Open and select z3ta+.dll. What can you see in the console then?
     

    Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
    GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
    RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
    www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
    #16
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/11 16:32:27 (permalink)
    azslow3
    Ok... download this program: http://www.azslow.com/index.php?action=downloads;sa=view;down=65
    Run it from console (cmd), File/Open and select z3ta+.dll. What can you see in the console then?

    07:212-VSTTEST.            VST_Load: Loading DLL...
    07:216-VSTTEST.            VST_Load: DLL 'D:\Programs\Reaper\VST\z3ta+\z3ta+.dll' is loaded
    07:217-VSTTEST.            VST_Load: It looks like a VST
    07:218-VSTTEST.            VST_Load: Attempt to create effect instance...
    07:276-VSTTEST.            VST_Load: Fail to create an instance


    #17
    azslow3
    Max Output Level: -42.5 dBFS
    • Total Posts : 3285
    • Joined: 2012/06/22 19:27:51
    • Location: Germany
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/12 10:11:38 (permalink)
    Are you sure there is nothing between last 2 lines?
    There should be at least "Asked for our version" line, it is a part of Steinberg VST framework before any user code supposed to start.
     
    It seems like Cakewalk has hacked some protection routine there. It is calling "Microsoft Enhanced Cryptographic Provider" stack. Under normal conditions, VST should proceed then. But in your case that operation fails and VST exits.
     
    By digging deeper I will violate Cakewalk license. So, assuming you are running legal copy of z3ta+ on legal copy of Win 10, lets stay away from the gray area
     
    Try to remember: have you run any "Windows optimizer"/"registry leaner" or manually disabled some service? Most probably corresponding windows part is not working correctly.
    In any case, I recommend to plan Windows upgrade to more recent major version. That overwrites complete system stack, so it will restore whatever could be broken.
     

    Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
    GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
    RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
    www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
    #18
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/13 09:42:20 (permalink)
    azslow3
    Are you sure there is nothing between last 2 lines?
    There should be at least "Asked for our version" line, it is a part of Steinberg VST framework before any user code supposed to start.
     
    Try to remember: have you run any "Windows optimizer"/"registry leaner" or manually disabled some service? Most probably corresponding windows part is not working correctly.
    In any case, I recommend to plan Windows upgrade to more recent major version. That overwrites complete system stack, so it will restore whatever could be broken.

    I am sure. I did it again and made a screenshot.

    I don't think there is something wrong with license, cause Reaper can't even initialize it.
     
    Not at all! I don't use this kind of software. Have I disabled some service? Probably, but it was already disabled, while plugin worked.
    I've heard there are some issues with new Windows 10 build.
    Anyway thank you for your kind help!
     
    post edited by vitalker - 2018/10/13 11:33:22
    #19
    azslow3
    Max Output Level: -42.5 dBFS
    • Total Posts : 3285
    • Joined: 2012/06/22 19:27:51
    • Location: Germany
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/15 16:25:02 (permalink)
    vitalker
    I don't think there is something wrong with license, cause Reaper can't even initialize it.

    The plug-in think there is something wrong with license... and exit immediately
    The only question is why it think so. As I have mentioned, it tries to use MS API for that. Probably the plug-in fails to initialize the API.
     
    The API could be disturbed by many different things, including unsuccessful MS updates, bugs in particular version, etc. 

    Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
    GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
    RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
    www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
    #20
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/15 19:12:06 (permalink)
    azslow3
    The API could be disturbed by many different things, including unsuccessful MS updates, bugs in particular version, etc.

    So why it worked before?
    #21
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/17 17:29:24 (permalink)
    Ok, I have updated system, but z3ta won't work...
    #22
    azslow3
    Max Output Level: -42.5 dBFS
    • Total Posts : 3285
    • Joined: 2012/06/22 19:27:51
    • Location: Germany
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/18 21:19:33 (permalink)
    vitalker
    Ok, I have updated system, but z3ta won't work...

    Hmm... was it "big update", with completely rewritten Windows folder?
    If yes, the only thing I can do is write a test for the API in question.

    Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
    GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
    RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
    www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
    #23
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/10/20 09:59:03 (permalink)
    azslow3
    vitalker
    Ok, I have updated system, but z3ta won't work...

    Hmm... was it "big update", with completely rewritten Windows folder?
    If yes, the only thing I can do is write a test for the API in question.

    I don't know. The last one is not October 2018 Update, but Windows update doesn't see any new updates for my system, so let's assume it was a big one (April 2018, for example, because I didn't update my system since it was released).
    Sorry, could you please explain what are you trying to do? The dll file is not broken. There must be something with my system.
    #24
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/11/17 13:14:03 (permalink)
    azslow3
    Hmm... was it "big update", with completely rewritten Windows folder?
    If yes, the only thing I can do is write a test for the API in question.

    I've just updated to the latest version (1809, October update). Still nothing.
    #25
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/11/18 13:56:48 (permalink)
    Ok, now I know there is a problem with my user on Windows 10, because after I created another one, z3ta+ worked there. :)
    #26
    azslow3
    Max Output Level: -42.5 dBFS
    • Total Posts : 3285
    • Joined: 2012/06/22 19:27:51
    • Location: Germany
    • Status: offline
    Re: z3ta+ (first) issue 2018/11/18 19:00:35 (permalink)
    I am glad you have finally found the reason
    So, that API can malfunction because of user specific settings... good to know. I had already observed user specific issues with network authentications. But for local thing that is the first time.

    Sonar 8LE -> Platinum infinity, REAPER, Windows 10 pro
    GA-EP35-DS3L, E7500, 4GB, GTX 1050 Ti, 2x500GB
    RME Babyface Pro (M-Audio Audiophile Firewire/410, VS-20), Kawai CN43, TD-11, Roland A500S, Akai MPK Mini, Keystation Pro, etc.
    www.azslow.com - Control Surface Integration Platform for SONAR, ReaCWP, AOSC and other accessibility tools
    #27
    vitalker
    Max Output Level: -90 dBFS
    • Total Posts : 16
    • Joined: 2016/10/15 16:59:16
    • Status: offline
    Re: z3ta+ (first) issue 2018/11/18 19:37:39 (permalink)
    azslow3
    I am glad you have finally found the reason
    So, that API can malfunction because of user specific settings... good to know. I had already observed user specific issues with network authentications. But for local thing that is the first time.

    Me too. The user on Windows 10 was in some way corrupted. And now I finally solved the issue with copying my whole user files and settings. I've used Transwiz. Perfect!!!
    If you want to know, how I started my investigation:
    1. Firstly I've downloaded Dependency walker (the original version of program, the link on fork of which you gave me before).
    2. Then I copied one of the dll library names, which was broken.
    3. This followed me on Microsoft support site, where I found 2 solutions: sfc scan via command line and new user.
    4. The first solution didn't give me any effective results.
    5. The second one was what I need!
    6. The next problem was how to copy all the settings.
    7. After that I found Transwiz and now I feel like Sherlock Holmes!
    post edited by vitalker - 2018/11/18 23:07:08
    #28
    Jump to:
    © 2018 APG vNext Commercial Version 5.1