Still Need Help Please with clean install of DimPro & Expansion Paks

Author
Musikman
Max Output Level: -86 dBFS
  • Total Posts : 220
  • Joined: 2008/08/26 11:21:27
  • Location: NorthEast, USA
  • Status: offline
2017/04/09 21:38:06 (permalink)

Still Need Help Please with clean install of DimPro & Expansion Paks

I just installed Platinum and my CW Intstruments, including DimPro and Rapture 1.2.2, but I noticed one or two of the Expansion Paks I had back when I was using Producer 8.5.3 were missing. Dimension Pro Expansion Paks 1 & 2, Dimension Pro Hollywood FX Expansion Pak, and also one for Rapture called Rapture XP Setup.  I do remember downloading them separate from the rest, but now they are missing from both My Products Page and the Cakewalk Command Center list.
 
My old Exp Pak installation files were not on a disc, after some searching on an external HDD I did find them, but according to this thread I found, there have been issues installing them into Platinum. .... http://forum.cakewalk.com/m/tm.aspx?m=3184798
 
Looks like one person tried and found a work-around by altering the registry, but I just upgraded my PC and have got it running smoothly, so I'm not one to go messing around with my registry file. I was hoping someone here might have found a different solution. I did send in a Support ticket a few days ago, in the hopes that the CW support team would come up with a patch file so that those three DimPro and the Rapture add-ons would install correctly. Just checking here in case anyone maybe has had the same issue.
 
I'm going to hold off for now until I get some answers on how to get these installed properly. I used the special FX a lot in the music I write, so I'd really like to get those expansion paks back into Platinum. Thanks very much.
 
MM
post edited by Musikman - 2017/04/12 22:13:41

Sonar Platinum, Win10 Pro 64bit, AMD FX 6300 6 Core, 8GB RAM, AMD Radeon R9-380
#1

5 Replies Related Threads

    Fog
    Max Output Level: 0 dBFS
    • Total Posts : 12302
    • Joined: 2008/02/27 21:53:35
    • Location: UK
    • Status: offline
    Re: Need Answers for DimPro Expansion Paks Installation... 2017/04/10 02:43:36 (permalink)
    with regard to sound packs, I remember buying an sonar update and getting a strings pack a Digital sound factory one, as a bonus.. think it was, maybe that rings a bell ? I looked in my downloads and it isn't there, I think I did back it up to a dvd (as the proteus packs also)
     
    I have rapture as a stand-alone.. I notice it wasn't there *BUT* was in one of the various sonar's I have registered in the file list. Also some expansion packs are within the major sonar file list.
     
    with regard to the location of the programs / multi samples.. not sure if you use later installers that it is looking for the default location.. the older ones it was a case of unzipping them.
     
    when I'd do the install , I'd install as per usual... then change locations , then shift the files to the other drive.
     
    I'd ask cakewalk themselves about the files. this might be of use regarding the time the offer was..
     
    http://forum.cakewalk.com/Is-the-DSF-Symphonic-Strings-HD-Expansion-For-Dimension-Free-for-all-who-get-Sonar-X2-m2653039-p3.aspx
     
     
    #2
    TheMaartian
    Max Output Level: -47.5 dBFS
    • Total Posts : 2774
    • Joined: 2015/05/21 18:30:52
    • Location: Flagstaff, AZ
    • Status: offline
    Re: Need Answers for DimPro Expansion Paks Installation... 2017/04/10 14:24:25 (permalink)
    Not sure about the others, but the old DimPro expansion packs 1-3 (including the Virtual B3) can be downloaded at:
     
    https://www.cakewalk.com/Support/Knowledge-Base/2007013208/Free-Dimension-Pro-Expansion-Packs-1-3
     


    Intel i7 3.4GHz, 16 GB RAM, 2 TB HD Win10 Home 64-bit Tascam US-16x08
    Studio One 4 Pro NotionMelodyne 4 Studio Acoustica 7 Guitar Pro 7
    PreSonus FaderPort Nektar P6 M-Audio BX8 D2 Beyerdynamic DT 880 Pro
    NI K9U XLN AK, AD2 AAS VS-2, GS-2, VA-2, EP-4, CP-2, OD Toontrack SD3, EZK
    #3
    Musikman
    Max Output Level: -86 dBFS
    • Total Posts : 220
    • Joined: 2008/08/26 11:21:27
    • Location: NorthEast, USA
    • Status: offline
    Re: Need Answers for DimPro Expansion Paks Installation... 2017/04/10 20:20:25 (permalink)
    Thanks for the links guys, I had actually forgotten about that Virtual B-3.  After reading only half of my email, support did add two of the DimPro XP paks to my Command Center, but probably ignored what I had mentioned about the files not installing properly into Platinum. When I ran CC and it downloaded and installed them, they never showed up in DimPro, even after I refreshed the preset window in DimPro using F5.  This is exactly what the other Platinum users in the thread I posted above had said as well. So other than trying the registry editing that another user posted, I have no other answer on how to fix this yet. I'm not even sure where Command Center loaded all the files to when it installed the DimPro XP paks.
     
    Further to that, I also had a Rapture XP pak that I'd like to install again. I re-addressed my original concern with support today, hopefully someone will have a fix for this someday. I think I'm going to have to try installing from the old files, but first I'd like to find the ones that CC installed to see where they went and either delete them or fix the issue, so that there aren't any corrupted files from multiple installations of the same thing.
     


    Sonar Platinum, Win10 Pro 64bit, AMD FX 6300 6 Core, 8GB RAM, AMD Radeon R9-380
    #4
    Musikman
    Max Output Level: -86 dBFS
    • Total Posts : 220
    • Joined: 2008/08/26 11:21:27
    • Location: NorthEast, USA
    • Status: offline
    Re: Need Answers for DimPro Expansion Paks Installation... 2017/04/12 02:49:54 (permalink)
    Now it seems my DimPro sounds are all messed up!  This is aggravating to say the least, and support is taking several days to get back to me. When I load a piano preset it sounds more like a strings or harmonium sound instead of like a piano. Similar problems with other presets not sounding as they should. Does anyone know the best way to uninstall only Dimension Pro?....or should I uninstall Platinum altogether?? I think I'm gonna have to uninstall one or the other, and try reinstalling it to see if that fixes the problem. Suggestions? Thanks!
    ***UPDATE: After further checking it looks like Rapture sounds, and also Rapture Session sounds are messed up the same way too, pianos sounding like strings, and other sounds not the way they're supposed to sound.  Looks like something got corrupted here, I'm thinking maybe I have to uninstall DimPro, Rapture, and Rapture Session, or uninstall and re-intstall Platinum altogether, which I'd rather not have to do. Don't know if this is anything, but there was also a Win10 update that installed a Windows security update, and an Adobe Flash Player update, maybe I should uninstall those updates?  Any help appreciated. Thank you.

    ***UPDATE 2: I tried using Command Center to "re-install" DimPro, the
    only option that CC gives me is "re-install", there's no option to "uninstall"
    the current version, so I tried the Command Center re-install and it seemed to
    install DimPro, but then CC just kept hanging, saying it was still installing
    DimPro but almost an hour had passed, so I had to manually close CC. When I
    opened Platinum, DimPro was installed, but I was having the same problem as
    before with the sounds not being correct. Is there a way to do a clean install
    for the virtual instruments? Maybe I need to "uninstall" DimPro and Rapture, and
    Rapture Session before trying to re-install them, but not sure how to do it, can
    anyone advise.
     
    post edited by Musikman - 2017/04/12 22:10:17

    Sonar Platinum, Win10 Pro 64bit, AMD FX 6300 6 Core, 8GB RAM, AMD Radeon R9-380
    #5
    Musikman
    Max Output Level: -86 dBFS
    • Total Posts : 220
    • Joined: 2008/08/26 11:21:27
    • Location: NorthEast, USA
    • Status: offline
    Re: Need Answers for DimPro Expansion Paks Installation... 2017/04/12 22:21:16 (permalink)
    I have not heard from support yet, so I have proceeded to uninstall DimPro, Rapture, and Rapture Session. It seems Rapture and Rapture Session uninstalled ok, but after running the DimPro Uninstaller program, it gave me the message that is was finished uninstalling, however, when I looked in the folder Pgm Files/Cakewalk/, there was the Dimension Pro Folder and all the Multisamples were all still there, Including the Multisamples for the two Expansion Paks. In Platinum there was no longer DimPro showing on the list of Synths, so I just went ahead and manually deleted the Dimension Pro folder and all the Multisamples. I did a search for any leftover files that I could find and I think I got them all, but not 100% sure.
     
    I re-booted my PC, then went into Command Center. On my products list, Rapture and Rapture Pro had a red button, indicating they were not installed, however, D-Pro and its two Expansion Paks had a green button next to them, as if CC was detecting D-Pro and the Exp Paks were still installed, and the only option CC was showing was "Re-Install". I right clicked on D-Pro in the products list and chose "delete files", but that didn't seem to change anything. If you have read my previous posts, I mentioned that when I tried the re-install of D-Pro from Command Center, it got stuck hanging, saying it was still installing when in fact it was already done, this went on for an hour and I finally manually stopped and closed Command Center.
     
    It seems I may be able to re-install Rapture and Rapture Session, but I'm going to wait for instructions from support or answers here before trying to re-install Dimension Pro and the Exp Paks. It seems CC is somehow detecting D-Pro is still installed, when in fact it has been uninstalled. I think I need to somehow get the status buttons next to D-Pro and the two Exp Paks to change from green to red in Command Center before it can install D-Pro correctly. I also did a clean re-install of Command Center just in case.  Any help or advice would be appreciated. Until then I'm going to hold off on installing anything. Thanks guys, hope someone out there has some insight on this. 
    post edited by Musikman - 2017/04/13 02:50:26

    Sonar Platinum, Win10 Pro 64bit, AMD FX 6300 6 Core, 8GB RAM, AMD Radeon R9-380
    #6
    Jump to:
    © 2020 APG vNext Commercial Version 5.1