Helpful ReplyX2a Track view fader issue

Page: 12 > Showing page 1 of 2
Author
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
2012/12/27 12:39:02 (permalink)

X2a Track view fader issue

Can't use X2a. In track view the fader is like in a "jammed" state. While I am trying to move it, it doesn't move. Then when I release the mouse click, it shoots up to +18db.  I can move the fader just fine in the inspector pane. 

Sonar seems less snappy now too overall compared to without this recent update patch. 


i7 920, 16G Ram Win 7 64 Sonar 64
#1
Haddox
Max Output Level: -84 dBFS
  • Total Posts : 321
  • Joined: 2007/12/31 17:23:10
  • Status: offline
Re:X2a Track view fader issue 2012/12/27 12:57:59 (permalink)
me too!  about the track view faders.  I thought it was project dependent at first because opening a different project had everything working as normal.
 
So I was about to post about a potential issue with importing a project thinking, that might be the problem but, I'm not so sure now. 
 
I noticed the faders in console view work as advertised.  I can't imagine a parameter or preference setting that would cause this effect.

It's just gettin' better an better

Some of my 2nz 
www.haddoxthomas.com
 

#2
Haddox
Max Output Level: -84 dBFS
  • Total Posts : 321
  • Joined: 2007/12/31 17:23:10
  • Status: offline
Re:X2a Track view fader issue 2012/12/27 13:16:58 (permalink)
I also just noticed that once the little white brackets are around the parameter, the mouse wheel will adjust it.  So it's, gotta be a setting involving the mouse or a bug involving touch screens.

It's just gettin' better an better

Some of my 2nz 
www.haddoxthomas.com
 

#3
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
Re:X2a Track view fader issue 2012/12/27 13:43:09 (permalink)
Thanks for confirming that Haddox
#4
scook
Max Output Level: 0 dBFS
  • Total Posts : 9786
  • Joined: 2005/07/27 13:43:57
  • Location: TX
  • Status: offline
Re:X2a Track view fader issue 2012/12/27 13:48:29 (permalink)
Sounds like offset mode, keyboard shortcut is the letter O. If the volume and pan in the track view have plus signs next to them, you are in offset mode.
#5
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
Re:X2a Track view fader issue 2012/12/27 14:05:45 (permalink)
No, it's not off-set mode. There is no reason I would be in off-set mode, I never set it to that. 
#6
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 13:39:53 (permalink)
So, what do we do in the meantime, twiddle our thumbs? 
#7
bvideo
Max Output Level: -66 dBFS
  • Total Posts : 1239
  • Joined: 2006/09/02 22:20:02
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 13:43:30 (permalink)
Perhaps there is a volume envelope on the track. If so, delete it or work with it (add nodes or turn on the [W]).
#8
StepD
Max Output Level: -80 dBFS
  • Total Posts : 546
  • Joined: 2003/11/08 01:03:52
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 13:46:56 (permalink)
TM, maybe you and Haddox can compare setups (including mouse type, any control surfaces, etc.) and what's on your tracks. If it's happening to both of you, I would think there's got to be something in common.

Core2 6600 2.40 GHz
ASUS P5B Deluxe
8GB RAM
GeForce GT 630 2GB
3 Seagate Sata
Echo AudioFire 4 asio
Windows 8.1 64-bit
#9
scook
Max Output Level: 0 dBFS
  • Total Posts : 9786
  • Joined: 2005/07/27 13:43:57
  • Location: TX
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 14:13:36 (permalink)
You could call tech support
#10
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 14:37:56 (permalink)
Here are all the details: I had X2 working "fine" - by that, I mean with the known bugs that were pending the X2a fix - with certainly no
fundamental issue like this mouse issue. I downloaded the update, ran it, and discovered this issue suddenly. No new hardware OR software other than the Sonar X2a has been added. Further, I checked it on a brand new project i.e. with no tracks, no plugins, in a word: clean. The issue persists. My system, as you can see is not old and considering all pretenses here, it must be a compatibility that CW did not thoroughly check over testing X2a. 

And just to be thorough, my system:

Gigabyte EX58-UD4P Intel X58. 
12Gb of Kingston HyperX DDR3/1600 Mhz Triple Ch. RAM. 
Intel i7 920 2.66GHz LGA1366 
Win 7 64 SP1 with the latest BIOS
Sonar 64 
Standard PS2 mouse/keyboard


#11
StepD
Max Output Level: -80 dBFS
  • Total Posts : 546
  • Joined: 2003/11/08 01:03:52
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 14:53:20 (permalink)
But what's the brand, model and driver version of your mouse? Maybe not related but you never know.

Core2 6600 2.40 GHz
ASUS P5B Deluxe
8GB RAM
GeForce GT 630 2GB
3 Seagate Sata
Echo AudioFire 4 asio
Windows 8.1 64-bit
#12
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 15:30:00 (permalink)
It is a Microsoft Intellimouse Opitcal PS2
#13
StepD
Max Output Level: -80 dBFS
  • Total Posts : 546
  • Joined: 2003/11/08 01:03:52
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 15:55:20 (permalink)
I thought I had an Intellimouse laying around somewhere, but I guess not. At least now someone else that has one can tell you it's working fine for them and you can eliminate that as the source. Did you try hooking it up to a PS2 port if you have one instead of USB?

Core2 6600 2.40 GHz
ASUS P5B Deluxe
8GB RAM
GeForce GT 630 2GB
3 Seagate Sata
Echo AudioFire 4 asio
Windows 8.1 64-bit
#14
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 16:42:09 (permalink)
StepD


I thought I had an Intellimouse laying around somewhere, but I guess not. At least now someone else that has one can tell you it's working fine for them and you can eliminate that as the source. Did you try hooking it up to a PS2 port if you have one instead of USB?



You mean the other way around, it is PS2 right now. I just tested a USB mouse and same story. 
#15
StepD
Max Output Level: -80 dBFS
  • Total Posts : 546
  • Joined: 2003/11/08 01:03:52
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 17:01:28 (permalink)
Yeah, definitely weird. I should probably just shut up anyway since I'm running Win8 and it might be some kind of Win7 problem.

Core2 6600 2.40 GHz
ASUS P5B Deluxe
8GB RAM
GeForce GT 630 2GB
3 Seagate Sata
Echo AudioFire 4 asio
Windows 8.1 64-bit
#16
Haddox
Max Output Level: -84 dBFS
  • Total Posts : 321
  • Joined: 2007/12/31 17:23:10
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 19:17:38 (permalink)
I ruled out the mouse as the problem as it works fine in all other apps and functions well in the prochannel pane.  I do have some trouble changing the ratio on the u-type compressor.

I don't believe that it's a setting because if it was, the setting would be pointless imho.

It isnt anything to do with envelopes as the mouse wheel moves these faders at .5 intervals without issue.

The mouse also works fine on the console view.  Adjusting the volume with the console is the obvious work around.  Using the mouse wheel will do as well.  

When I opened another project I had full functionality over these panes.  As I did before the x2a upgrade.  I haven't tested the "saving it in X2a brings on the issue" yet but, will.  It might help CW in the bug hunt.  I am pretty confident that it has to do with the code in these track panes that doesnt translate to Windows 7.  Or at least, the version I'm using.  We need a few more users to share the problem to figure it out.  I use the faders a lot and hope that the issue isnt ignored based on the few users with the issue.

It's just gettin' better an better

Some of my 2nz 
www.haddoxthomas.com
 

#17
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 20:01:47 (permalink)
Yes, the wheel does work on the track fader, that I noticed too. I am just surprised more users haven't chimed in on this. 
#18
Keysman
Max Output Level: -89 dBFS
  • Total Posts : 79
  • Joined: 2008/01/15 16:41:00
  • Location: Hollywood, Ca.
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 22:02:33 (permalink)
Was all set to install X2 in place of X1 until I keep reading more stuff like this. How much more do we pay for the STABLE version? lol!
#19
StepD
Max Output Level: -80 dBFS
  • Total Posts : 546
  • Joined: 2003/11/08 01:03:52
  • Status: offline
Re:X2a Track view fader issue 2012/12/28 22:21:08 (permalink)
Keysman, don't install X2 in place of X1, install it alongside X1 until you know everything's working fine. It's running great here. Unfortunately, weird things pop up in software for some users. And that goes for all software. Just read "The Version 2.5 bugs thread" on the Studio One forum if you don't believe me.

Core2 6600 2.40 GHz
ASUS P5B Deluxe
8GB RAM
GeForce GT 630 2GB
3 Seagate Sata
Echo AudioFire 4 asio
Windows 8.1 64-bit
#20
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
Re:X2a Track view fader issue 2012/12/30 13:57:48 (permalink)
I reported this. Ugh, down time.
#21
rabeach
Max Output Level: -51 dBFS
  • Total Posts : 2412
  • Joined: 2004/01/26 14:56:13
  • Status: offline
Re:X2a Track view fader issue 2012/12/30 16:47:23 (permalink)
tracks
Transcending Music


Yes, the wheel does work on the track fader, that I noticed too. I am just surprised more users haven't chimed in on this. 

fader in track pane works as expected, running win 7 64 bit
#22
Paul P
Max Output Level: -69 dBFS
  • Total Posts : 1067
  • Joined: 2012/12/08 17:15:47
  • Location: Montreal
  • Status: online
Re:X2a Track view fader issue 2012/12/30 21:39:50 (permalink)
Works ok in my X2a as well.

However, X2 and X2a have screwed up my mouse, I mean really screwed it up, on two occasions now.  Once I could no longer use the mouse at all, after it started being erratic.  The second time when it started acting up I exited X2a and the mouse was back to normal when I reentered the program.

I've never had a program mess with the mouse.

#23
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
Re:X2a Track view fader issue 2012/12/31 09:22:18 (permalink)
There must be something going on here related to touchscreen and mouse functionality. 
#24
Haddox
Max Output Level: -84 dBFS
  • Total Posts : 321
  • Joined: 2007/12/31 17:23:10
  • Status: offline
Re:X2a Track view fader issue 2013/01/02 14:05:52 (permalink)
Ok.  I reported it too.  And I asked for a patch that fixes the x2 bugs without the Windows 8 stuff.
I'm finding some mousing issues in other panes but, not consistent. Reboots seem to clear up some and create others.
#25
Transcending Music
Max Output Level: -86 dBFS
  • Total Posts : 241
  • Joined: 2006/05/20 12:15:19
  • Location: NY
  • Status: offline
Re:X2a Track view fader issue 2013/01/02 17:18:36 (permalink)
Cool, thanks for reporting Haddox
#26
ptheisen
Max Output Level: -89 dBFS
  • Total Posts : 85
  • Joined: 2008/12/15 21:55:03
  • Status: offline
Re:X2a Track view fader issue 2013/01/03 15:31:21 (permalink)
I think it is worth pointing out that almost all issues with computers, in fact life, too, are due to a combination of factors, not a single factor.

I do not have a problem with the mouse dragging the track view fader, just like several others who have indicated the same. I am also running X2a on Win 7 64bit.

So it is not logical to blame the issue on X2a all by itself. There must be one or more as yet unidentified factors that are combining with X2a on your system to cause the issue. If you can work with the others having the same issue to discover more common denominators, you might be able to give Cakewalk information that would help them diagnose the issue more quickly.

As it stands now, they don't have much to go on, since for some users, perhaps the majority, there is no such issue with X2a on Win 7 64 bit.
#27
Haddox
Max Output Level: -84 dBFS
  • Total Posts : 321
  • Joined: 2007/12/31 17:23:10
  • Status: offline
Re:X2a Track view fader issue 2013/01/03 17:12:24 (permalink) ☄ Helpful
Indeed.  I am very much aware of the multiple, potential factors involved.  I could, perhaps, appease you by correctly stating that the combination of my system and x2 did not have this issue yet, the combination of my system and x2a does.  I am also aware that not only is the information going to cakewalk thin, at best, but, given the response from them so far will not be helpful in solving the issue.  With every one else's system working well, there will be two of using the work arounds.  

Thanks for the input.  I think it's helpful to keep this thread on the top list.

It's just gettin' better an better

Some of my 2nz 
www.haddoxthomas.com
 

#28
Haddox
Max Output Level: -84 dBFS
  • Total Posts : 321
  • Joined: 2007/12/31 17:23:10
  • Status: offline
Re:X2a Track view fader issue 2013/01/03 17:28:24 (permalink)
As I sit in continuous contemplation over this matter, it seems like a straight forward trouble shooting flow chart would solve the issue rather quickly.

Is the pointer code in track panes the same as it is in console view?

If not,  what's different?

The idea that this isn't an issue for everyone doesn't positively relieve cakewalk of a code problem.  The track pane code for x2a is different than it was before and it is different than the other screens.  

I will buy a new mouse later today.  Keep the reciept.  I will also cycle through usb ports and perhaps reload the mouse drivers.

I will also try anything anyone here suggest.

Anyone?

It's just gettin' better an better

Some of my 2nz 
www.haddoxthomas.com
 

#29
Haddox
Max Output Level: -84 dBFS
  • Total Posts : 321
  • Joined: 2007/12/31 17:23:10
  • Status: offline
Re:X2a Track view fader issue 2013/01/03 17:30:37 (permalink)
As I sit in continuous contemplation over this matter, it seems like a straight forward trouble shooting flow chart would solve the issue rather quickly.

Is the pointer code in track panes the same as it is in console view?

If not,  what's different?

The idea that this isn't an issue for everyone doesn't positively relieve cakewalk of a code problem.  The track pane code for x2a is different than it was before and it is different than the other screens.  

I will buy a new mouse later today.  Keep the reciept.  I will also cycle through usb ports and perhaps reload the mouse drivers.

I will also try anything anyone here suggest.

Anyone?

It's just gettin' better an better

Some of my 2nz 
www.haddoxthomas.com
 

#30
Page: 12 > Showing page 1 of 2
Jump to:
© 2014 APG vNext Commercial Version 5.1