Helpful ReplyResponse to issues with Rapture Pro

Page: 1234 > Showing page 1 of 4
Author
Josh Langberg [Cakewalk]
Max Output Level: -88 dBFS
  • Total Posts : 136
  • Joined: 2011/04/13 11:07:07
  • Location: Boston
  • Status: offline
2015/05/04 12:23:53 (permalink)

Response to issues with Rapture Pro

Hello,
Thanks to everyone who purchased Rapture Pro. We appreciate your business. We have been actively reading the forums, logging and investigating the issues.
This past Friday, we issued a quick update to address a serious bug when installing Rapture Pro on OS X in a custom directory and are planning to post one or more maintenance release in the next couple of weeks to addresses many of these issues including content, Command Center, and OS X installation.  
Thanks again for your patience as we quickly work to resolve these issues.

-Josh Langberg
PM/QA Lead Engineer, DSP Team
Cakewalk, Boston

#1
mcl
Max Output Level: -89 dBFS
  • Total Posts : 95
  • Joined: 2007/05/31 05:37:15
  • Location: UAE
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/04 14:30:08 (permalink)
Good to know - thanks Josh.

Mike CL
#2
Vilovilo
Max Output Level: -84 dBFS
  • Total Posts : 335
  • Joined: 2014/05/13 17:15:24
  • Location: France
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/04 16:30:13 (permalink)
Ok, Nice
Waiting for an update,as far as more or less,all the issues I've read in the forums occured in my set-up.
I would also like to mention that I have a bad connexion and downloading 1 giga here is 6 hours so if there is a way to make things work and avoid to have to download once again all the D pro stuff and else,it would be really valuable.
Thanks for your great job and implication in the music software and all.
All the best.
Olivier.
post edited by Vilovilo - 2015/05/04 16:54:41
#3
azikiwezig
Max Output Level: -90 dBFS
  • Total Posts : 4
  • Joined: 2015/04/28 21:33:33
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/05 05:45:31 (permalink)
offline activate for OS X please 
#4
azikiwezig
Max Output Level: -90 dBFS
  • Total Posts : 4
  • Joined: 2015/04/28 21:33:33
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/05 05:46:24 (permalink)
this plugin won't activate in OS X yosimete at all areas sad
 
 
#5
azikiwezig
Max Output Level: -90 dBFS
  • Total Posts : 4
  • Joined: 2015/04/28 21:33:33
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/05 05:48:59 (permalink)
super great plugin for all your dimensions pro and le and digital sound factory expansions but won't activate on osx
please fix cakewalk need my mo phat dropoffsine bass to work
 
 
#6
azikiwezig
Max Output Level: -90 dBFS
  • Total Posts : 4
  • Joined: 2015/04/28 21:33:33
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/05 05:51:59 (permalink)
won't activate on OS X tried every daw from logic 9, logic x, studio one 2.6 machine 2.2.4 command centre may be the issue cakewalk help us in OS X 
and make sonar for OS X and the mv 8800 a daw/drum sampler before akai mpc en and machine 
thanks
 
#7
Dan Gonzalez [Cakewalk]
Administrator
  • Total Posts : 395
  • Joined: 2013/01/14 12:28:40
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/05 11:38:59 (permalink)
azikiwezig
won't activate on OS X tried every daw from logic 9, logic x, studio one 2.6 machine 2.2.4 command centre may be the issue cakewalk help us in OS X 
and make sonar for OS X and the mv 8800 a daw/drum sampler before akai mpc en and machine 
thanks
 




Seems like it install and activated for me. I'm running 10.10.2 and it hasn't kicked back a demo mode or registration error. Did you do the following to install it?
1) Download Cakewalk Command Center from our site
2) Install Cakewalk Command Center 
3) Yosemite asks you for your computer's password to install
4) Login to CCC
5) Click "Install" or "Install All" 
6) Open DAW, insert Rapture Pro
#8
ascardoso
Max Output Level: -90 dBFS
  • Total Posts : 5
  • Joined: 2015/04/22 14:10:29
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/05 15:56:53 (permalink)
I haven't tried running CCC in 10.10.2 but I doubt this is working as you suggest. For one thing, you guys are using a browser framework that has references to MS packages. You won't find those in the Python that ships with OS X.
 
Nice try.
 
Sergio
#9
fatbenjamin
Max Output Level: -90 dBFS
  • Total Posts : 2
  • Joined: 2015/05/02 17:27:51
  • Location: UK
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/05 18:34:51 (permalink)
CC does not show that all of my sound packs have been installed even though they have.  Seems a bit buggy!  Loving Rapture though!
post edited by fatbenjamin - 2015/05/05 18:48:05



 
#10
promidi
Max Output Level: -66 dBFS
  • Total Posts : 1220
  • Joined: 2014/11/21 18:46:39
  • Location: South Australia
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/05 20:58:10 (permalink)
fatbenjamin
CC does not show that all of my sound packs have been installed even though they have.  Seems a bit buggy!  Loving Rapture though!


Were these sound packs installed via CCC or did you run the separate downloads?
 
They will only show in the CCC if they were installed via CCC
#11
aeigens
Max Output Level: -90 dBFS
  • Total Posts : 25
  • Joined: 2012/06/19 18:34:01
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/06 06:11:14 (permalink)
I can't activate it either on OSX 10.10.3
 
I download CC from CW site
I install CC
OS X asks for my password. I enter and say ok. I log in to CC and its Green.
I install one at a time . First the plugin then all the sound banks.
All is green except Legacy Content Pack Vol 1 and Concert Grand Harp Content Pack Vol 10. These are all 006 version in the downloads. i try manually installing them. they install but still red. 
I open Logic X while CC still open and green
Engage rapture pro on a track and its in demo :(
I delete everything , all hidden files, preferences and start again.
Same problem.
I delete the 2 red sound banks. Install again.
Same problem :(
 
I give up. I bought Omnisphere
 
Installation shouldn't waste you're time like that over activation. 
 
 
#12
Keith Albright [Cakewalk]
Max Output Level: -68 dBFS
  • Total Posts : 1117
  • Joined: 2006/07/10 15:44:42
  • Location: Boston, MA
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/06 10:52:37 (permalink)
Ok, there's some confusion here.  Speaking to OS X specifically...
C3 is required to setup some initial data on OS X.  So you must provide the system password to the dialog asking for permission to make changes.  Click cancel to that dialog and authorization will not work.  Subsequently if you don't allow permission, then silent installers won't work either (they require elevation to run). 
 
However, you don't have to uninstall/reinstall to try to get authorization working.  In fact, according to Apple guidelines, we do NOT have any authorization logic in the installers.
 
As far as authorization, that's handled in a separate process.  It's not necessary to have C3 open in order to authorize.  So to diagnose demo mode, you need to look at the about box and work with support to give them the code if any that appears.  We're working on a newer version of this process to fix the auth issues on 10.7/10.8 so expect things to improve very soon.  
 
There is currently a bug with some of the installers that are not correctly updating the data used by C3 to show the installation state.  To get the lights working does not require installation/reinstallation through C3.  It's supposed to work whether or not the packs are installed directly through C3 or by running the pkg files directly in the download directory.  In fact all C3 does is launch the pkg installers silently.  
 
As far as what's listed in C3?  Think of the UI of C3 as a connected download manager/installer.  The products that appear are connected products that you own.  You will likely own other products that are not listed for a few reasons.  1) it may be for a different platform, we only show OS X products on that os.  2) it may not be a connected product.  (Dimension Pro for example).  What causes products to appear is purchasing connected products.
 
We're hard at work addressing serious issues and will roll out an update for the various bits as they are sanctioned by QA.
 
Thanks for everyone's patience as we work to give you the great experience you deserve.
 
Best,
Keith Albright
Director of Development
 
 
 
post edited by Keith Albright [Cakewalk] - 2015/05/06 11:32:42

Keith
#13
Keith Albright [Cakewalk]
Max Output Level: -68 dBFS
  • Total Posts : 1117
  • Joined: 2006/07/10 15:44:42
  • Location: Boston, MA
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/06 11:33:10 (permalink)
azikiwezig
won't activate on OS X tried every daw from logic 9, logic x, studio one 2.6 machine 2.2.4 command centre may be the issue cakewalk help us in OS X 

If you are on 10.7 or 10.8 that could be the reason.  The code that was built for that had some dependencies on 10.9+ that we were not aware of.  I've rebuilt that natively targeting 10.7 and later, and we're testing it now. So it should work for 10.7, 10.8 as well as 10.9 and 10.10.1, 2., 3., +

Keith
#14
aeigens
Max Output Level: -90 dBFS
  • Total Posts : 25
  • Joined: 2012/06/19 18:34:01
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/07 03:16:01 (permalink)
For me its still an issue in 10.10. Its in demo mode and the serial says CWRP200-0.00-999999-999999 ( 2008,0) . Which isn't my serial. Ive deleted avery cakewalk file and folder , preferences and hidden. Reinstalled. still get the same issue.
 
#15
midi sentinel
Max Output Level: -90 dBFS
  • Total Posts : 4
  • Joined: 2015/01/11 07:00:48
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/07 16:58:02 (permalink)
I am having the same problem (on OSX 10.9.5). Also 2 red packs, no matter what I do or how I install them. Also can't register Rapture (Rupture, rather) Pro and it keeps running in demo mode.
 
6 nights ago, support has asked me for OS version and I haven't heard anything back from them.
 
You reckon there might be a fix for this issue sometime this year? Or should I come back and check next year?
#16
Dan Gonzalez [Cakewalk]
Administrator
  • Total Posts : 395
  • Joined: 2013/01/14 12:28:40
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/07 17:07:23 (permalink)
midi sentinel
I am having the same problem (on OSX 10.9.5). Also 2 red packs, no matter what I do or how I install them. Also can't register Rapture (Rupture, rather) Pro and it keeps running in demo mode.
 
6 nights ago, support has asked me for OS version and I haven't heard anything back from them.
 
You reckon there might be a fix for this issue sometime this year? Or should I come back and check next year?


We're putting together a patch for Rapture Pro ASAP. This will not take years to do - I can assure you that. 
-DG
#17
Jcrystal
Max Output Level: -90 dBFS
  • Total Posts : 6
  • Joined: 2015/01/02 01:15:38
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/07 17:45:48 (permalink)
Installing now. Rapture Pro opens fine in Numerology4, but immediately crashes Live 9. Running 10.9.5 on my Mac in 64-bit. It WORKS in Live 9 32 -bit. Any recommendations? Same happened for a while with Z3ta+2, deleted and reinstalled. Any reason to think that will help?
 
EDIT:
 
Deleted and reinstalled and then rebooted my computer and it worked for a while. Next time I ran Live 9/64 bit loading Rapture crashed it again. Support - please help!
 
EDIT AGAIN:  Seems related to the VST3 plugin. I reinstalled and it is now working (for the moment)
post edited by Jcrystal - 2015/05/12 10:44:47
#18
MUSE
Max Output Level: -87 dBFS
  • Total Posts : 173
  • Joined: 2005/09/04 18:45:48
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/07 19:58:08 (permalink)
Where do you find the update that fixes the folder delete bug in the installer? You would think Command centre would be able to notify you of updates.
#19
Andrew Rossa
Max Output Level: -56 dBFS
  • Total Posts : 1910
  • Joined: 2006/04/14 13:33:18
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/08 14:32:59 (permalink)
MUSE
Where do you find the update that fixes the folder delete bug in the installer? You would think Command centre would be able to notify you of updates.


We've replaced the installer with a new one in Command Center. 
#20
aeigens
Max Output Level: -90 dBFS
  • Total Posts : 25
  • Joined: 2012/06/19 18:34:01
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/08 22:07:42 (permalink)
Andrew Rossa [Cakewalk]
MUSE
Where do you find the update that fixes the folder delete bug in the installer? You would think Command centre would be able to notify you of updates.


We've replaced the installer with a new one in Command Center. 


Has this been done recently because in my CCC its still version 2.0.480 the one in the download folder so it just reinstalls that without downloading a new one.
#21
Grem
Max Output Level: -19.5 dBFS
  • Total Posts : 5562
  • Joined: 2005/06/28 09:26:32
  • Location: Baton Rouge Area
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/09 08:24:22 (permalink)
aeigens

Has this been done recently because in my CCC its still version 2.0.480 the one in the download folder so it just reinstalls that without downloading a new one.



Try deleting the installation package from the down load folder. That will force it to download the new one.

Grem

Michael
 
Music PC
i7 2600K; 64gb Ram; 3 256gb SSD, System, Samples, Audio; 1TB & 2TB Project Storage; 2TB system BkUp; RME FireFace 400; Win 10 Pro 64; CWbBL 64, 
Home PC
AMD FX 6300; 8gb Ram; 256 SSD sys; 2TB audio/samples; Realtek WASAPI; Win 10 Home 64; CWbBL 64 
Surface Pro 3
Win 10  i7 8gb RAM; CWbBL 64
#22
aeigens
Max Output Level: -90 dBFS
  • Total Posts : 25
  • Joined: 2012/06/19 18:34:01
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/09 09:15:06 (permalink)
Grem
aeigens

Has this been done recently because in my CCC its still version 2.0.480 the one in the download folder so it just reinstalls that without downloading a new one.



Try deleting the installation package from the down load folder. That will force it to download the new one.



At present it does not authorise on 10.10 OS X .
#23
Jcrystal
Max Output Level: -90 dBFS
  • Total Posts : 6
  • Joined: 2015/01/02 01:15:38
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/09 11:12:18 (permalink)
Any way to confirm what libraries have loaded or not? I used CC and all but 2 libraries now show green. Those two I've downloaded repeatedly, they say they succeeded, but then when I go back to the list they show red. How can I tell whether they are there or not?
#24
Doktor Avalanche
Max Output Level: -32.5 dBFS
  • Total Posts : 4294
  • Joined: 2015/03/26 18:02:02
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/09 12:33:52 (permalink)
There needs to be some sort of batch validator built into Rapture to show which libraries are broken. Sadly we don't have that functionality you have to test each sample 
#25
MUSE
Max Output Level: -87 dBFS
  • Total Posts : 173
  • Joined: 2005/09/04 18:45:48
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/09 12:50:34 (permalink)
Andrew Rossa [Cakewalk]
MUSE
Where do you find the update that fixes the folder delete bug in the installer? You would think Command centre would be able to notify you of updates.


We've replaced the installer with a new one in Command Center. 




So this isn't going to delete anything else in the same folder now? I just want to be sure as I'm having to install it to the root of my USB drive seeing as Rapture Pro also seems to have a problem with long paths for samples so I need to be able to trust it not to delete everything else.
#26
ascardoso
Max Output Level: -90 dBFS
  • Total Posts : 5
  • Joined: 2015/04/22 14:10:29
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/09 13:59:24 (permalink)
You are using Chromium, a browser framework to build CCC with. If you look at the error log from a run it will have error messages like these:
 
xxxxx:MacOS xxx$ ./nwjs
[2570:0509/105409:INFO:CONSOLE(531)] ""Translation for \"<username>\" not found in language pack: en"", source: file:///var/folders/7s/_d4qz7r95qj0ft3r9w3smwv00000gn/T/.org.chromium.Chromium.TMU5pv/js/libs/jquery-lang.js (531)
[2570:0509/105410:INFO:CONSOLE(0)] "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check ", source: (0)
 
You will find quite a bit more in the warncmd.txt log file in the same location.
 
And this is coming from a run of Rapture Pro itself:
11:21:02 (!) [ Start Up ] ERROR: unable to get value for key "C3 Path"
 
Can you provide a script to uninstall it from a system? 
 
Sergio
 
 
post edited by ascardoso - 2015/05/09 14:32:53
#27
widovanheemstra
Max Output Level: -90 dBFS
  • Total Posts : 3
  • Joined: 2015/04/30 16:18:20
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/09 15:22:47 (permalink)
My Logic Pro has problems opening Rapture Pro and Z3ta+ 2. As described above I did a reinstall to get te latest version with fixes. However I still cannot load these plugins. I have only tested this with the AU's can't say anything for the VST ones.
 
Below I attached the error message from Logic. Is it something I can solve or is it a bug?
 
validating Audio Unit Rapture Pro by Cakewalk:
AU Validation Tool
Version: 1.6.1a1
Copyright 2003-2013, Apple Inc. All Rights Reserved.
Specify -h (-help) for command options
--------------------------------------------------
VALIDATING AUDIO UNIT: 'aumu' - 'rpro' - 'CWSY'
--------------------------------------------------
2015-05-09 21:18:58.968 auvaltool[1359:497833] 21:18:58.968 WARNING: >compload> AudioComponentPluginLoader.cpp:445: ParseInfoPlistArray: RapturePro.component -- file:///Library/Audio/Plug-Ins/Components/: trouble parsing Info.plist's AudioComponents; entry: <CFBasicHash 0x7fb97c1015d0 [0x7fff73814ed0]>{type = mutable dict, count = 7,
entries =>
2 : <CFString 0x7fb97c10f840 [0x7fff73814ed0]>{contents = "manufacturer"} = <CFString 0x7fb97c107120 [0x7fff73814ed0]>{contents = "Cakewalk"}
7 : <CFString 0x7fb97c10f980 [0x7fff73814ed0]>{contents = "factoryFunction"} = <CFString 0x7fb97c10f9e0 [0x7fff73814ed0]>{contents = "AUWrapperFactory"}
8 : <CFString 0x7fb97c10bfd0 [0x7fff73814ed0]>{contents = "subtype"} = <CFString 0x7fb97c10fca0 [0x7fff73814ed0]>{contents = "rpro"}
9 : <CFString 0x7fff737e8400 [0x7fff73814ed0]>{contents = "description"} = <CFString 0x7fb97c10ef20 [0x7fff73814ed0]>{contents = "Rapture Pro Instrument"}
10 : <CFString 0x7fb97c10fce0 [0x7fff73814ed0]>{contents = "type"} = <CFString 0x7fb97c1102b0 [0x7fff73814ed0]>{contents = "aumu"}
11 : <CFString 0x7fb97c10fb20 [0x7fff73814ed0]>{contents = "name"} = <CFString 0x7fb97c10f130 [0x7fff73814ed0]>{contents = "Cakewalk: Rapture Pro"}
12 : <CFString 0x7fb97c1102f0 [0x7fff73814ed0]>{contents = "version"} = <CFString 0x7fb97c10ffa0 [0x7fff73814ed0]>{contents = "0x00020000"}
}
2015-05-09 21:18:58.978 auvaltool[1359:497833] 21:18:58.978 WARNING: >compload> AudioComponentPluginLoader.cpp:445: ParseInfoPlistArray: Z3TA+%202.component -- file:///Library/Audio/Plug-Ins/Components/: trouble parsing Info.plist's AudioComponents; entry: <CFBasicHash 0x7fb97ad0a360 [0x7fff73814ed0]>{type = mutable dict, count = 7,
entries =>
2 : <CFString 0x7fb97ad076a0 [0x7fff73814ed0]>{contents = "manufacturer"} = <CFString 0x7fb97ad0c840 [0x7fff73814ed0]>{contents = "Cakewalk"}
7 : <CFString 0x7fb97ad0c730 [0x7fff73814ed0]>{contents = "factoryFunction"} = <CFString 0x7fb97ad0c790 [0x7fff73814ed0]>{contents = "AUWrapperFactory"}
8 : <CFString 0x7fb97ad0c940 [0x7fff73814ed0]>{contents = "subtype"} = <CFString 0x7fb97ad0c980 [0x7fff73814ed0]>{contents = "samp"}
9 : <CFString 0x7fff737e8400 [0x7fff73814ed0]>{contents = "description"} = <CFString 0x7fb97ad0c5f0 [0x7fff73814ed0]>{contents = "Z3TA+ 2 Instrument"}
10 : <CFString 0x7fb97ad0ca40 [0x7fff73814ed0]>{contents = "type"} = <CFString 0x7fb97ad0ca80 [0x7fff73814ed0]>{contents = "aumu"}
11 : <CFString 0x7fb97ad0c8d0 [0x7fff73814ed0]>{contents = "name"} = <CFString 0x7fb97ad0c7f0 [0x7fff73814ed0]>{contents = "Cakewalk: Z3TA+ 2"}
12 : <CFString 0x7fb97ad0cac0 [0x7fff73814ed0]>{contents = "version"} = <CFString 0x7fb97ad0cb00 [0x7fff73814ed0]>{contents = "0x00020000"}
}
Manufacturer String: Cakewalk
AudioUnit Name: Rapture Pro
Component Version: 2.1.1 (0x20101)
Component's Bundle Version: 2.0.0
* * PASS
--------------------------------------------------
TESTING OPEN TIMES:
COLD:
Time to open AudioUnit: 5.983 ms
WARM:
Time to open AudioUnit: 0.076 ms
FIRST TIME:
FATAL ERROR: Initialize: result: -1

validation result: couldn't be opened
#28
hellfog
Max Output Level: -90 dBFS
  • Total Posts : 2
  • Joined: 2015/05/01 02:51:38
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/10 07:07:15 (permalink)
Is 2.0.480b the new version?, i tried it but still it says In demo mode.
 
ML 10.8.5.
post edited by hellfog - 2015/05/10 07:29:06
#29
gnosis123
Max Output Level: -90 dBFS
  • Total Posts : 2
  • Joined: 2015/03/22 15:45:54
  • Status: offline
Re: Response to issues with Rapture Pro 2015/05/11 16:45:51 (permalink)
Am still waiting, two weeks later, for a way to authorize RP on Mac OS 10.8.5. A week ago, CW support said a fix was imminent. Today they wouldn't even give me a time frame.
 
How hard can this be?
#30
Page: 1234 > Showing page 1 of 4
Jump to:
© 2022 APG vNext Commercial Version 5.1